Suzuki GSX-R Motorcycle Forums Gixxer.com banner
1 - 7 of 7 Posts

·
Registered
Joined
·
232 Posts
Discussion Starter · #1 ·
I've been looking through these forums left and right and I can't seem to find the solution to my 2015 750. My bike wouldn't start all of a sudden so I bought a new battery and that wasn't the problem. Then I watched a video on how a guy used a screwdriver on his Starter relay solenoid. I tried it and my bike started up just fine. I went ahead and bought it and that didn't work either and I still have to use the screwdriver to start it. Anymore out there have any other ideas as to what is wrong?

Here's the video of the guy I'm talking about.
 

·
Likes to race old junk.
Joined
·
2,935 Posts
Do you have a multi-meter or test light?
Do you have a service manual?...it has an electrical schematic to follow when troubleshooting.
Check for continuity in your start circuit wires.
Check for power at the start button...if so, then see if you have power going to the relay when you press the switch etc.
 

·
Registered
Joined
·
232 Posts
Discussion Starter · #5 ·
Do you have a multi-meter or test light?
Do you have a service manual?...it has an electrical schematic to follow when troubleshooting.
Check for continuity in your start circuit wires.
Check for power at the start button...if so, then see if you have power going to the relay when you press the switch etc.
 

·
Registered
Joined
·
232 Posts
Discussion Starter · #6 ·
I'll end having to take it to a shop. I don't have the time for all that since I work so much. I do thank you.
I was just hoping another rider that the same issue as I do.
 

·
Premium Member
Joined
·
7,706 Posts
You apparently can't read my post!! I did replace the relay and this isn't my video. WOW!!

* "
I've been looking through these forums left and right and I can't seem to find the solution to my 2015 750. My bike wouldn't start all of a sudden so I bought a new battery and that wasn't the problem. Then I watched a video on how a guy used a screwdriver on his Starter relay solenoid. I tried it and my bike started up just fine. I went ahead and bought it and that didn't work either and I still have to use the screwdriver to start it. Anymore out there have any other ideas as to what is wrong?

Here's the video of the guy I'm talking about." *

lol, funny, trolling??? if it says you replaced the starter solenoid I'm the man on the fuggen moon, get a grip dood, life's way too short...

fact is I'm having a hard time seeing where you say this isn't your video? clarity man, clarity... in any event why are you posting some whacked up garbage no one wants to see? c'mon man
 
1 - 7 of 7 Posts
Top