Suzuki GSX-R Motorcycle Forums Gixxer.com banner
1 - 18 of 18 Posts

·
Registered
Joined
·
10 Posts
Discussion Starter · #1 ·
I've been looking through these forums left and right and I can't seem to find the solultion to my gsxr 750 (L1). After a few minutes idling and between the Temps of 201-215 My bike suddenly shuts off. The gauge and electricity is still on and the fan too but the motor suddenly dies. No codes to show for it. Also, when I was on the hwy and did like 80 it suddenly shut off as well. If no codes to show for it, I began to think it may be mechanical. My fuel pump works cuz I can hear it prime once I switch it to on. What could it be guys? TIA! It is greatly appreciated.
 

·
Registered
L1 750
Joined
·
309 Posts
Just coz the pump primes doesn't mean it's flowing enough.
Do a pressure or flow test. Search it up on here.
If the bike shuts off but the dash, fan etc is still on then it sounds like it's stalling.
 

·
Registered
Joined
·
10 Posts
Discussion Starter · #3 ·
Just coz the pump primes doesn't mean it's flowing enough.
Do a pressure or flow test. Search it up on here.
If the bike shuts off but the dash, fan etc is still on then it sounds like it's stalling.
Very true. Didn't think about that. I hardly use it. It only has 5k miles on it. Could it be that the fuel filter is clogged? I've dissected the wiring and everything looks intact. I may have to prop out the fuel pump and check it out. I'll get back to you on that see if it really is the fuel pump. Thanks bro!
 

·
Registered
Joined
·
10 Posts
Discussion Starter · #6 ·
Does anything come up on the dash when it happens? Any FI light?
Nothing at all! I bought the suzuki oem switch for dealer mode (later found out you can do it with a simple wire lol) no codes show. No FI or "chec" comes out on the dash. I even left it there so when the bike shuts off suddenly the ecu won't erase it and STILL, codes say -c00. Everything looks legit. I researched a bit and it may be the IAT, IAP, or the TPS but they're all good. I doubt the spark plugs since I haven't rid it that much.
 

·
Registered
Joined
·
10 Posts
Discussion Starter · #9 ·
when it stalls does it says CHEC?
if the dash, lights still works when it stalls i would check: bad connection from the killswitch or the side stand switch.
Nope! It doesn't say "chec" nor the FI light turns on. It just suddenly dies. I'ma post some updates of what I've done in a bit...
 

·
Registered
Joined
·
10 Posts
Discussion Starter · #10 · (Edited)
Easily.

If you can't see anything up with the pump/filter,
Definitely test it.
Quick update!...so I took out the fuel pump. It looks in good condition. However, i went ahead and ordered a new fuel pump from quantum fuel systems. I cannot say the same thing about the filter lol. Have a look bro. This may be a stupid question but judging the looks of this filter, can it be possible it is the reason why it's shutting off?
 

Attachments

·
Registered
Joined
·
10 Posts
Discussion Starter · #12 ·
Possibly. Looks pretty manky. Definitely worth changing.
I'ma wait til the new fuel pump comes in and test it out. I have a few filters I ordered from ebay cuz the strainer alone cost and arm and leg. Hate to put the filter in and test just like that. So I'll just for the new fuel pump comes and install it. I'll keep you posted.
 

·
Registered
Joined
·
10 Posts
Discussion Starter · #14 ·
Possibly. Looks pretty manky. Definitely worth changing.
So I finally changed the filter and the fuel pump. The parts were from Quest fuel systems. I re-installed everything and the bike currently hasn't shut off! I'm a go test it in the hwy and see if it doesn't shut off.
 

·
Registered
Joined
·
8 Posts
i would still consider a bad killswitch or sidekick stand.
i first bypassed the sidestand sensor, it still shuts off random.
on my way home i pushed hard on the killswitch button and guess what, the bike stalls. repeated it few times and keeps stalling when pushing on the button.
i bypassed the killswitch red button. the bike never stalled again while riding
 

·
Registered
Joined
·
10 Posts
Discussion Starter · #17 ·
i would still consider a bad killswitch or sidekick stand.
i first bypassed the sidestand sensor, it still shuts off random.
on my way home i pushed hard on the killswitch button and guess what, the bike stalls. repeated it few times and keeps stalling when pushing on the button.
i bypassed the killswitch red button. the bike never stalled again while riding
After doing a thorough check, I finally found out what it was. I changed the spark plugs. The older ones looked so worn out. I mean, you didn't have to be a mechanic to see it. After I changed them, the bike felt different. Thr rpms didn't get twitchy while on idle nor did the bike shut off. After countless weeks of research. I had to rule those out and they were the culprit. My last resort was that maybe It could be that it needed a valve clearance but it didn't get to that point.
 
1 - 18 of 18 Posts
Top