Suzuki GSX-R Motorcycle Forums Gixxer.com banner
1 - 14 of 14 Posts

·
Registered
Joined
·
177 Posts
Discussion Starter · #1 ·
Here it is,it is an 03 750 ran good untill I did the air filter. I followed the directions K/N gives I let it dry in the sun 2 days,sprayed the oil let set day and a half. Now I put it all back together all the hoses and puges were where they need to be. I don't show any FI codes but when I put it in the dealer mod it shows the TPS is high. So when rideing at 8500 rpm it totally falls on it face and won't rev much higher, still no codes. Will the TPS being off do this? The TPS has never been messed with on this bike there are only 3100 miles on it. What kills me is that the bike ran fine before the air filter cleaning. and why now is it showing the TPS is off??????????????????????????????????? Any help THANX
 

·
Registered
Joined
·
180 Posts
Try unhooking the battery for a while and letting the computer reset. It may help, I always do it on my bike after changin anything motor related and it seems to help. I may be wrong, but someone correct me if I am.
 

·
Registered
Joined
·
1,475 Posts
Try a dry filter, such as stock. K+N oil screws up sensors etc.

Keith
Tractionless
 

·
Registered
Joined
·
179 Posts
how do you know if your dealer switch is on and how do you turn it off and where is it?
 

·
Registered
Joined
·
177 Posts
Discussion Starter · #6 ·
Will the K/N oil screw up th TPS That is the code I get C14.The thing that gets me is the bike ran great and the TPS was never messed with. Will the TPS being off make the bike not want to rev up past 8500-9000??????? And I pulled the jummper out of the dealer mode socket so I think I turned it off???????????????? Thanx.
 

·
Registered
Joined
·
96 Posts
Is the bar above or below center in dealer mode?
Maybe the screw was loose to begin with and it got knocked when u changed your filter.
Also if you have a PCIII your stock tps reading will be off, you have to check and adjust in PC software. Dynojet says it's normal
 

·
Registered
Joined
·
251 Posts
if you have a service manual and a multi meter just check the tps,,,,and yes if the tps is off it doesn't know how much fuel to give it......
 

·
Registered
Joined
·
951 Posts
KN oil won't hurt a thing. My filters are oozing oil and neither bike has ever had a problem. Your TPS is likely your problem not the filter.
 

·
Registered
Joined
·
177 Posts
Discussion Starter · #12 ·
I thought that I might of had too much oil and it sucked some in??? I didn't want too mess with the TPS because it was never touched from the factory,and ran good. But I guess I will have too now.
 

·
Registered
Joined
·
96 Posts
Remeber to check the tps when hot or it will read high because the cold start
cam pushes the butterflys up a little tll warm.

And your idle should be close to 1200 rpm.

I played around with diff. tps adjustments while trying to tune out a flat spot and
the bike never really ran badly at all just gave it hesitation.
 

·
Registered
Joined
·
177 Posts
Discussion Starter · #14 ·
at throttle the bike falls on it's face and dosn't want too rev up passed 8500-9000. If I let off a lil it will run the RPM's up.
 
1 - 14 of 14 Posts
Top