Suzuki GSX-R Motorcycle Forums Gixxer.com banner

1 - 20 of 35 Posts

·
Registered
Joined
·
19 Posts
Discussion Starter #1
Hey guys this is my first post finally snapped and joined the forum.

I have a k2 1000 swapped into a 750 frame and it was running great. Took pump off and cleaned filter reinstalled. Fired it up and let it idle for 10 minutes. Revved it up and everything was great.

Tore bike apart to fix fairings and battery tray. Reinstalled everything with a new battery. 2 months later.

Fired right up let it idle for 10 seconds and opened the throttle a bit and the bike died.

Primed pump a few times and tried starting it. Will not fire up. Brand new battery and it just keeps turning over. In neutral kick stand down. New fuel and I can hear the pump working.

Any ideas?

I will do an introduction thread later I really want to get this baby fired up lol
 

·
Registered
Joined
·
2,922 Posts
Looked in a repair manual? Read any of the thousands of threads available?
Probably not rite.......Be funny if nobody helps....Shit you most likely haven't done shit to help yourself...Why should anyone else?
Catch ya at the starting line...;Wink
 

·
Registered
Joined
·
19 Posts
Discussion Starter #3
LOL

I did do a search here and on gsxr but all I could find with these symptoms was an old srad that's carbed. I just ran out and tried again it fired up for a second and died. Maybe it isn't getting fuel and used whatever was left in the injectors.

I did notice the twist off gas cap I have was tight as fuck. Like under a vacuum or something.

Appreciate the help pal
 

·
Registered
Joined
·
2,922 Posts
Ok, well. Bullshit you searched. Wrong section if you did guy.
Whole trouble shooting section in a manual.
 

·
Registered
Joined
·
19 Posts
Discussion Starter #5
C23 is the code. The chec engine light came on the second time I tried to start it.

With the code I'll do some more searching. Thanks slow rider. Super helpful.
 

·
Registered
Joined
·
311 Posts
Wow 1slowrider can you help me now please! Lol. Eddyg have you checked the micro switch on the clutch lever ? And your battery and earth lead connections seing as you had the rear end apart?
 

·
Registered
Joined
·
311 Posts
Nice I got a gsxr 1000 k1 a zxr400L and a old dog zx6r the 400 is completely stripped I'm in the middle of restoring it ur srad is sweet I like the old school sports bikes
 

·
Registered
Joined
·
19 Posts
Discussion Starter #14
Wow 1slowrider can you help me now please! Lol. Eddyg have you checked the micro switch on the clutch lever ? And your battery and earth lead connections seing as you had the rear end apart?
I haven't checked the clutch. I basically removed the battery box. Just put the leads back on a brand new battery earth should be good. Lights work etc. It turns over hard and fast lol this C23 code I wonder why it just randomly showed up. Bike was fine 2 months ago
 

·
Registered
Joined
·
19 Posts
Discussion Starter #16
Forget it. I'll look elsewhere and repost when I have 2800 posts then I can be a piece of shit and look cool.
 
1 - 20 of 35 Posts
Top