Suzuki GSX-R Motorcycle Forums Gixxer.com banner

1 - 3 of 3 Posts

·
Registered
Joined
·
1 Posts
Discussion Starter #1
I really need help figuring out what the issue is with my bike.
I have a 2007 GSXR 600 with a full Yoshimura R-55 exhaust and Power Commander and the idle has been raised to 1300.

When I first start riding, the bike performs well but then every time I ease on the throttle to slow down or to come to a red light, the bike starts 'bucking and kicking and faltering'- it feels like I'm riding a horse. It'll feel like a jerking motion until I open the throttle again. There'll be times when I'm down shifting coming up to a red light and the bike just dies.

I've gotten my bike serviced for valves, got a new battery, cleaned the fuel injectors, relocated the rectifier, checked out the stator, and did and oil change. Thought that would've solved the issue but no, that wasn't it.

I took my bike to a dealership and one of the people there kept revving my bike and every single time it came back down to idle, my bike would just die. They tried messing around with the clutch but that didn't do anything. They quoted me $2k on fixing it but when I asked them what the problem is, they didn't even know.

I've tried asking around, some people said it could be the power commander or to raise my idle to 1800 or it could be the fueling system or a electrical issue with the fueling system. Please help me!!!

*Side note: I've never re-tuned by bike since I bought it- I kind of assumed the previous owner would've already gotten it tuned if he bought the power commander
 

·
Premium Member
Joined
·
3,498 Posts
Could be clogged vacuum lines. Try disconnecting IAP sensor's electrical connector. If bike runs better, then remove the vacuum lines and clean them.
 
1 - 3 of 3 Posts
Top