Suzuki GSX-R Motorcycle Forums Gixxer.com banner

1 - 6 of 6 Posts

·
Registered
Joined
·
5 Posts
Discussion Starter #1
So the other day I was coming back from a ride and my bike suddenly lost all power. The throttle wouldn’t respond but the dash was still on. I pulled over and saw smoke coming from under my seat (it turned out to be my battery). I thought my battery was toast so I put a brand new one in. Nothing. I also replaced a few mysteriously burnt fuses. Nothing. The fuel pump refuses to prime and the starter won’t turn over. Even with a bum stator/rectifier it should be able to achieve both of these things right? Days prior to this the bike was getting harder to start and I would smell sulfur every time I finished riding. I’ve looked around for something similar but can’t find anything that has to do with both a starter and fuel pump not working. If you have any idea what might be happening please let me know.
 

·
Registered
Joined
·
422 Posts
Re: Bike died mid-ride, won’t start

Sulphur is battery related imo. I'd check for a short somewhere. Bad rectifier/stator may have burnt your wire harness somewhere.

Great a bright light and go over your harness and/or electrical connections. I wonder if you burned out your ECU.
 

·
Hand-Eye Coordinator
Joined
·
6,529 Posts
You fucked your ECU.

All fuses, relays, and connections need to be checked, now.

You need to check your R/R and stator- at least one of them is knackered.

Next time, fix things when they become suspicious- otherwise, you will need to replace a lot more- like now.
 

·
Registered
Joined
·
4 Posts
Check all ur wire connectors mine kinda did the same thing without the smell and I had some connectors that were burnt so I just cut them and wired my wires together and now no problems and it's been almost 5 months and about 1500 miles since and still runs top notch for a 99 gixxer I ride it to work everyday. Good luck bro
 
1 - 6 of 6 Posts
Top