Suzuki GSX-R Motorcycle Forums Gixxer.com banner

1 - 4 of 4 Posts

·
Registered
Joined
·
411 Posts
Discussion Starter #1
Hi all,

Im after someone who know about the old Watercooled bikes in the south west (Wiltshire) that might be able to help me.
Ive got a wiring problem. well the main 30ampp fuse blows everyting its put in. Ive just got the bike back from the local dealer again. its been in every month for past 8 months.

Just wanted to see if any could help.

thanks
Garvey2003
 

·
Registered
Joined
·
411 Posts
Discussion Starter #3
The fuse is newish... I had a problem months ago with my ignition and blow the fuse then.
Its just come back from the dealers after getting the carbs sorted for the 8th time... Its been in the dealers every month for the past 8 months.. I was going to start a direct payment to them to save hassle. I think I might be abe to sort this out with out them lol


The expansion tank on the back of the bike had the lid missing and water was over the rear connectors for the rear light etc... do you think this could do with anything?

I have unplugged the CDI and took the rear lights off but still blows... I can put the fise in the start relay but as soon as I connect the top of it is blows... Its one thing after another on this bike... The soon I sell it the better..

I will have to go through all the wiring tomorrow after work and try to find the problem..
 

·
Registered
Joined
·
23 Posts
HI Garvey (cheers for the dynojet kit by the way). For my sins i'm an automotive vehicle electrician and believe me 99% of all electrical problems are down to corroded connections and poor earths. Give everything a good clean with light wet&dry and the grease it with something like vaseline (ooh er!)

Does it blow when 1:soon as you put it in
2:when you turn the ignition
3:when you try and start
4: intermitently

PS I'm down in Weymouth if you get really stuck give us an email and ill try and help, it's not that far away and it'll be a good excuse for a ride out
 
1 - 4 of 4 Posts
Top