Suzuki GSX-R Motorcycle Forums Gixxer.com banner
1 - 2 of 2 Posts

·
Registered
Joined
·
37 Posts
Discussion Starter · #1 ·
Have been getting a high RPM hesitation with my beast, 01 GSXR750. The bike is mint, no mods, and has always been treating good but this year after pulling it out of winter storage I have been getting this hesitation. Finally last night was able to coax the bike into giving me a FI code. Was C27 Ignition signal #4. I read in the manual to not to remove the coils without disconnecting the harness, for if you do you will damage the harness. Now when I changed the plugs last year I did NOT remove the plugs, but the coils still seemed to slip out just fine without doing so, it definitely didnt stress them too much or so I think. Has anyone ever heard of the harness getting damaged? I wonder if it is as bad as what the Service manual seems to indicate?

I have jumped thru MANY hoops trying to get this thing tip top again, but all the jumping has been for Nothing. This code is the first thing tangible I have gotten. I think if nothing else I am going to swap the #4 "troubled" coil with another cylinder and see if the code follows.... if not then I assume it IS harness related.

Any insight or similar experience notes appreciated..

Rob
 

·
Registered
Joined
·
37 Posts
Discussion Starter · #2 ·
Update to my problem:
Turns out is was valve adjustments, bike runs perfect now. My #4 cylinder had a couple intakes that were on the tight side of the spec (~.1mm) that I believe caused the problem... a few others I changed too just to get them all perfectly consistent like the others. Bike has 9500 miles and the manual says dont do valve adjustments till 15000 miles as why I ruled it out... but it was it... heheh

Rob
 
1 - 2 of 2 Posts
This is an older thread, you may not receive a response, and could be reviving an old thread. Please consider creating a new thread.
Top