Suzuki GSX-R Motorcycle Forums Gixxer.com banner

1 - 9 of 9 Posts

·
Registered
Joined
·
7 Posts
Discussion Starter #1
Kindof a two part stumper here. When i bought the bike it ran rough at idle. Dont have much experience with carbs but i figured itd be a simple rebuild job. I pulled the carb and took a look inside and it looks pristine, no gunk or deposit build up. Jets are all clear and all four diaphragms glide nice up and down. Next i looked at coils. They all tested fine and it isnt missing(replaced the plugs, the old ones werent so bad either). Still runs rough. Now to part two. When i bought it there was a small pinhole leak on the tank but it came with an extra so i cleaned it and swapped em. Now i can ride it for about five minutes and i lose all power as it slowly dies till the rpms hit zero. No response from giving it throttle during this. But it will sometimes jump and want to run as its dying. Then once i pull over ill have to wait 5-10 mins before itl fire right up amd run for another 5-10 mins. This was not an issue until i switched tanks. It is the same fuel pump. My only thought as of now is faulty fuel pump causing both problems?
 

·
Registered
Joined
·
7 Posts
Discussion Starter #6
Yea? Second tank..= gas tank.
You alright?
Yea just had a retard moment. I ordered new strainers and boutta to to the local shop to get a new inline. I really wanna rule anything out before i start ordering parts because i didnt realize they are kinda rare so expensive for this bike
 
1 - 9 of 9 Posts
About this Discussion
8 Replies
2 Participants
Blacksavath
Suzuki GSX-R Motorcycle Forums Gixxer.com
A forum community dedicated to the Suzuki GSX-R motorcycle. Discuss the GSX-R600, GSX-R750, GSX-R1000, and GSX-R1100, and more!
Full Forum Listing
Top