Suzuki GSX-R Motorcycle Forums Gixxer.com banner

1 - 5 of 5 Posts

·
Registered
Joined
·
14 Posts
Discussion Starter #1
Hello everyone My Name is Joe I'm happy to be apart of this site I have been going threw some forums to try and get a grasp of what's wrong with my bike so I decided to create my own. I hope everyone is as cool as I have been seeing. I have a 93 suzuki GSXR 750w Cali edition, I'm having problems with the start button and also I'm not getting any spark :cursing, so far I have check the safety switches and actually bypasses the side stand, i have check everuthing i can think of with a pocket meter replaced fuses and starter relay and just for measures I have purchased a ignitor box that's I should get on Saturday but one thing I have noticed beside no spark is the wires connected to the coils have no juice (brand new coils also) so if any one can help me figure this out I would be more then thankful...
 

·
Premium Member
Joined
·
24,541 Posts
Welcome :cheers

Please re-read forum descriptions,read the heading at the top of the pic below
 

Attachments

·
Ex-Lady Supermod
Joined
·
16,100 Posts
Moved to water cooled forum. Does the bike crank? Have you replaced levers or dropped bike on left side? Sounds like maybe clutch safety switch issue.
 

·
Premium Member
Joined
·
2,015 Posts
Do as Samantha suggests (clutch safety), re-check side stand, new cdi doesn't fix the problem,....chase the power wire coming of the signal advancer. That wire is prone to loosing its connection where it joins up with two other power wires in the harness.
 
1 - 5 of 5 Posts
Top