Suzuki GSX-R Motorcycle Forums Gixxer.com banner

1 - 3 of 3 Posts

·
Registered
Joined
·
1 Posts
Discussion Starter #1
21Gsxr1000r, got a full predator titanium exhaust, no 02 sensor, servo delete, Flash.
Bike is not holding a steady rpm, or it will hold it for a couple minutes then go back to fluttering. the rpm drop in N or 1st as well will sometimes lead to the engine cutting off.
Any advice?
block off plates are already on order.
I gots videos of the rpm flutter as well if that helps?
 

·
Registered
Joined
·
247 Posts
Surely that sounds like a fuel delivery problem or at least fuel/air problem. How long after you did the exhaust and flash did this start? If the answer is straight away, then it sounds almost obvious that there is what I suggested and that the flash might be the problem..
Other things to consider - All bolts done up tightly enough especially on exhaust, and there are no air leaks - Air filter is not overly dirty,, hopefully you DID put a filter in - All needed wiring is properly in place.
Always look of the most obvious first, even if it seems too small to have an effect.. Good luck - hope you get it solved...!!!

Al
 

·
Premium Member
Joined
·
166 Posts
21Gsxr1000r, got a full predator titanium exhaust, no 02 sensor, servo delete, Flash.
Bike is not holding a steady rpm, or it will hold it for a couple minutes then go back to fluttering. the rpm drop in N or 1st as well will sometimes lead to the engine cutting off.
Any advice?
block off plates are already on order.
I gots videos of the rpm flutter as well if that helps?
How did you do the flash? Take out ecu or install bike side harness?
When I installed my bike side harness initially, I messed up a couple of pins and it ran like shit when I started it up. Had to go back in and readjust pins and all was good.
 
1 - 3 of 3 Posts
Top