Suzuki GSX-R Motorcycle Forums Gixxer.com banner

1 - 5 of 5 Posts

·
Registered
Joined
·
2 Posts
Discussion Starter #1
Hey guys new to the forums. I have a 07 750 that has had a problem with power output since I got it 6 months ago. The bike only has 6500 miles. I just put a new fuel pump in, spark plugs, air filter, and a new ignition coil. Bike has full two brothers exhaust and power commander fc. Any ideas what it could be? I'm running out of ideas and it's really bothering me. Idles fine and only happens when on it hard. Does not pull to redline. Not letting me upload a picture for some reason?
 

·
Captain Obvious ... because obviously it’s obvious
Joined
·
3,922 Posts
Did you do any actual diagnostics before throwing those parts at it? What was your fuel flow test result? And your fuel pressure?
 

·
Registered
Joined
·
2 Posts
Discussion Starter #3
No not really other than putting it in dealer mode and checking tps. I decided to just swap the pump out with a new one instead of doing a flow test as I figured it's already an 11 year pump so why not. Is the fuel pressure test hard?
 

·
I know things... A lot of things.
Joined
·
3,172 Posts
If the replacement par is aftermarket then, it's an OEM 11 year-old unit, worth several hundred dollards with only 6500mi of service, vs a new cheap replacement unit worth several tens of dollars. Not necessarily an upgrade, depending on the condition of the OEM unit. If you replaced only the pump motor and not the whole assembly, then you also have the same high-pressure filter (and perhaps strainer) which is/are probably the source of the problem.

Finally the difference with making a measurement vs replacing the part (even if the latter is a good idea anyway), is that with the measurement you get a step ahead in troubleshooting regardless of outcome: you know it either is or isn't a fuel volume issue, for instance. On the other hand, replacing the part preemptively, is a gamble: if the problem is fixed, you know it was probably the part (although something in the replacement procedure might have just as likely been the real cause of the fix), If it didn't fix the issue, you don't really know much more.
 
1 - 5 of 5 Posts
Top