Suzuki GSX-R Motorcycle Forums Gixxer.com banner

1 - 12 of 12 Posts

·
Registered
Joined
·
28 Posts
Discussion Starter #1
Hi i have a 2007 GSXR 600 but i have to spin it 3 or 4x in the mornings for it to start. And also there is a smell of gasoline coming from the pipes.
Any ideas for me to check.
The bike is ALL stock, even down to the stock short pipe.
It still has the ECV connected also.

Thank you.
 
Joined
·
1,931 Posts
Make sure you gapped the plugs properly before putting them on. Dont trust the factory gapped ones. Whats your idle set at?
 

·
Registered
Joined
·
28 Posts
Discussion Starter #5
the idle is set to about 1500 rpm at start..
what should the gap be?
I just bought the new plugs and put them in. I did not change the gap at all.
to start i would typically turn on and off the kill switch like 3x i hear the fuel pump
prime up 3x then i would hit the start button. without any throttle...
but would have to do this like 3 or 4x in the morning.
after the engine has started
if i shut down. it start right back up.
but once its cold.. i have to go through that.
 
Joined
·
1,931 Posts
Spark plugs are usually pre gapped already, but sometimes they get bumped and close the gap. Factory recommends a 0.028 – 0.031 in gap. I would check those just to be on the safe side.

If you turn the key to the "on" position, then flip on the kill switch, do you hear the fuel pump priming at the first try? Or does it take a few tries to get it going?

Sounds like you might need a fuel pump or fuel filter.
 

·
Registered
Joined
·
28 Posts
Discussion Starter #7
yes everytime i turn on the kill switch with the key in the ON position.
I hear the fuel pump everytime.
i had taken the fuel pump out the tank and connected it
and i can see it spraying fuel with pressure.
 
Joined
·
1,931 Posts
Is the bike throwing any codes? It could still be the fuel filter that might be getting clogged up. Do you get any misfires while riding?

Get those plugs gapped and make sure the plug wires arent burnt or damaged. Then we can rule out spark.
 

·
Registered
Joined
·
28 Posts
Discussion Starter #9
I have 2 error code but have bought the sensors already just waiting to install them at this point. I got Engine Coolant Temp sensor code
and i got oil pressure sensor FI code.
I dont live in the US. So it takes a while for me to get stuff for my bike.
 

·
Hand-Eye Coordinator
Joined
·
6,529 Posts
the idle is set to about 1500 rpm at start..
what should the gap be?
I just bought the new plugs and put them in. I did not change the gap at all.
to start i would typically turn on and off the kill switch like 3x i hear the fuel pump
prime up 3x then i would hit the start button. without any throttle...
but would have to do this like 3 or 4x in the morning.
after the engine has started
if i shut down. it start right back up.
but once its cold.. i have to go through that.
so once it is started you immediately shut it off, and then it starts up again easily, or after it warms up?

swap your fuel. i would put $5 on bad fuel.
 

·
Registered
Joined
·
28 Posts
Discussion Starter #11
Once i get the bike started. If i shut it down immediately, and crank it. THe bike will start back no problem. Or if the bike starts i can take it for a ride for 40 miles. with no problem.
I use ONLY Premium fuel in my bike, i have a friend that has a 2007 GSXR 600 just like mine. He rides like 1x per month or 2 month. And we put in fuel at the same service station.
Even if his bike is sitting down for a month. And he goes to start it. It starts no problem.
I have another friend that has 2007 GSXR 1000. And he puts in fuel at the same place as me also. And his bike starts no problem. SO am not sure is fuel.
 

·
Registered
Joined
·
1 Posts
Once i get the bike started. If i shut it down immediately, and crank it. THe bike will start back no problem. Or if the bike starts i can take it for a ride for 40 miles. with no problem.
I use ONLY Premium fuel in my bike, i have a friend that has a 2007 GSXR 600 just like mine. He rides like 1x per month or 2 month. And we put in fuel at the same service station.
Even if his bike is sitting down for a month. And he goes to start it. It starts no problem.
I have another friend that has 2007 GSXR 1000. And he puts in fuel at the same place as me also. And his bike starts no problem. SO am not sure is fuel.
did you fix it bro? I have the same bike as you and the same exact problem like this, cold start is very hard but once its warm, the start is easier, but sometimes it’s hard to start again, could it be the immobilizer?
 
1 - 12 of 12 Posts
Top