Suzuki GSX-R Motorcycle Forums Gixxer.com banner

1 - 9 of 9 Posts

·
Rides dick , and a fully sick gixxer made of eBay
Joined
·
2 Posts
Discussion Starter #1
I was putting a new stator cover on because of a leak , then the bike wouldn't start, sounded like it didn't have enough power, so I got a brand new battery, checked the Ground changed the starter, I checked the stator and still nothing. My question is can a bad rectifier stop the bike from starting??
 

·
Moderator
Joined
·
16,989 Posts
I was putting a new stator cover on because of a leak , then the bike wouldn't start, sounded like it didn't have enough power, so I got a brand new battery, checked the Ground changed the starter, I checked the stator and still nothing. My question is can a bad rectifier stop the bike from starting??
Welcome to GDC.
This section is strictly for intros to the site.
Any help/repair questions should be posted over in the correct bike specific section.
 

·
Squid
Joined
·
3,564 Posts
So it worked before you took the cover off and not after you put it back on? Maybe you left something unplugged when you put it back on, or maybe the wires coming out of the stator cover have been damaged. They were on mine the last time I took it off, copper was showing so I had to put liquid electrical tape on the wires right where they come out of the rubber.
 

·
Hand-Eye Coordinator
Joined
·
6,509 Posts
Lemme guess... you bought a chinese cover and/or didn't use a gasket when installing it. THe R/R has nothing to do with starting the bike and you just spent a couple hundred replacing things that didn't need replacement. That cheap cover didn't save you much money at all.
 

·
Captain Obvious ... because obviously it’s obvious
Joined
·
3,843 Posts
Let me guess, you used RTV instead of a gasket.
 

·
Rides dick , and a fully sick gixxer made of eBay
Joined
·
2 Posts
Discussion Starter #6
My problem isn't the stator cover it is the fact that the bike is not starting, been using cheap stator covers for a while and no problem but I post a lil gasket maker by the wires. Just liked the different look the after markets provide.... I know I put it back together correctly. I think it's the rectifier cause the stator is fine.
 

·
Captain Obvious ... because obviously it’s obvious
Joined
·
3,843 Posts
Hey, check this out: didn't want people to see it, so he PMed me.

"I used the gasket that the cover came with. No need for sarcasm or smart remarks. The gasket has nothing to do with a no start condition"

He got the smart remark he wanted, thereafter. Lol

Fun fact, kiddo: I've been on here for quite a while and I've seen quite a few instances where a cheap covers, gaskets, and RTVs cause issues. Why? Because the stator rubs against it, which binds, and when it binds you don't get the proper voltage your bike needs to run. But, you'd have figured that out if you had bothered to search or waited and listened instead of whine and tell me about how you think it's something else without doing any actual diagnostic steps.
It's a pretty easy thing to eliminate, and it's something that people don't think about and drive themselves crazy trying to figure out. But, that's all the help you're getting from me. I don't waste my time on ungrateful people that expect everything from people in return for nothing, yet have the audacity to cry about not liking the exact phrasing.
 

·
Hand-Eye Coordinator
Joined
·
6,509 Posts
From my PMs:
Kdeezy817 said:
Yeah I spent money with new battery and starter that probably didn't need replacing so that's u I'm on here trying to find out what wrong with the bike smart ass
.. and that comment about cheap stator cover have nothing to do with the bike not starting like u said so if u have some constructive criticism, I'm for it and if no then stfu

My problem isn't the stator cover it is the fact that the bike is not starting, been using cheap stator covers for a while and no problem but I post a lil gasket maker by the wires. Just liked the different look the after markets provide.... I know I put it back together correctly. I think it's the rectifier cause the stator is fine.
You thought wrong. The R/R has NOTHING to do with the bike starting.

Isn't it funny that two of us knew right away that you were using cheap shit? Is it not funny that if you went through the threads similar to this, the answer was cheap shit?

You will not fix the issue until you get a new cover. Full stop.
 
1 - 9 of 9 Posts
About this Discussion
8 Replies
6 Participants
2017Dave
Suzuki GSX-R Motorcycle Forums Gixxer.com
A forum community dedicated to the Suzuki GSX-R motorcycle. Discuss the GSX-R600, GSX-R750, GSX-R1000, and GSX-R1100, and more!
Full Forum Listing
Top