Suzuki GSX-R Motorcycle Forums Gixxer.com banner

1 - 14 of 14 Posts

·
Premium Member
Joined
·
6 Posts
Discussion Starter #1
I bought a 2002 GSXR1000 a while back and now it seems that in 3rd gear and higher when you twist the throttle all the way open it bogs down but when you release the throttle alittle it accelerates. It just bogs down when you just yank the throttle all the way open. Any help would be great!!!!
 

·
Registered
Joined
·
138 Posts
Check your fuel filter. There is a simple test for how much gas you get out in a 30 second period. It's in the service manual. If you aren't getting much gas, you get no go at full-throttle.

My fuel filter gunked up around 50k miles. Back-flushing (dangerous) helped, but a new fuel filter fixed the problem.
 

·
Registered
Joined
·
1 Posts
I have a 2003 gsxr 1000 and I had the same problem. The factory fuel filter is very expensive.I fixed the problem by replacing the fuel pump assembly with a used unit from a 2008 gsxr 1000 with less than 5000 miles. The 2008 fuel filter is also cheaper to replace. You will have to remount your low fuel sending unit to the proper height and supply a ground to the sensor.Everything else bolts & plugs in. I have put over 11,000 miles on the pump assembly without any problems,even at top speed or leaned over in a corner. I have done high speed runs with the low fuel light on without fuel starvation.If you are interested in doing the swap I have pictures of the pump assembly before & after I mounted the low fuel sensor.
 

·
Registered
Joined
·
5 Posts
wasup ya'll
I had same problem on my gsxr 600 2003. on mien i had a little rusty tank fron inside that got caused by sitting for a year after previous guy crashed it. all what i did --- just pull a fuel pump out, disassamble it, clean all dust, durt and rust with tooth brush. make sure fuel filter clean. and assamble it back. make sure a white plastic clip on presure regulator sitting firm and tight.
Clean it up first, see if it helps --- save yourself couple bucks:cheers
 

·
Premium Member
Joined
·
952 Posts
Put it into deaaler mode and check for codes? Also check that the throttle postion sensor is good and adjusted correctly and check if the IAP sensor is connected and all other engine sensors as well.
 

·
Constantly in trouble now
Joined
·
16,403 Posts
If none of those work, check ALL of your vacuum lines and be SURE they're all connected in the right places.

Same with the fuel lines.

--Wag--
 

·
Non-Giver of F*ucks
Joined
·
258 Posts
Try removing the secondary butterflies an see if it helps. Or run the bike an rev to 5 or 6k an see if they open all the way. If not there is your problem

Sent from my DROID2 GLOBAL using Motorcycle.com App
 

·
Registered
Joined
·
3 Posts
have same problem need help!! bad! so i have a 06 gsxr 1000 full yoshi pipe k and n filter pc3 dyno tuned went to store everything ran perfect then at night its started bogging bad. i took out the second butterflies and took out pc3 completely. took it out still samthing took out the pump cleaned it and tank ran injector cleaner took it back out same damn thing at 11500 it throws fire at wide open throttle if i close it just a lil it will climb to redline but at full throttle it stops at 11500 like as if thats the red line help please!!
 
1 - 14 of 14 Posts
Top