Suzuki GSX-R Motorcycle Forums Gixxer.com banner
1 - 3 of 3 Posts

· Registered
Joined
·
1 Posts
Discussion Starter · #1 ·
Hi everyone! I don’t even know where to start with this but maybe I can get some help. So recently I bought a 2000 GSXR 600, started up fine and ran decent, rode her home about a 30 minute ride, everything was fine a little choppy in the lower rpm’s but needs a tune up, then the next day when I went to turn it on she didn’t budge, was just making a noise so then I figured out that the battery was trash, it was just a bad battery that was probably charged the night before so it start. So I got a new battery and put it in there and after a charge she started up and got going but the only issue was you had to keep the rev’s up with the clutch so it wouldn’t get to low and die. So after this I realized it was not the battery because even after fully charging the new battery it would still die if not rev’d enough. So then I started to think it was the alternator but I didn’t look into that either, also I am missing the main 50 fuse but that wouldn’t prevent the bike from starting. So then one night I didn’t give it enough throttle and it died like fully, no lights or anything and it’s been dead ever since. Could anyone give me any idea on what it could be? Maybe a bad wire somewhere or something along those lines? I’m not sure but anything would help. Thank you!❤
-Jay
 

· Registered
Joined
·
1,316 Posts
Start with the charging system, have you got a manual and a multi meter. Check all the wiring from the alternator for signs of corrosion\melting. You also need to find out about the main fuse, how they have bypassed it and why ( maybe your issue ).
 
1 - 3 of 3 Posts
This is an older thread, you may not receive a response, and could be reviving an old thread. Please consider creating a new thread.
Top