Suzuki GSX-R Motorcycle Forums Gixxer.com banner

1 - 6 of 6 Posts

·
Registered
Joined
·
29 Posts
Discussion Starter #1
Hi all, could really co with some help in trying to get a neutral light to work.

I've been rebuilding a UK 1991 1100m and all the electrics appear to be working ok with the exception of the neutral light.

I've checked the neutral switch which looks good, I metered between switch and ground theres a continuity in neutral and no continuity when in gear which is correct.

The sidestand switch appears good and the diode seems to check out, when I press the sidestand switch I can hear the relay clicking on and off.

I've metered the cabling to the neutral bulb and this appears all good and the bulb is all good, I've checked all fuses which are all good.

I'm at a loss as to what to try next, am I missing something? I really want the light working.

Appreciate any help.

Cheers
Liam
 

·
Uses squid tentacles as a butt-plug
Joined
·
262 Posts
You've checked continuity in the green indicator bulb in the cluster itself?
 

·
Uses squid tentacles as a butt-plug
Joined
·
262 Posts
Is there a gear position sensor on this bike ? I'm not familiar with this one in particular.
 

·
Registered
Joined
·
29 Posts
Discussion Starter #5
Yeah there is one mounted down by the front sprocket, I've disconnected this at the plug in connector and metered between the cable and ground, theres continuity in neutral which goes open circuit when in gear, I think this is the correct operation.
 
1 - 6 of 6 Posts
Top