Suzuki GSX-R Motorcycle Forums Gixxer.com banner
141 - 160 of 171 Posts

·
Premium Member
Joined
·
4,706 Posts
It is alive :punk

Ok, so last spring/summer after trying to help find some dry clutch parts for 86750LTD and after several conversations about the bike, I bought the LTD from him. I mean how often are you going to run across an 86 GSXR LTD (unless your Hans or Johnny :shifty )

Anyway, I carted of the 86 and fixed a few bits and pieces while trying to figure out how to fix that clutch cover. Thanks to Hans I have a cover to tide me over until I get one of Johnny's and I bought a clutch basket and used plates from EBay so I'm getting closer to actually riding the beast. It's been about a month since I last did anything other than dust the bike and last time I tried, I couldn't get her to fire up. I've never had it running.

Today I had a couple of spare hours so I pulled the carbs to figure out what was going on.
  • Two set of floats were stuck in the flooded position but as I actuated the throttle with the carbs off the bike and the bowls with residual gas I could see the accelerator pump was working.
  • One carb (#1) might have a plugged artery in the bowl but everything else looks great.
  • #2 carb was crammed on last time the carbs were services and the intake is somewhat distorted... I made sure it went on straight this time.
I cleaned them up, lubed em up and slapped them back on to see if it made a difference (airbox is not connected so open carbs). Imagine my surprise when it kicked as I turned it over... And that was with some old gas still in the cylinders (The gas tank was still off). On went my spare gas tank, I pulled the headlamp fuse and after a few cranks she fired up :biggrin

She runs pretty rough but holds an idle. I have no idea when she was run last but I would guess maybe ten years or so. It's been a good day :cheers
 

·
Premium Member
Joined
·
6,964 Posts
NICE!!! congrats, it's always good to hear them come to life after a long hibernation...
 

·
Premium Member
Joined
·
4,242 Posts
It is alive :punk

Ok, so last spring/summer after trying to help find some dry clutch parts for 86750LTD and after several conversations about the bike, I bought the LTD from him. I mean how often are you going to run across an 86 GSXR LTD (unless your Hans or Johnny :shifty )

Anyway, I carted of the 86 and fixed a few bits and pieces while trying to figure out how to fix that clutch cover. Thanks to Hans I have a cover to tide me over until I get one of Johnny's and I bought a clutch basket and used plates from EBay so I'm getting closer to actually riding the beast. It's been about a month since I last did anything other than dust the bike and last time I tried, I couldn't get her to fire up. I've never had it running.

Today I had a couple of spare hours so I pulled the carbs to figure out what was going on.
  • Two set of floats were stuck in the flooded position but as I actuated the throttle with the carbs off the bike and the bowls with residual gas I could see the accelerator pump was working.
  • One carb (#1) might have a plugged artery in the bowl but everything else looks great.
  • #2 carb was crammed on last time the carbs were services and the intake is somewhat distorted... I made sure it went on straight this time.
I cleaned them up, lubed em up and slapped them back on to see if it made a difference (airbox is not connected so open carbs). Imagine my surprise when it kicked as I turned it over... And that was with some old gas still in the cylinders (The gas tank was still off). On went my spare gas tank, I pulled the headlamp fuse and after a few cranks she fired up :biggrin

She runs pretty rough but holds an idle. I have no idea when she was run last but I would guess maybe ten years or so. It's been a good day :cheers
Well done ... keep it up !
 

·
Premium Member
Joined
·
4,706 Posts
Hey that's wierd... I thought I posted another message last night with a picture of her all stripped down and mismatched parts that would make crispone proud... Well here it is:
 

·
Registered
Joined
·
410 Posts
Looking Awesome andrew~! And plenty more time to complete her with the weather we've been having... It practically a blizzard @ SFU today.
 

·
Premium Member
Joined
·
4,706 Posts
Thanks man,
I just got back in from taking my best girl for breakfast and picking up some supplies for the house and yes it was snowing again :wtf

It's too warm over here for it to stick but it sure is bizarre.
 

·
Premium Member
Joined
·
4,706 Posts
Here you go Hans.... It's on my tube: http://www.youtube.com/watch?v=Pwy23X1_JIo

It's running and didn't even need the choke but really needs a good going over (ie: I need to rev her up and get rid of the cobwebs in the combustion chambers). She's not revving on all cylinders but might be idling on all 4 which leads me to think that the acceleration pump circuit is still clogged in #1. I have parts to fix that.

I put the clutch housing and hub back on with all of the associated bearings, sleeves, washers and seals but I'm short one spring and a couple of the bolts and spacers for the pressure plate (disk). I'll have to dig those up before I can put the plates back in and finish assembling the clutch.

Hans could be right... I may be riding the LTD this Spring :punk
 

·
Premium Member
Joined
·
4,242 Posts
Here you go Hans.... It's on my tube: http://www.youtube.com/watch?v=Pwy23X1_JIo

It's running and didn't even need the choke but really needs a good going over (ie: I need to rev her up and get rid of the cobwebs in the combustion chambers). She's not revving on all cylinders but might be idling on all 4 which leads me to think that the acceleration pump circuit is still clogged in #1. I have parts to fix that.

I put the clutch housing and hub back on with all of the associated bearings, sleeves, washers and seals but I'm short one spring and a couple of the bolts and spacers for the pressure plate (disk). I'll have to dig those up before I can put the plates back in and finish assembling the clutch.

Hans could be right... I may be riding the LTD this Spring :punk
The link tells me: we're sorry, this video is no longer available :scratch:sad
 

·
Premium Member
Joined
·
4,706 Posts
The link tells me: we're sorry, this video is no longer available :scratch:sad
Well that's weird.... It plays fine for me and looks like it has been viewed 21 times since I put it up yesterday... It's the first video I've posted on YouTube so maybe I did something wrong.
 

·
Premium Member
Joined
·
6,964 Posts
I just watched it... deff got a limping cyl. But it runs!!!!!
 

·
Premium Member
Joined
·
4,706 Posts
Just give the carb bowls a smack with the soft end of a swrew driver or small rubber mallet. Sounds like it has a sticking float. The old Flatslide Syndrome.
I freed up the floats when I had the carbs off. Two of them were definitely frozen but they unstuck pretty easily.

I think the passage from the acc pump to the carb in the bowl for #1 is plugged... The passage to the next carb (via the little rubber hose) is fine but I don't think #1 is getting a spray of gas when the carb opens up. I'll grab one off my spare set and see if it works.
 

·
Premium Member
Joined
·
4,242 Posts
Here you go Hans.... It's on my tube: http://www.youtube.com/watch?v=Pwy23X1_JIo

It's running and didn't even need the choke but really needs a good going over (ie: I need to rev her up and get rid of the cobwebs in the combustion chambers). She's not revving on all cylinders but might be idling on all 4 which leads me to think that the acceleration pump circuit is still clogged in #1. I have parts to fix that.

I put the clutch housing and hub back on with all of the associated bearings, sleeves, washers and seals but I'm short one spring and a couple of the bolts and spacers for the pressure plate (disk). I'll have to dig those up before I can put the plates back in and finish assembling the clutch.

Hans could be right... I may be riding the LTD this Spring :punk
O.K. seen and heard it now, works fine at home ( must be protected at work )
 

·
Premium Member
Joined
·
4,242 Posts
YES :drool :cheers Yes :cheers YES :punk :drool :drool :drool:burnout:burnout
 

Attachments

·
Premium Member
Joined
·
4,706 Posts
Hans :wtf

How is it that you have all of these photos of unobtainable GSXR LTD & RK stuff? Oh, that and that huge stable of bikes :eek:hmy

Just seeing those plates made my pulse quicken. Nice :biggrin
 

·
Premium Member
Joined
·
4,242 Posts
Hans :wtf

How is it that you have all of these photos of unobtainable GSXR LTD & RK stuff? Oh, that and that huge stable of bikes :eek:hmy

Just seeing those plates made my pulse quicken. Nice :biggrin
I bet ... soon I can put 'm around my pulse(s) ... :lol

Tomorrow I will pick up a NOS upper for a 86 Limited Edition :cheers
 

·
Premium Member
Joined
·
4,706 Posts
I bet ... soon I can put 'm around my pulse(s) ... :lol

Tomorrow I will pick up a NOS upper for a 86 Limited Edition :cheers
Cool :biggrin

One of these days I'll be looking for a NOS upper, right side mid and maybe a belly but for now I'm just happy to be able to get her on the road this year. Thanks for your help :cheers
 
141 - 160 of 171 Posts
Top