Suzuki GSX-R Motorcycle Forums Gixxer.com banner
1 - 20 of 22 Posts

·
Registered
Joined
·
27 Posts
Discussion Starter · #1 ·
Hey guys, so I have a k7 600, 14k miles and im having issues with it turning over. Apparently I had a bad ecu, (bike died when riding, all lights n everything died, wouldnt start) so I got it replaced with one that was tested n used. I put it in, and the bike turned over!!! Only problem was that the tac was dead, got no response except for hi beam indication, hazards, and a neutral indicator. When I turned my bike off after the first start, it dies and wont turn back over. I hooked the battery up to a tender, charged it all the way up, and when I put it in the bike it worked. It only worked for the first startup after being fully charged and now it wont completely turn over. Im really confused and cant seem to find any decent info on similar issues online. Can anyone help?
 

·
Premium Member
Joined
·
5,779 Posts
check all your wiring for bent corroded destroyed pins so forth, celan em all up, you can get new pins I've seen em do it on cars should work for bikes, if not then you have to start checking each component wire by wire, testing load, ohm, volts leakage all that, electrical isn't always fun but check your connectors first clean check for bad pins and hen pack with dielectric grease
 

·
Registered
Joined
·
27 Posts
Discussion Starter · #5 ·
Are you sure it's a 'good' battery?
When was the last time the bike ran correctly?
So when my bike died the first time I went to get a new battery. The old one had the plastic lid like ripped off. Only problem was bike still wouldnt start, so the new battery sat unused for about a month and a half until I got a new ecu, and charged the battery.
 

·
Premium Member
Joined
·
910 Posts
Battery lid ripped off ? This sounds like the battery was over charging and exploded.
What does your Regulator Rectifier test at ? Keep your old ECM they rarely fail.
 

·
Registered
Joined
·
27 Posts
Discussion Starter · #7 ·
Yeah I could look into the hole on the top of the battery, still got the old ecu, and I haven't tested the rectifier yet!
 

·
Registered
Joined
·
27 Posts
Discussion Starter · #8 ·
Battery lid ripped off ? This sounds like the battery was over charging and exploded.
What does your Regulator Rectifier test at ? Keep your old ECM they rarely fail.
Battery lid ripped off ? This sounds like the battery was over charging and exploded.
What does your Regulator Rectifier test at ? Keep your old ECM they rarely fail.
Yeah I could look into the hole on the top of the battery, still got the old ecu, and I haven't tested the rectifier yet!
 

·
Premium Member
Joined
·
910 Posts
This thread jumps to a new heading.
K7 GSXR 600 Rectifier Wire fried/wire identification
?
 

·
Registered
2006 GSX-R 600
Joined
·
585 Posts
Is the fuel pump priming? Will the motor crank? Getting 12v at the positive side on the starter when you hit the starter button? Speedo power up and run through its cycle?


Sent from my iPhone using Tapatalk
 

·
Registered
Joined
·
27 Posts
Discussion Starter · #12 ·
Is the fuel pump priming? Will the motor crank? Getting 12v at the positive side on the starter when you hit the starter button? Speedo power up and run through its cycle?


Sent from my iPhone using Tapatalk
speedo not powering and running thru the its cycle
 

·
Premium Member
Joined
·
5,779 Posts
what all have you done? have you tried auxiliary power like jumping from a car? if yes and no go have you checked all the fuses, the main in back by the starter relay, check em all.. inspect wiring everything related, connectors, clean and pack..

if not that's your next step if you haven't already you say you got a new battery but didn't post results.. have you thrown it off the bridge or?
 

·
Premium Member
Joined
·
5,779 Posts
he needs to troubleshoot if its battery or? rule that out first, odds are it wont even crank but sometimes batteries can appear charged by the charger but not have enough amps to crank.. he needs to systematically rule out possibilities, simplest to the more difficult.. like suddenly when your bike won't turn over the first thing you check is the on/off switch... lol

been there done that...
 

·
Registered
Joined
·
245 Posts
So, when you turn the key, are you getting any lights?

Check all your fuses in the fuse box. As far as I know, the "Signal 15A" fuse powers up the dash.
Also, there is a big connector under the left side fairing that connects to the dash. Check for burnt
wires, bad contact or corrosion here.

Then, once the dash is on, tell us what it says. "CHEC" or "FI" or "Temp".

Also, does the starter motor work?
 

·
Registered
2006 GSX-R 600
Joined
·
585 Posts
also can try push starting it from 2nd gear and dump the clutch
 
1 - 20 of 22 Posts
Top