Suzuki GSX-R Motorcycle Forums Gixxer.com banner

1 - 5 of 5 Posts

·
Registered
Joined
·
1 Posts
Discussion Starter #1
Im at loss trying to trouble shoot this issue,So bike was running fine then died..When I tried to start again I noticed the fuel wasnt priming there for will not start.i checked the fuses an my fuel fuse was blown I changed it and still no prime.i check the "run stop" switch its good. I bought a new fuel relay and still nothing... So i checked power to relay that is good, i checked power to fuel pump that is good. I checked the fuel pump that is good. Then I found this, I hope the picture uploads. I dont know what this is.i am assuming this could be the problem since my relay isnt clicking which would mean my circuit isnt get back to where it needs to be
20200620_154906_HDR.jpg
, I could use some help on how to either fix it in a sense .
572491
 

·
Premium Member
Joined
·
325 Posts
Im at loss trying to trouble shoot this issue,So bike was running fine then died..When I tried to start again I noticed the fuel wasnt priming there for will not start.i checked the fuses an my fuel fuse was blown I changed it and still no prime.i check the "run stop" switch its good. I bought a new fuel relay and still nothing... So i checked power to relay that is good, i checked power to fuel pump that is good. I checked the fuel pump that is good. Then I found this, I hope the picture uploads. I dont know what this is.i am assuming this could be the problem since my relay isnt clicking which would mean my circuit isnt get back to where it needs to be View attachment 572491 , I could use some help on how to either fix it in a sense . View attachment 572491
I’m having a similar issue with my 07 750..no spark on start at all. Had to bump start it all day last track day.

If I were you I’d go on a parts fiche and figure out what that is and then figure out how to replace it.

Www.partzilla.com


Sent from my iPhone using Tapatalk
 

·
Dreaming of buttsecks for years...
Joined
·
13,842 Posts
That looks like the main ground link. It basically has that big connector down the middle that links all the grounds together. You could essentially just cut that connector out and strip about 2" from the wires and solder it all together.
 

·
Registered
Joined
·
4 Posts
I was having an issue with my fuel pump fuse blowing...ended up changing out the EFI computer...found a good used one on ebay for $400. problem solved
 
1 - 5 of 5 Posts
Top