Suzuki GSX-R Motorcycle Forums Gixxer.com banner

1 - 3 of 3 Posts

·
Registered
Joined
·
1 Posts
Discussion Starter #1
Hey I just made this account because I’m constantly checking it out. Anyways. I have an 07 gsxr 750 I just got 3 days ago. And and I’m realizing now the cluster isn’t showing the correct gears when shifting. Or sometimes shows nothing at all. Also my speed isn’t accurate at all it shows at least 10 - 15 mpg faster than what I’m really going. And I’m losing power and it’s jumpy. Please someone help me figure this out!!!
 

·
Ex-Lady Supermod
Joined
·
16,100 Posts
Hey I just made this account because I’m constantly checking it out. Anyways. I have an 07 gsxr 750 I just got 3 days ago. And and I’m realizing now the cluster isn’t showing the correct gears when shifting. Or sometimes shows nothing at all. Also my speed isn’t accurate at all it shows at least 10 - 15 mpg faster than what I’m really going. And I’m losing power and it’s jumpy. Please someone help me figure this out!!!
You sound like you have numerous issues. Your gps may be going out, dirty, loose or all. The jumpy could be a maladjusted TPS or the dreaded "herky jerky". As for your bike being 10-15 miles per gallon faster, not sure how to address that?
 

·
Hand-Eye Coordinator
Joined
·
6,529 Posts
WRT your gear position- your gear position sensor sounds broken. Inspect it and replace it if needed.

As for speed being off- how many teeth on the front sprocket, and how many on the rear? it should be 17 and 45.

As for being jumpy and losing power- you need to provide more details. Explain when it happens and what happens.
 
1 - 3 of 3 Posts
Top