Suzuki GSX-R Motorcycle Forums Gixxer.com banner

1 - 4 of 4 Posts

·
Registered
Joined
·
3 Posts
Discussion Starter #1
whats up. new to this site

i searched and read multiple threads but none help my issue
the rectifier went out and fried a bunch of stuff
the throttle body actuator turns on and the fan relay clicks when i turn the key to on position

bike will crank but not start because the fuel pump will not prime.

i put 12v direct to the pump and it turns on and puts out fuel.

i swapped the fan relay with the fuel pump relay and still the same issue.
so the relays are working.

here is what was replaced
ECU
rectifier
stator
cluster
wiring harness
ignition switch resistor (was giving code c42 because the resistor was burnt)
all fuses checked and good

what else can i test?

something is not sending voltage to the fuel pump relay
 

·
I know things... A lot of things.
Joined
·
3,133 Posts
What makes you sure it's the fan relay that clicks? Does the fan run? If so, might it be that you've mixed up the fan and pump relays when you connected the new harness?
 

·
Registered
Joined
·
3 Posts
Discussion Starter #3
when i turn the key to the on position the relay clicks.
i swapped both relays and the pump still does not prime even though the relay clicks
 

·
I know things... A lot of things.
Joined
·
3,133 Posts
I understand a relay clicks, but how/why are you sure it's the fan relay and not the pump relay? And if it's the fan relay, why does the fan not start?
 
1 - 4 of 4 Posts
Top