Suzuki GSX-R Motorcycle Forums Gixxer.com banner
1 - 15 of 15 Posts

·
Registered
Joined
·
8 Posts
Discussion Starter · #1 ·
\'05 speed limiter

Which wire is the magic one to cut to disable the speed limiter on my '05 gsxr-1000?
 

·
Chubby Chaser
Joined
·
57,844 Posts
Re: \'05 speed limiter

The one that is wired to the speedometer.
 

·
Registered
Joined
·
1,888 Posts
Re: \'05 speed limiter

It is a little more complicated that the old bike. There are many people that will sell the 01-04 job that fits in the harnass under the tank. Believe me that this no longer works. All the signs are right. The gear indicator goes to 5th gear but a whole lot of other things also happen. For example, you cannot start the bike with the side stand out. I does not matter whether it is in gear or not, it will not start. You have to sit on the bike. In addition the neatral light does not work but finally, the real kicker is that the thing goes into limp mode and you loose a ton of HP. The only way to do it on the 05 is the cut the pink wire at the ECU and solder in a 6.8 k ohm resistor to the 'in' end of the pink wire and the black ground wire on the end on the ECU plug. Better still, put a 2 way switch in line so that you can get the gear indicator functionality all the time until you switch the resistor on.

Nigel.
 

·
Premium Member
Joined
·
176 Posts
Re: \'05 speed limiter

Nigel - thanks for the info, I'm hoping you can put up with a few questions because I'm trying to get my '05 race prepped and need to figure this crap out! Do you have any pics of what you did with the resistor? Also, how do you know the TRE puts it into limp mode, do you get an FI error or did you see it on the dyno? One more question - is there truly a speed limiter in 6th on the '05's, and if so, do you think disconnecting the speedo wire take care of it? or does the 6.8k ohm resistor only remove the timing retard in 1st - 4th? Thanks again for your great input!
Dan

It is a little more complicated that the old bike. There are many people that will sell the 01-04 job that fits in the harnass under the tank. Believe me that this no longer works. All the signs are right. The gear indicator goes to 5th gear but a whole lot of other things also happen. For example, you cannot start the bike with the side stand out. I does not matter whether it is in gear or not, it will not start. You have to sit on the bike. In addition the neatral light does not work but finally, the real kicker is that the thing goes into limp mode and you loose a ton of HP. The only way to do it on the 05 is the cut the pink wire at the ECU and solder in a 6.8 k ohm resistor to the 'in' end of the pink wire and the black ground wire on the end on the ECU plug. Better still, put a 2 way switch in line so that you can get the gear indicator functionality all the time until you switch the resistor on.

Nigel.
 

·
Premium Member
Joined
·
176 Posts
Re: \'05 speed limiter

I checked out the website, and pardon my ignorance, but what's the difference between the JSD-1 (unswitched) and JSD-2 (switched)?

JSD-2 is exactly what you need
 

·
Chubby Chaser
Joined
·
57,844 Posts
Re: \'05 speed limiter

I checked out the website, and pardon my ignorance, but what's the difference between the JSD-1 (unswitched) and JSD-2 (switched)?

JSD-2 is exactly what you need
Switched means you can turn it on and off. Unswitched means it's on all the time.

See?
 

·
Registered
Joined
·
1,888 Posts
Re: \'05 speed limiter

Nigel - thanks for the info, I'm hoping you can put up with a few questions because I'm trying to get my '05 race prepped and need to figure this crap out! Do you have any pics of what you did with the resistor? Also, how do you know the TRE puts it into limp mode, do you get an FI error or did you see it on the dyno? One more question - is there truly a speed limiter in 6th on the '05's, and if so, do you think disconnecting the speedo wire take care of it? or does the 6.8k ohm resistor only remove the timing retard in 1st - 4th? Thanks again for your great input!
Dan

It is a little more complicated that the old bike. There are many people that will sell the 01-04 job that fits in the harnass under the tank. Believe me that this no longer works. All the signs are right. The gear indicator goes to 5th gear but a whole lot of other things also happen. For example, you cannot start the bike with the side stand out. I does not matter whether it is in gear or not, it will not start. You have to sit on the bike. In addition the neatral light does not work but finally, the real kicker is that the thing goes into limp mode and you loose a ton of HP. The only way to do it on the 05 is the cut the pink wire at the ECU and solder in a 6.8 k ohm resistor to the 'in' end of the pink wire and the black ground wire on the end on the ECU plug. Better still, put a 2 way switch in line so that you can get the gear indicator functionality all the time until you switch the resistor on.

Nigel.
It is restricted only in 5th. It will pull 13500 on the rev counter. Once de-restricted it will pull 14000 provided you have shorted gearing or more power as a stocker will certainly not pull de-restricted top-end with stock gearing in 6th. I am sorry I don't have a diagram. I could perhaps draw something.

Nigel.
 

·
Registered
Joined
·
787 Posts
Re: \'05 speed limiter

Nigel, thanks for the info..However, it sounds rather complex to the average "non mechanic". Derestricted, the bike should be good for high 190s..think?
 

·
Chubby Chaser
Joined
·
57,844 Posts
Re: \'05 speed limiter

Nigel, thanks for the info..However, it sounds rather complex to the average "non mechanic". Derestricted, the bike should be good for high 190s..think?
Stock gearing is 204 on the K5 if I remember correctly.
 

·
Registered
Joined
·
382 Posts
Re: \'05 speed limiter

I don't like the idea of the "limiter". It's okay to go 186 but not 187? hmm... Might have to check into this JSD thingy.
 

·
Registered
Joined
·
8 Posts
Discussion Starter · #15 ·
Re: \'05 speed limiter

Nigel,

your insrtuctions are a little ambiguous.... Cut the pink wire...check solder one end of the resistor to the pink wire coming from the ecu and the other end to the black wire going into the harness? Do you cut the black wire also?

SO far, I cut the pink wire and the black/white wire.... actually pushed the pins out of the connector going to the engine by the countershaft sprocket (that general area) It perform excellent now, huge difference, but, no gear indicator on the dash and stalls when the stand is down even in neutral, and no neutral light.....

I figure I could jump the side stand safety switch to fix the stall thing, but I would like to have a neutral light.... any ideas?

ALSO..... I bypassed the pair valve.... now I have a constant FI light..... Should I just plug the pair valve back in the electrical connector even though the vent hoses don't run through it? or can I just jump the wires on the harness?

Any info is greatly appreciated.....

And as I said, what a huge difference!!!!!! Now it runs strong in the first few gears, carries the tire by 5,000 rpm in 1st while rolling on....
 
1 - 15 of 15 Posts
Top