Suzuki GSX-R Motorcycle Forums Gixxer.com banner
1 - 7 of 7 Posts

·
Registered
Joined
·
56 Posts
Discussion Starter · #1 ·
Hey what's up everyone. I have had this bike for two maybe three months and have yet to get on it. Tonight on the way I decide to try to take to 90 mph in third but I left like I hit a limiter. Maybe I did throttle all the way down but it just didn't feel right. Any ideas? A little history on the bike. I bought used and it was previously wrecked. I bought it running good. Motor ran good but cosmetic needed help. I already replaced windscreeen, mirrors, new cluster and Honda 954rr tailight. The bike really needs a new pipe cause the can on there is all bent and beat up. It's got a yoshi header so I just need the can. The last cluster tach was not working. This cluster is telling me I have a FI code. All help is welcome.
 

·
Registered
Joined
·
82 Posts
did this and the code that came out was c28 and c29
well, that would be the secondary throttle postion sensor and the STV actuator-- check that the harness is still hooked into each, an that the wiring isnt damaged. They both feed into the harness beside one another-- so there is a chance its a simple fix (keep your fingers crossed!)
 

·
Registered
Joined
·
56 Posts
Discussion Starter · #6 ·
guys i just replaced the STVA and i still am having that code. its really wierd. i can rev to 12grand while not in gear. while in gear i will not pass 8-9grand. i dont know what else
 

·
Registered
Joined
·
56 Posts
Discussion Starter · #7 ·
still got the same damm problem. i tried adjusting the sensors on there, moving cables around to see if maybe there was a pintched cable, i even put on a new fuel rail with different injectors and different wiring and still same shit. only thing i did find out is that i am not getting the correct voltage to the STPS. but i dont know what else to do or how to fix it
 
1 - 7 of 7 Posts
Top