Suzuki GSX-R Motorcycle Forums Gixxer.com banner

1 - 4 of 4 Posts

·
Registered
Joined
·
2 Posts
Discussion Starter #1
I have a project bike I've put together and I can't get it to stay running. Here is the rundown on what is happening and what I've troubleshot so far.

Turns over and starts up for about 5 seconds, if you give it gas it dies.

What I've looked at/replaced:
-fuel pump, verified it worked and the pressure was correct. Disassembled fuel pump and cleaned thoroughly.
-new injectors (old were clogged), verified new injectors are firing
-dealer mode to verify no codes
-fuel rail is not clogged
-fuel line is working/good condition
-checked the pin in the ECU that controls the fuel injectors, no visible issue

I didn't keep a list of everything I've done but I believe I have listed nearly everything. I've scoured the forums and tried anything that seemed relevant. Any suggestions as to what else I can try to get this to stay running is appreciated.
 

·
You should listen to me. No, seriously, listen to
Joined
·
7,559 Posts
You didn't mention doing a flow test on the fuel pump. Did you? It's more important than the pressure test. Alternately, but harder to do, measure the pressure in the fuel line during the 5 seconds that the bike is running.
 

·
Registered
Joined
·
2 Posts
Discussion Starter #3
You didn't mention doing a flow test on the fuel pump. Did you? It's more important than the pressure test. Alternately, but harder to do, measure the pressure in the fuel line during the 5 seconds that the bike is running.
Yes, I did a flow test. I've gone over so many things it was hard to remember them all. I'll see if I can do as you suggested with the pressure when it runs for that split second. Thanks.
 
1 - 4 of 4 Posts
About this Discussion
3 Replies
3 Participants
dpapavas
Suzuki GSX-R Motorcycle Forums Gixxer.com
A forum community dedicated to the Suzuki GSX-R motorcycle. Discuss the GSX-R600, GSX-R750, GSX-R1000, and GSX-R1100, and more!
Full Forum Listing
Top