07 gsxr 750 oil pressure dropping at low revs when hot - Suzuki GSX-R Motorcycle Forums Gixxer.com

 
LinkBack Thread Tools Display Modes
post #1 of 7 (permalink) Old 07-22-2019, 05:36 AM Thread Starter
Squid
 
Join Date: Jul 2019
Posts: 4
07 gsxr 750 oil pressure dropping at low revs when hot

I had been doing a lot of riding during the day and she was fine. I had then stopped for a couple hours and then set off to go home. once the engine was hot and I was cruising at around 60mph, if I pulled the clutch in for too long and the revs dropped low the oil pressure warning light would come on and the engine would start to run rough. As soon as I engaged a gear she was fine again.

Any advice please

Cheers

Chris
Chrisgill89 is offline  
Sponsored Links
Advertisement
 
post #2 of 7 (permalink) Old 07-22-2019, 10:40 PM
You should listen to me. No, seriously, listen to me.
 
Join Date: Oct 2008
Location: Santa Barbara
Motorcycle: Blue 2006 GSX-R1000
Posts: 7,496
Re: 07 gsxr 750 oil pressure dropping at low revs when hot

What RPM did it drop to and is your idle RPM properly set? Run through the OIL PRESSURE CHECK procedure in the periodic maintenance section of the service manual. You'll need a pressure gauge and an adapter, or you can connect the pressure gauge in place of the pressure switch. Suzuki says it's "a good indication of the condition of the moving parts".
BillV is offline  
post #3 of 7 (permalink) Old 07-23-2019, 06:00 AM Thread Starter
Squid
 
Join Date: Jul 2019
Posts: 4
I can’t remember the exact revs when it did it. cheers for that I’m away atm but once I get back in mid August I will give them a try and I might post some questions on this post if I’m struggling.
👌
Chrisgill89 is offline  
Sponsored Links
Advertisement
 
post #4 of 7 (permalink) Old 07-23-2019, 07:37 PM
Amateur
 
Nightbat®'s Avatar
 
Join Date: May 2007
Location: Holland
Motorcycle: GSX-R 1000k5
Posts: 666
Garage
Re: 07 gsxr 750 oil pressure dropping at low revs when hot

Quote:
Originally Posted by Chrisgill89 View Post
the oil pressure warning light would come on and the engine would start to run rough.
The oilpressure warning Light?
I was unaware a k6/7 had a light for oilpressure, I know it has an indicator on the led display, but that's monochrome, it doesn't light up by itself
Nightbat® is offline  
post #5 of 7 (permalink) Old 07-24-2019, 11:27 AM
Provisional Novice
 
Süsser Tod's Avatar
 
Join Date: Dec 2013
Location: Mexico City
Motorcycle: GSX S750, D675R, Versys 650
Posts: 225
Re: 07 gsxr 750 oil pressure dropping at low revs when hot

They do have one:

DSC_3179-1.jpg


I don't have the service manual at hand, but IIRC it also doubled as a FI light, but I might be completely wrong on that one.

Last edited by Süsser Tod; 07-24-2019 at 11:37 AM.
Süsser Tod is offline  
post #6 of 7 (permalink) Old 07-24-2019, 01:11 PM
Amateur
 
Nightbat®'s Avatar
 
Join Date: May 2007
Location: Holland
Motorcycle: GSX-R 1000k5
Posts: 666
Garage
Re: 07 gsxr 750 oil pressure dropping at low revs when hot

Quote:
Originally Posted by Süsser Tod View Post
They do have one:

I don't have the service manual at hand, but IIRC it also doubled as a FI light, but I might be completely wrong on that one.
Somewhat my point
It does triple duty as Oil, Coolant and General failure warning light

Usually an oil problem doesn't make a bike run rough when pulling the clutch
I'm guessing a hickup in the FI, , maybe even something as simple as a bad clutch switch
but the only way to know for sure is get the old paperclip in there and start pulling codes, the moment it happens again
Nightbat® is offline  
post #7 of 7 (permalink) Old 07-29-2019, 08:06 PM
Hand-Eye Coordinator
 
MacBayne's Avatar
 
Join Date: Jun 2008
Location: Edmonton AB
Motorcycle: 2014 675R, 2019 Husky TE300i, 2014 Grom. Yes, Grom, fuck you, it's fun.
Posts: 6,509
Re: 07 gsxr 750 oil pressure dropping at low revs when hot

That's pretty much just a fault light. FI light, if you will. The symbol beside it is for oil temp, which is the number reading on the right side.

OP, that blinking light was probably an ECU fault. Did the bike run smoothly after letting the clutch out OR adding throttle. Do a site search for dealer mode.
MacBayne is offline  
Sponsored Links
Advertisement
 
Reply

Quick Reply
Message:
Options

Register Now



In order to be able to post messages on the Suzuki GSX-R Motorcycle Forums Gixxer.com forums, you must first register.
Please enter your desired user name, your email address and other required details in the form below.

User Name:
Password
Please enter a password for your user account. Note that passwords are case-sensitive.

Password:


Confirm Password:
Email Address
Please enter a valid email address for yourself.

Email Address:
OR

Log-in










Thread Tools
Show Printable Version Show Printable Version
Email this Page Email this Page
Display Modes
Linear Mode Linear Mode



Posting Rules  
You may post new threads
You may post replies
You may not post attachments
You may not edit your posts

BB code is On
Smilies are On
[IMG] code is On
HTML code is Off
Trackbacks are On
Pingbacks are On
Refbacks are On

 
For the best viewing experience please update your browser to Google Chrome