K6 750 instruments problem - Suzuki GSX-R Motorcycle Forums Gixxer.com
 
LinkBack Thread Tools Display Modes
post #1 of 4 (permalink) Old 07-21-2019, 06:01 AM Thread Starter
Squid
 
Join Date: Jul 2019
Posts: 3
K6 750 instruments problem

The instrument cluster on my k6 750 is working only spasmodically. It seems to work OK for a while after the battery is disconnected and then reconnected, then dies overnight. Almost like a boot up problem. The red backlight is working but no LCD. Is the cluster broken or is there another fix? Thanks in advance.
RMutt is offline  
Sponsored Links
Advertisement
 
post #2 of 4 (permalink) Old 07-21-2019, 09:52 PM
Hand-Eye Coordinator
 
MacBayne's Avatar
 
Join Date: Jun 2008
Location: Edmonton AB
Motorcycle: 2014 675R, 2019 Husky TE300i, 2014 Grom. Yes, Grom, fuck you, it's fun.
Posts: 6,509
Re: K6 750 instruments problem

What is your battery voltage in the morning? What is the general condition of the machine/wiring? Post pics.
MacBayne is offline  
post #3 of 4 (permalink) Old 07-24-2019, 05:14 AM Thread Starter
Squid
 
Join Date: Jul 2019
Posts: 3
Re: K6 750 instruments problem

Thanks for replying MacBayne. Condition of bike is generally good. Twenty odd thousand miles. Wiring is standard apart from the reg/rec which was moved away from the heat of the original position. The connector behind the clocks is very good. The big connector under the fairing on the left is dirty but looks OK. The issue is repeatable/ predictable. Clocks dead, disconnect battery and wait half an hour, connect, clocks working again. Works for a few hours. Dies until disconnected from battery and reconnected, repeat ad nauseum. Sorry cannot give voltage readings.
RMutt is offline  
Sponsored Links
Advertisement
 
post #4 of 4 (permalink) Old 07-25-2019, 07:11 PM
Hand-Eye Coordinator
 
MacBayne's Avatar
 
Join Date: Jun 2008
Location: Edmonton AB
Motorcycle: 2014 675R, 2019 Husky TE300i, 2014 Grom. Yes, Grom, fuck you, it's fun.
Posts: 6,509
Re: K6 750 instruments problem

One cannot diagnose an electrical issue without a DMM.
MacBayne is offline  
Sponsored Links
Advertisement
 
Reply

Quick Reply
Message:
Options

Register Now



In order to be able to post messages on the Suzuki GSX-R Motorcycle Forums Gixxer.com forums, you must first register.
Please enter your desired user name, your email address and other required details in the form below.

User Name:
Password
Please enter a password for your user account. Note that passwords are case-sensitive.

Password:


Confirm Password:
Email Address
Please enter a valid email address for yourself.

Email Address:
OR

Log-in










Thread Tools
Show Printable Version Show Printable Version
Email this Page Email this Page
Display Modes
Linear Mode Linear Mode



Posting Rules  
You may post new threads
You may post replies
You may not post attachments
You may not edit your posts

BB code is On
Smilies are On
[IMG] code is On
HTML code is Off
Trackbacks are On
Pingbacks are On
Refbacks are On

 
For the best viewing experience please update your browser to Google Chrome