Lost clip on engine... - Suzuki GSX-R Motorcycle Forums Gixxer.com
 
LinkBack Thread Tools Display Modes
post #1 of 2 (permalink) Old 07-02-2018, 09:31 PM Thread Starter
Squid
 
Join Date: Jun 2013
Posts: 2
Lost clip on engine...

I was trying to take the air box off to get to the connector plug. When I popped off the plastic clip that blocks the hole that allows a screwdriver to get the the throttlebody clamps, it shot out and landed somewhere in the bike. It didn't fall to the ground. It also didn't get into the throttle body as the box was still on. I took off both fairings and searched for it for like 30 minutes with a flash light. At this point I am about to call it quits and just go buy a new clip. Should I be afraid of the lost clip catching on fire?
Kasmod is offline  
Sponsored Links
Advertisement
 
post #2 of 2 (permalink) Old 07-03-2018, 12:59 AM
Squid
 
Join Date: Jun 2011
Location: Midlands UK
Motorcycle: 2007 Suzuki GSX-R750
Posts: 15
Re: Lost clip on engine...

No. It'll drop out with a bit of use.

Sent from my HTC Desire 530 using Tapatalk
Linx is offline  
Sponsored Links
Advertisement
 
Reply

Quick Reply
Message:
Options

Register Now



In order to be able to post messages on the Suzuki GSX-R Motorcycle Forums Gixxer.com forums, you must first register.
Please enter your desired user name, your email address and other required details in the form below.

User Name:
Password
Please enter a password for your user account. Note that passwords are case-sensitive.

Password:


Confirm Password:
Email Address
Please enter a valid email address for yourself.

Email Address:
OR

Log-in










Thread Tools
Show Printable Version Show Printable Version
Email this Page Email this Page
Display Modes
Linear Mode Linear Mode



Posting Rules  
You may post new threads
You may post replies
You may not post attachments
You may not edit your posts

BB code is On
Smilies are On
[IMG] code is On
HTML code is Off
Trackbacks are On
Pingbacks are On
Refbacks are On

 
For the best viewing experience please update your browser to Google Chrome