My gsxr 600 k6 wont start - Suzuki GSX-R Motorcycle Forums Gixxer.com

 1Likes
  • 1 Post By Samantha750
 
LinkBack Thread Tools Display Modes
post #1 of 15 (permalink) Old 05-05-2018, 11:07 AM Thread Starter
Squid
 
Join Date: May 2018
Posts: 9
My gsxr 600 k6 wont start

Hi! My gsxr just wont start, the pump wont prime and the cluster light turns on but the number dont appear plus the revs is blocked at 1000rpm, any ideas please?

Enviado desde mi Redmi 4X mediante Tapatalk
bigdaddy_919 is offline  
Sponsored Links
Advertisement
 
post #2 of 15 (permalink) Old 05-05-2018, 11:09 AM Thread Starter
Squid
 
Join Date: May 2018
Posts: 9
Re: My gsxr 600 k6 wont start

I checked the fuses and theyre all fine, it all started when I turned on the bike and I put up the leg and it suddenly stalled, the cluster went blank and it just wouldnt start again!

Enviado desde mi Redmi 4X mediante Tapatalk
bigdaddy_919 is offline  
post #3 of 15 (permalink) Old 05-05-2018, 11:36 AM
Squid
 
Join Date: Jun 2017
Posts: 9
Re: My gsxr 600 k6 wont start

i'd start with connector under your left fairing
krzyq is offline  
Sponsored Links
Advertisement
 
post #4 of 15 (permalink) Old 05-05-2018, 12:54 PM Thread Starter
Squid
 
Join Date: May 2018
Posts: 9
Re: My gsxr 600 k6 wont start

Hi, What conector? Is it near the regulator?
Quote:
Originally Posted by krzyq View Post
i'd start with connector under your left fairing
Enviado desde mi Redmi 4X mediante Tapatalk
bigdaddy_919 is offline  
post #5 of 15 (permalink) Old 05-05-2018, 01:05 PM
Squid
 
Join Date: Jun 2017
Posts: 9
Re: My gsxr 600 k6 wont start

you have to remove your left fairing otherwise you wont be able to access it (i think its a 16 pin connector, on the left from regulator but u wont see it unless u remove your left fairing)



TYPE "Speedo/Tach not working – 2007 Suzuki GSXR 600" in google, 1st link there are pictures included (i cant add pics here) clean that connetor and let us know if its working

Last edited by krzyq; 05-05-2018 at 01:14 PM.
krzyq is offline  
post #6 of 15 (permalink) Old 05-05-2018, 02:35 PM Thread Starter
Squid
 
Join Date: May 2018
Posts: 9
Re: My gsxr 600 k6 wont start

Great Ill try out tomorrow morning, Im writting from Spain and its too late now! Fingers crossed, you think this issue would prevent the bike from priming the fuel pump and thus starting up?
Quote:
Originally Posted by krzyq View Post
you have to remove your left fairing otherwise you wont be able to access it (i think its a 16 pin connector, on the left from regulator but u wont see it unless u remove your left fairing)



TYPE "Speedo/Tach not working 2007 Suzuki GSXR 600" in google, 1st link there are pictures included (i cant add pics here) clean that connetor and let us know if its working
Enviado desde mi Redmi 4X mediante Tapatalk
bigdaddy_919 is offline  
post #7 of 15 (permalink) Old 05-05-2018, 03:04 PM
Squid
 
Join Date: Jun 2017
Posts: 9
Re: My gsxr 600 k6 wont start

ye i think so, also if cleaning that connector doesnt help next step would be checking your kill switch then fuel pump relay, dont forget to post if you get it fixed
krzyq is offline  
post #8 of 15 (permalink) Old 05-05-2018, 03:48 PM
Squid
 
Join Date: May 2018
Posts: 4
Check the connector under fairing
Taymooraly is offline  
post #9 of 15 (permalink) Old 05-06-2018, 03:55 AM Thread Starter
Squid
 
Join Date: May 2018
Posts: 9
Re: My gsxr 600 k6 wont start

Well Im right at it, this is what I found, not that bad Id say
Quote:
Originally Posted by krzyq View Post
ye i think so, also if cleaning that connector doesnt help next step would be checking your kill switch then fuel pump relay, dont forget to post if you get it fixed


Enviado desde mi Redmi 4X mediante Tapatalk
bigdaddy_919 is offline  
post #10 of 15 (permalink) Old 05-06-2018, 04:11 AM Thread Starter
Squid
 
Join Date: May 2018
Posts: 9
Re: My gsxr 600 k6 wont start

I also checked by changing the fuses just in case, I noticed the main fuse, the one just above the ecu has a 20a fuse but a 30a reserve, I seem to remember it should be a 30a one, am I right? Does someone know? Next step is cheking the relay in charge of the clutch and the "leg" (dont know how its called in English) microswitches.

Enviado desde mi Redmi 4X mediante Tapatalk
bigdaddy_919 is offline  
post #11 of 15 (permalink) Old 05-06-2018, 04:18 AM
Ex-Lady Supermod

 
Join Date: Jul 2008
Posts: 16,129
Garage
Re: My gsxr 600 k6 wont start

20A?

bigdaddy_919 likes this.
Samantha750 is offline  
post #12 of 15 (permalink) Old 05-06-2018, 04:38 AM Thread Starter
Squid
 
Join Date: May 2018
Posts: 9
Re: My gsxr 600 k6 wont start

I knew I had read it somewhere! Its the same in America and in Europe right? What symptoms would it present if its not getting enough?
Quote:
Originally Posted by Samantha750 View Post
20A?

Enviado desde mi Redmi 4X mediante Tapatalk
bigdaddy_919 is offline  
post #13 of 15 (permalink) Old 05-06-2018, 04:48 AM
Ex-Lady Supermod

 
Join Date: Jul 2008
Posts: 16,129
Garage
Re: My gsxr 600 k6 wont start

I can only imagine America and Europe are the same. As for using a 20A instead of a 30A could lead to the fuse blowing. Using a smaller amp I would think is not nearly as risky as using a higher amp fuse than is required, say 15A or 20A instead of a 10A.
Samantha750 is offline  
post #14 of 15 (permalink) Old 05-06-2018, 05:36 AM Thread Starter
Squid
 
Join Date: May 2018
Posts: 9
Re: My gsxr 600 k6 wont start

It still isnt blown, but still Ill make it right
Quote:
Originally Posted by Samantha750 View Post
I can only imagine America and Europe are the same. As for using a 20A instead of a 30A could lead to the fuse blowing. Using a smaller amp I would think is not nearly as risky as using a higher amp fuse than is required, say 15A or 20A instead of a 10A.
Enviado desde mi Redmi 4X mediante Tapatalk
bigdaddy_919 is offline  
post #15 of 15 (permalink) Old 05-07-2018, 12:33 PM Thread Starter
Squid
 
Join Date: May 2018
Posts: 9
Re: My gsxr 600 k6 wont start

Well tested the side stand relay and its fine, I surrender, Ill be taking it to the shop and see what they have to say

Enviado desde mi Redmi 4X mediante Tapatalk
bigdaddy_919 is offline  
Sponsored Links
Advertisement
 
Reply

Quick Reply
Message:
Options

Register Now



In order to be able to post messages on the Suzuki GSX-R Motorcycle Forums Gixxer.com forums, you must first register.
Please enter your desired user name, your email address and other required details in the form below.

User Name:
Password
Please enter a password for your user account. Note that passwords are case-sensitive.

Password:


Confirm Password:
Email Address
Please enter a valid email address for yourself.

Email Address:
OR

Log-in










Thread Tools
Show Printable Version Show Printable Version
Email this Page Email this Page
Display Modes
Linear Mode Linear Mode



Posting Rules  
You may post new threads
You may post replies
You may not post attachments
You may not edit your posts

BB code is On
Smilies are On
[IMG] code is On
HTML code is Off
Trackbacks are On
Pingbacks are On
Refbacks are On

 
For the best viewing experience please update your browser to Google Chrome