Gsx750f -98, running problems - Suzuki GSX-R Motorcycle Forums Gixxer.com

 
LinkBack Thread Tools Display Modes
post #1 of 7 (permalink) Old 03-18-2019, 04:55 PM Thread Starter
Squid
 
Join Date: Mar 2019
Posts: 5
Gsx750f -98, running problems

Hello all.

My name is Johan and I'm from Sweden.

I own a -98 Gsx750 and long story short, it's not running as it should.

I have spent many hours troubleshooting and I can't find anything wrong with it though.

The bike starts easy and idles well but as soon as you open the throttle more then 1/8, the engines dies.
It cuts off just like you have turned off the ignition.
When it dies, it blows squirts of gas back out of the carbs.



A list of the work done up until now:

*Measured and tested all of the electrical components and there's no problem with them.
All is ok, I have also borrowed som components from a working bike but to no success.

*Cleaned the carbs, checked the floatheight etc, condition of the carbs is great. All is stock, jets, needles etc.
I also tried some other carbs from a working bike but no success there either.
I have tried setting the carbs rich and lean = no difference.

*I have checked the whole wire harness = it is in condition like new.

*The engine has good compression, it ranges from 173 to 176 psi.
Did a leakdown test on every cylinder and that showed 5-6% leakage.

*The cam timing is correct according to the workshop manual.

*New fresh gas

*The exhaust is not plugged or stuffed, it flows freely.

*Tried new set of spark plugs and another coilpack but that did not change a thing.

I'm completely out of ideas now, everything that I have checked turned out to be faultless, but still the engine runs like crap.

I have a video on Youtube that shows how it runs, but since I'm new on this forum, I can't post any links.



Thanks in advance and best regards from a really confused Swede 🙂
Oaksmotor is offline  
Sponsored Links
Advertisement
 
post #2 of 7 (permalink) Old 03-19-2019, 12:08 PM
Provisional Novice
 
Süsser Tod's Avatar
 
Join Date: Dec 2013
Location: Mexico City
Motorcycle: GSX-R 750, Versys 650
Posts: 188
Re: Gsx750f -98, running problems

Do you have the airbox installed? It's a pain in the behind to get them tuned correctly with pod filters.
Süsser Tod is offline  
post #3 of 7 (permalink) Old 03-19-2019, 03:11 PM Thread Starter
Squid
 
Join Date: Mar 2019
Posts: 5
Yes, I have tested the engine both with and without the airbox.
No difference, it acts the same.
Oaksmotor is offline  
Sponsored Links
Advertisement
 
post #4 of 7 (permalink) Old 03-19-2019, 03:19 PM Thread Starter
Squid
 
Join Date: Mar 2019
Posts: 5
Since i'm totally out of ideas of what the problem might be, I'm about to remove the engine out of the frame and dig deeper into it.
Such as removing the cylinder head and check for anything suspicius.
Oaksmotor is offline  
post #5 of 7 (permalink) Old 03-20-2019, 09:01 AM
Provisional Novice
 
Süsser Tod's Avatar
 
Join Date: Dec 2013
Location: Mexico City
Motorcycle: GSX-R 750, Versys 650
Posts: 188
Re: Gsx750f -98, running problems

These bikes had a vacuum operated petcock, have you tried with an external fuel tank without a petcock and just blocking the vacuum line? I woudln't drop the engine yet, if there was a problem with the head or timing it wouldn't idle.
Süsser Tod is offline  
post #6 of 7 (permalink) Old 03-20-2019, 04:18 PM Thread Starter
Squid
 
Join Date: Mar 2019
Posts: 5
Yes I have tried both the stock fuel tank/petcock and also a external tank.
No difference unfortunately.

No airleaks, the carbs are synched and they do not flood.
The valve clearances are correct according to the workshop manual.

I have been a mechanic for about 25 years but I think I will bite the dust with this bike 🙂

It is so strange, I have checked and doublecheck everything and can not find anything wrong with it.

The swapped parts (carbs, intake, coilpacks, sparkplugs, pulse generator, etc) that work great on my other 750, does not cure the problem.
Oaksmotor is offline  
post #7 of 7 (permalink) Old 03-20-2019, 04:27 PM Thread Starter
Squid
 
Join Date: Mar 2019
Posts: 5
Here's a picture that shows the video on Youtube where you can hear the bike and how strange it runs.
Screenshot_20190320-222952_YouTube_1553117425636.jpg
Oaksmotor is offline  
Sponsored Links
Advertisement
 
Reply

Quick Reply
Message:
Options

Register Now



In order to be able to post messages on the Suzuki GSX-R Motorcycle Forums Gixxer.com forums, you must first register.
Please enter your desired user name, your email address and other required details in the form below.

User Name:
Password
Please enter a password for your user account. Note that passwords are case-sensitive.

Password:


Confirm Password:
Email Address
Please enter a valid email address for yourself.

Email Address:
OR

Log-in










Thread Tools
Show Printable Version Show Printable Version
Email this Page Email this Page
Display Modes
Linear Mode Linear Mode



Similar Threads
Thread Thread Starter Forum Replies Last Post
725 engine running injection - problems with ecu choice? AlanRush10 SRADs (97-00 600 and 96-99 750) 5 04-30-2016 09:10 AM
Jerky Throttle Fix - Now running problems? magsmagsmags 06-07 GSX-R600/750 1 07-14-2015 01:32 PM
gsxr 1000 k5 running problems dropping all cylinders :( HELP eric1988hull 05-06 GSX-R1000 1 05-20-2013 10:52 PM
1989 GSXR 750 running problems PLEASE HELP!! boejayngles Oil Cooled Gixxers 13 10-16-2010 05:24 AM
Problems with timing/ running on 3 cylinders M//// Guy Oil Cooled Gixxers 19 06-05-2007 11:02 AM

Posting Rules  
You may post new threads
You may post replies
You may not post attachments
You may not edit your posts

BB code is On
Smilies are On
[IMG] code is On
HTML code is Off
Trackbacks are On
Pingbacks are On
Refbacks are On

 
For the best viewing experience please update your browser to Google Chrome