All four indicators/turn signals flashing (NOT LEDS!) - Suzuki GSX-R Motorcycle Forums Gixxer.com

 
LinkBack Thread Tools Display Modes
post #1 of 9 (permalink) Old 10-26-2018, 04:19 PM Thread Starter
Squid
 
Join Date: Oct 2018
Posts: 4
All four indicators/turn signals flashing (NOT LEDS!)

hi everyone.

my gsxr750 k4 has randomly started flashing all four indicators/turn signals when I indicate to turn.

turn signal on the panel is still working.

I of course googled this (how i found this forum) and it seems everyone else has experienced this after changing to LED bulbs.

I havent, I've still got the original stock bulbs on the bike. All are working so none have blown.

I've pulled out the relay, it seems ok - presumably if it wasnt nothing would flash as there's only an in and out (2pins) for the indicators so presumably the split is elsewhere.

Any ideas greatly appreciated - thanks!
boredatwork is offline  
Sponsored Links
Advertisement
 
post #2 of 9 (permalink) Old 10-27-2018, 07:49 AM
Dreaming of buttsecks for years...
 
TheGeek's Avatar
 
Join Date: Feb 2006
Location: Indiana
Motorcycle: Anniversary Edition 600 & 2018 Harley Street Glide
Posts: 13,201
Garage
Re: All four indicators/turn signals flashing (NOT LEDS!)

Possibly the switch. The flasher supplies power to the switch, which distributes to the bulbs. Something is linking the left circuit and the right circuit. It's either the switch, or a short in the wiring.
TheGeek is offline  
post #3 of 9 (permalink) Old 10-27-2018, 12:19 PM
You should listen to me. No, seriously, listen to me.
 
Join Date: Oct 2008
Location: Santa Barbara
Motorcycle: Blue 2006 GSX-R1000
Posts: 7,228
Re: All four indicators/turn signals flashing (NOT LEDS!)

+1 on the switch. The hazard warning switch is nearby and connects to the same leads. There might be a short or other malfunction there.

Otherwise look for a short between the B and Lg leads, either at the switch or at any of the several connectors that they pass through.
BillV is offline  
Sponsored Links
Advertisement
 
post #4 of 9 (permalink) Old 10-28-2018, 08:12 AM Thread Starter
Squid
 
Join Date: Oct 2018
Posts: 4
Re: All four indicators/turn signals flashing (NOT LEDS!)

thanks guys going to have a look tommorow evening - will report back in case it s helpful to others.
boredatwork is offline  
post #5 of 9 (permalink) Old 04-16-2019, 03:50 PM Thread Starter
Squid
 
Join Date: Oct 2018
Posts: 4
Re: All four indicators/turn signals flashing (NOT LEDS!)

Hi, just to give an update in case this ever affects anyone else.

It wasnt the switch - i fully dismantled and re-assembled and made no difference so i borrowed a switch unit from a friend - same thing.

taking out all the bulbs or different combinations doesnt make a difference and a voltmeter doesnt appear to lead to a dodgy ground.

ive discovered some diodes leading to the indicator light on the dashboard some im going to replace them (i dont really know how to test them)

i'll update!
boredatwork is offline  
post #6 of 9 (permalink) Old 04-17-2019, 07:47 PM
Hand-Eye Coordinator
 
MacBayne's Avatar
 
Join Date: Jun 2008
Location: Edmonton AB
Motorcycle: 2014 675R, 2019 Husky TE300i
Posts: 6,231
Re: All four indicators/turn signals flashing (NOT LEDS!)

Quote:
Originally Posted by boredatwork View Post
ive discovered some diodes leading to the indicator light on the dashboard some im going to replace them (i dont really know how to test them)

i'll update!
In general, or specific?
MacBayne is offline  
post #7 of 9 (permalink) Old 04-19-2019, 04:03 PM Thread Starter
Squid
 
Join Date: Oct 2018
Posts: 4
Re: All four indicators/turn signals flashing (NOT LEDS!)

Quote:
Originally Posted by MacBayne View Post
In general, or specific?

sorry not sure i understand the question.. i dont know generally how to test diodes not just the ones on the bike.
boredatwork is offline  
post #8 of 9 (permalink) Old 04-20-2019, 04:51 AM
Dreaming of buttsecks for years...
 
TheGeek's Avatar
 
Join Date: Feb 2006
Location: Indiana
Motorcycle: Anniversary Edition 600 & 2018 Harley Street Glide
Posts: 13,201
Garage
Re: All four indicators/turn signals flashing (NOT LEDS!)

A simple continuity test from one side to the other, then reverse it. One should read open. I really think you're over complicating this.

The tail would be the easiest way to access some wires for SIMPLE testing:

Just take the key out so there's no power to the system. Tap into the hot lines for the left (Black) and right (light green). Check continuity between these. There should be none. If there is, you have a short. To test your diode theory, just disconnect the cluster. Then disconnect the big main connector to the end that's under the left ram air tube. Then disconnect the left switch pod. If all these are disconnected, and you still have continuity, your short is in the main harness.

If disconnecting the cluster opens the circuit, then yeah, your problem is in the cluster.

If disconnecting the front main connector, then your short is in the front sub harness.

If disconnecting the left switch pod, your short is in the pod lead, or the switch.

If there's no continuity at all when you start, it's the switch.


Last thought, do you have an aftermarket tail light with integrated signals?


To view links or images in signatures your post count must be 10 or greater. You currently have 0 posts.

Never mistake education for intelligence.

"Don't go ninjain nobody that don't need ninjain" -
To view links or images in signatures your post count must be 10 or greater. You currently have 0 posts.
TheGeek is offline  
post #9 of 9 (permalink) Old 04-20-2019, 03:17 PM
Hand-Eye Coordinator
 
MacBayne's Avatar
 
Join Date: Jun 2008
Location: Edmonton AB
Motorcycle: 2014 675R, 2019 Husky TE300i
Posts: 6,231
Re: All four indicators/turn signals flashing (NOT LEDS!)

Quote:
Originally Posted by boredatwork View Post
sorry not sure i understand the question.. i dont know generally how to test diodes not just the ones on the bike.
Put your meter in "Diode" setting. (pic below is the diode symbol. your meter may not have that setting, or you may have to press a 'second function' button)

Put your leads on either polarity of the diode, then switch polarities. One way should read O/L, the other reads how many volts the diode takes to open.

If you get two voltages, or two O/L, the diode is pooched. Also, if you get a small voltage (like a fair amount less less than 0.5 volts) it is also pooched.


"A girl phoned me and said, "Come on over. There's nobody home." I went over. Nobody was home!"

-Dangerfield
MacBayne is offline  
Sponsored Links
Advertisement
 
Reply

Quick Reply
Message:
Options

Register Now



In order to be able to post messages on the Suzuki GSX-R Motorcycle Forums Gixxer.com forums, you must first register.
Please enter your desired user name, your email address and other required details in the form below.

User Name:
Password
Please enter a password for your user account. Note that passwords are case-sensitive.

Password:


Confirm Password:
Email Address
Please enter a valid email address for yourself.

Email Address:
OR

Log-in










Thread Tools
Show Printable Version Show Printable Version
Email this Page Email this Page
Display Modes
Linear Mode Linear Mode



Similar Threads
Thread Thread Starter Forum Replies Last Post
Mod help: LEDs, Signals, Air Horn, etc... Dream of Flight General Bike Talk 37 04-11-2010 06:00 PM
04 gixxer with hotbodies undertail fast flashing signals and few other ?'s mywickedgsxr GSX-R1000 General Forum 1 05-04-2009 08:47 PM
signals flashing fast !! GS6Rrr 04-05 GSX-R600/750 13 03-09-2008 11:20 PM
Using LED's as turn signals bandito Mods & How To's 5 03-31-2005 11:25 PM
LED's for all the turn signals nygixxernv SRADs (97-00 600 and 96-99 750) 7 09-21-2003 01:02 AM

Posting Rules  
You may post new threads
You may post replies
You may not post attachments
You may not edit your posts

BB code is On
Smilies are On
[IMG] code is On
HTML code is Off
Trackbacks are On
Pingbacks are On
Refbacks are On

 
For the best viewing experience please update your browser to Google Chrome