Help! - Suzuki GSX-R Motorcycle Forums Gixxer.com

 
LinkBack Thread Tools Display Modes
post #1 of 2 (permalink) Old 01-21-2019, 05:11 PM Thread Starter
Squid
 
Join Date: Jan 2019
Posts: 8
Help!

2006 GSXR 600

I just recently switched my old fuel pump assembly with a brand new fuel pump assembly for my bike just Saturday 1/19

Put everything back together.

Today, I did a cold start on it.

Pump primed and the bike started up immediately. The bike was running fine, trying to heat itself up, I started revving the throttle. Sounded great 😏😏. Then I let the back idle and then suddenly it shut off. All of this was about 30 seconds.

After I started it again, bike warmed up and didn’t die once warm. Took out for a spin and ran like a champ.

My question is why would it shut off suddenly while cold starting it?
James Goff is offline  
Sponsored Links
Advertisement
 
post #2 of 2 (permalink) Old 01-22-2019, 04:00 AM
I know things... A lot of things.
 
Join Date: Feb 2015
Motorcycle: GSXR 750 K4
Posts: 3,033
Re: Help!

Could be lots of things: worn plugs, low idle, something causing it not to fast idle. If you start it cold, without applying throttle, what engine speed does it idle at? Does that speed fall after half a minute or so? How low does it get if it does?
dpapavas is offline  
Sponsored Links
Advertisement
 
Reply

Quick Reply
Message:
Options

Register Now



In order to be able to post messages on the Suzuki GSX-R Motorcycle Forums Gixxer.com forums, you must first register.
Please enter your desired user name, your email address and other required details in the form below.

User Name:
Password
Please enter a password for your user account. Note that passwords are case-sensitive.

Password:


Confirm Password:
Email Address
Please enter a valid email address for yourself.

Email Address:
OR

Log-in










Thread Tools
Show Printable Version Show Printable Version
Email this Page Email this Page
Display Modes
Linear Mode Linear Mode



Posting Rules  
You may post new threads
You may post replies
You may not post attachments
You may not edit your posts

BB code is On
Smilies are On
[IMG] code is On
HTML code is Off
Trackbacks are On
Pingbacks are On
Refbacks are On

 
For the best viewing experience please update your browser to Google Chrome