Need troubleshooting tips - Suzuki GSX-R Motorcycle Forums Gixxer.com

 
LinkBack Thread Tools Display Modes
post #1 of 4 (permalink) Old 07-15-2019, 07:21 PM Thread Starter
Squid
 
Join Date: Jul 2019
Posts: 1
Need troubleshooting tips

I've got the gsxr-750 and I've been having trouble getting it to run. It turns over just doesn't run. It had a c29 code so I replaced the actuator and the stps(used part). The stps code cleared but threw the c28 code and still didn't start. Checked it today and now its throwing the c29 code.?? An the butterfly's move with the bike on(after I already turned it on and they moved the first time)?? I also tested the relay and got no click or light from the test light, check power to the fuel pump from the harness and got no light either.? Any ideas?
Dman1993 is offline  
Sponsored Links
Advertisement
 
post #2 of 4 (permalink) Old 07-17-2019, 04:49 AM
I know things... A lot of things.
 
Join Date: Feb 2015
Motorcycle: GSXR 750 K4
Posts: 3,047
Re: Need troubleshooting tips

You seem to have two separate problems at least. One is related to the STPS/STVA which though would not prevent the bike from starting. The other seems to be due to bad wiring, as you should be getting power at the various ignition system components when you can operate the starter. You don't mention what model you have, but whichever it is, you'll need to get a service manual and troubleshoot these two separately. Consult the wiring diagram at the end of the manual. It looks intimidating but all it takes, generally, is tracing lines. (There's a diagram in the section on the ignition interlock in the chapter on electrics which is also of interest and much simplified.)

You'll need to find out why the fuel pump relay isn't operating. The relay is controlled by the ECU but it gets powered by the O/W wire coming out of the engine stop switch. Make sure the connection is intact. The ECU also monitors the output and throws a code if it's commanded the relay on but it hasn't turned on. It's weird that it doesn't click but you also don't see a code. Perhaps you missed the click and it did turn on but the connection to the pump or the pump's ground is broken.

You'll need to troubleshoot this methodically and similarly so for the STVA/STPS problem, which might be a wiring problem, a bad STVA/STPS, or an improperly installed component. Some experience with troubleshooting electrics will be required and probably a DMM. (Alternatively, the patience to learn how without causing any damage in the process.) If you're not up to it, consider taking it to a shop or a friend.
dpapavas is offline  
post #3 of 4 (permalink) Old 07-17-2019, 10:49 AM
Dreaming of buttsecks for years...
 
TheGeek's Avatar
 
Join Date: Feb 2006
Location: Indiana
Motorcycle: Anniversary Edition 600 & 2018 Harley Street Glide
Posts: 13,341
Garage
Re: Need troubleshooting tips

If you have the TPS and STPS connections reversed, it'll cause problems like this. But I'm not sure if it's possible because I'm not sure what model you're working on.
TheGeek is offline  
Sponsored Links
Advertisement
 
post #4 of 4 (permalink) Old 07-20-2019, 08:55 PM
Hand-Eye Coordinator
 
MacBayne's Avatar
 
Join Date: Jun 2008
Location: Edmonton AB
Motorcycle: 2014 675R, 2019 Husky TE300i, 2014 Grom. Yes, Grom, fuck you, it's fun.
Posts: 6,507
Re: Need troubleshooting tips

The code did not clear. If the bike throws a code using the "cheat" found on the website, turning the ignition off cleared the code.

You need a manual for this.
MacBayne is offline  
Sponsored Links
Advertisement
 
Reply

Quick Reply
Message:
Options

Register Now



In order to be able to post messages on the Suzuki GSX-R Motorcycle Forums Gixxer.com forums, you must first register.
Please enter your desired user name, your email address and other required details in the form below.

User Name:
Password
Please enter a password for your user account. Note that passwords are case-sensitive.

Password:


Confirm Password:
Email Address
Please enter a valid email address for yourself.

Email Address:
OR

Log-in










Thread Tools
Show Printable Version Show Printable Version
Email this Page Email this Page
Display Modes
Linear Mode Linear Mode



Posting Rules  
You may post new threads
You may post replies
You may not post attachments
You may not edit your posts

BB code is On
Smilies are On
[IMG] code is On
HTML code is Off
Trackbacks are On
Pingbacks are On
Refbacks are On

 
For the best viewing experience please update your browser to Google Chrome