Crankshaft position sensor part number - Suzuki GSX-R Motorcycle Forums Gixxer.com

 1Likes
  • 1 Post By b3w4r3
 
LinkBack Thread Tools Display Modes
post #1 of 6 (permalink) Old 03-20-2018, 04:16 PM Thread Starter
Squid
 
Join Date: Mar 2018
Posts: 10
Garage
Crankshaft position sensor part number

My bike is giving me a C12 fault which refers to the crankshaft position sensor. I have followed the wiring from the sensor to the ECU... does not seem to be any loose wires so I am thinking the sensor needs to be replaced. Problem is, I cannot find a part number for this.

My bike is a 2007 GSX-R750. I called a Suzuki dealer in my area and they weren't able to find anything for a crankshaft position sensor. Closest thing he found was a cam position sensor.

Can anyone help me please? I am hoping someone else has dealt with replacing this part.


killswitchSevenfold is offline  
Sponsored Links
Advertisement
 
post #2 of 6 (permalink) Old 03-20-2018, 05:16 PM
Amateur
 
b3w4r3's Avatar
 
Join Date: Oct 2014
Posts: 337
Garage
Re: Crankshaft position sensor part number

I could be wrong but I think it's called "STATOR, SIGNAL GENERATOR" Part number - 33110-01H00
b3w4r3 is offline  
post #3 of 6 (permalink) Old 03-20-2018, 05:40 PM Thread Starter
Squid
 
Join Date: Mar 2018
Posts: 10
Garage
Re: Crankshaft position sensor part number

Just checked that part number. That is the one! It should not have been that hard to find the part related to a C12 fault. Thanks!
killswitchSevenfold is offline  
Sponsored Links
Advertisement
 
post #4 of 6 (permalink) Old 03-20-2018, 06:50 PM
Amateur
 
b3w4r3's Avatar
 
Join Date: Oct 2014
Posts: 337
Garage
Re: Crankshaft position sensor part number

Glad I could help. It's sad that the dealership didn't know.
b3w4r3 is offline  
post #5 of 6 (permalink) Old 03-27-2018, 11:43 AM Thread Starter
Squid
 
Join Date: Mar 2018
Posts: 10
Garage
Re: Crankshaft position sensor part number

For anyone that comes across this post, I can confirm that changing the CKP sensor did indeed get the bike running again.
killswitchSevenfold is offline  
post #6 of 6 (permalink) Old 05-08-2019, 10:11 AM
Squid
 
Join Date: May 2019
Posts: 3
What were the symptoms your bike had and did you test the sensor through the connector at all with a multimeter?

I’ve tested my ckp sensor connector for resistance which is fine + continuity which I believe is fine as well.

The reason I ask is because i just got a c12 code and the bike died on me and will not fire. It has full power, cranking, fuel pump priming when ignition switched to on, and it will continuously crank but will not fire. I am unable to push start it as it didn’t start up completely and then it bogged and shut off.. I checked ignition coils, and spark plugs which were fine but I am ha gong spark plugs anyways since I have it open.

The only thing I found was that the connector from the rectifier was really corroded on the inside prong/terminal things.

If you can give me some symptoms that you had so I can compare them to mine, I would greatly appreciate it.

Thanks !!
Jscrilla187 is offline  
Sponsored Links
Advertisement
 
Reply

Quick Reply
Message:
Options

Register Now



In order to be able to post messages on the Suzuki GSX-R Motorcycle Forums Gixxer.com forums, you must first register.
Please enter your desired user name, your email address and other required details in the form below.

User Name:
Password
Please enter a password for your user account. Note that passwords are case-sensitive.

Password:


Confirm Password:
Email Address
Please enter a valid email address for yourself.

Email Address:
OR

Log-in










Thread Tools
Show Printable Version Show Printable Version
Email this Page Email this Page
Display Modes
Linear Mode Linear Mode



Posting Rules  
You may post new threads
You may post replies
You may not post attachments
You may not edit your posts

BB code is On
Smilies are On
[IMG] code is On
HTML code is Off
Trackbacks are On
Pingbacks are On
Refbacks are On

 
For the best viewing experience please update your browser to Google Chrome