Electronics question TPS? - Suzuki GSX-R Motorcycle Forums Gixxer.com
 
LinkBack Thread Tools Display Modes
post #1 of 5 (permalink) Old 04-02-2016, 12:32 PM Thread Starter
Squid
 
Join Date: Mar 2014
Posts: 2
Question Electronics question TPS?

Hello all, I've been a member for a while now, but due to the extensive amount of information on here I've never had to ask a question! Unfortunately that time has come.

I have an issue with the bike running rough at low rpm and cutting out on tick over.

I had a PCV installed with a map on it for a track i use and thought it maybe an issue with the PCV. Upon checking it it was clearly evident that there is something up with my throttle position as it's sitting at 90% on idle.

When i rest the idle using the configuration option, it would only go down to 30% at idle. Being that this is a strange issue, i opted to remove the PCV and try again, this didn't work!

It's still running pretty rough and cutting out.

A few things i need to take into consideration would be the battery went totally flat for a short period of time over winter, and my last ride on it prior to winter was fine. Something between now and then has gone wrong.

I have read about resetting the TPS in dealer mode for the older bikes, nothing for my year. It's a 2010 K9 1000.

Any suggestions would be great!

Kindest regards
James
dellenty69 is offline  
Sponsored Links
Advertisement
 
post #2 of 5 (permalink) Old 04-02-2016, 02:50 PM
!##NULL##!
 
Join Date: Mar 2016
Posts: 184
Re: Electronics question TPS?

Try the TPS reset the same way. The pc has to see 0 to 100% and match the TPS. So my guess is first set the TPS.
Catch122 is offline  
post #3 of 5 (permalink) Old 04-02-2016, 03:18 PM Thread Starter
Squid
 
Join Date: Mar 2014
Posts: 2
Re: Electronics question TPS?

I'm unable to set the TPS through the PCV, and have since removed the PCV.

Is there an full guide on setting it in dealer mode?
dellenty69 is offline  
Sponsored Links
Advertisement
 
post #4 of 5 (permalink) Old 04-02-2016, 03:42 PM
!##NULL##!
 
Join Date: Mar 2016
Posts: 184
Re: Electronics question TPS?

You knowatt, I'm going by the service plug, paper clip two wires, the dash comes on with some tps popup window, you move the mode switch or trip button, something to that same effect. The pc will only line up with whatever the tps lines up with. First you need the bike's tps to lines up the 1 bar so 3 bars line up even is the preset. Maybe something old school like the busa. Once the bike's tps is 0 to 100 say; is when you will see the pc zero out to 0 and WOT at 100%. Make sense?

Last edited by Catch122; 04-02-2016 at 03:44 PM.
Catch122 is offline  
post #5 of 5 (permalink) Old 04-02-2016, 05:13 PM
You should listen to me. No, seriously, listen to me.
 
Join Date: Oct 2008
Location: Santa Barbara
Motorcycle: Blue 2006 GSX-R1000
Posts: 7,513
Re: Electronics question TPS?

My K6 isn't blessed with an ISC but I see that it has a "learned value" that can be reset by SDS. Might it have something to do with your problem? See 1A-97 in the service manual.
BillV is offline  
Sponsored Links
Advertisement
 
Reply

Quick Reply
Message:
Options

Register Now



In order to be able to post messages on the Suzuki GSX-R Motorcycle Forums Gixxer.com forums, you must first register.
Please enter your desired user name, your email address and other required details in the form below.

User Name:
Password
Please enter a password for your user account. Note that passwords are case-sensitive.

Password:


Confirm Password:
Email Address
Please enter a valid email address for yourself.

Email Address:
OR

Log-in










Thread Tools
Show Printable Version Show Printable Version
Email this Page Email this Page
Display Modes
Linear Mode Linear Mode



Posting Rules  
You may post new threads
You may post replies
You may not post attachments
You may not edit your posts

BB code is On
Smilies are On
[IMG] code is On
HTML code is Off
Trackbacks are On
Pingbacks are On
Refbacks are On

 
For the best viewing experience please update your browser to Google Chrome