Spark Plug Issue - Suzuki GSX-R Motorcycle Forums Gixxer.com

 
LinkBack Thread Tools Display Modes
post #1 of 5 (permalink) Old 03-08-2015, 08:37 AM Thread Starter
Squid
 
Join Date: Mar 2015
Posts: 1
Spark Plug Issue

I have recently serviced my L1 and changed the spark plugs NGK CR9EIA-9 and the engine was running fine prior to change but now it has a flat spot and on idle the needle is jumping any ideas?

At low revs its like bogging down and then picks up as soon as the revs go up, I have got a power commander fitted

Last edited by Derhi04; 03-08-2015 at 08:55 AM.
Derhi04 is offline  
Sponsored Links
Advertisement
 
post #2 of 5 (permalink) Old 03-08-2015, 01:34 PM
You should listen to me. No, seriously, listen to me.
 
Join Date: Oct 2008
Location: Santa Barbara
Motorcycle: Blue 2006 GSX-R1000
Posts: 7,500
Re: Spark Plug Issue

Make sure the coils are properly seated on the plugs. Off hand, it sounds like you didn't get all the hoses back where they belong.
BillV is offline  
post #3 of 5 (permalink) Old 03-10-2015, 06:16 PM
Provisional Novice
 
Join Date: Aug 2008
Posts: 134
Re: Spark Plug Issue

If everything else checks out, change all the plugs again! Unless you are able to locate a bad one by trial and error. Those Iridiums are sensitive little Fockers! If one was dropped, forget it. I've had trouble with 'em on 2 bikes already...
nightrain is offline  
Sponsored Links
Advertisement
 
post #4 of 5 (permalink) Old 03-10-2015, 07:25 PM
!##NULL##!
 
Join Date: Aug 2010
Location: Melbourne, Australia
Motorcycle: K1 1000, K7 750
Posts: 3,858
Re: Spark Plug Issue

Following on from nightrain I came across an interesting post a couple of days ago where it appears a couple of other forum members experienced problems with Iridium spark plugs.

Read post #22 which also contains a quote to an earlier post where someone experienced the same issue.

https://www.gixxer.com/forums/showthr...=272785&page=2

I had a very similar issue a few days ago after really giving my 750 some juice for a few minutes. Started experiencing hesitation, poor throttle response and power. Limped the bike back home. Took it for a ride the next day and everything seemed to be fine again.

However, no one reported a jumping tacho needle so maybe it's not the same issue. Just worth noting in case someone ends up chasing their tail and doesn't consider the spark plugs.

Last edited by kwaka10r; 03-10-2015 at 07:25 PM. Reason: forgot thread link
kwaka10r is offline  
post #5 of 5 (permalink) Old 04-01-2015, 07:52 PM
Amateur
 
Join Date: Jun 2006
Posts: 327
Re: Spark Plug Issue

Had similar issue. Chased around everything only to find the plugs that had low mileage and looked brand new were bad. Had surging idle, poor response etc.
v6stanger is offline  
Sponsored Links
Advertisement
 
Reply

Quick Reply
Message:
Options

Register Now



In order to be able to post messages on the Suzuki GSX-R Motorcycle Forums Gixxer.com forums, you must first register.
Please enter your desired user name, your email address and other required details in the form below.

User Name:
Password
Please enter a password for your user account. Note that passwords are case-sensitive.

Password:


Confirm Password:
Email Address
Please enter a valid email address for yourself.

Email Address:
OR

Log-in










Thread Tools
Show Printable Version Show Printable Version
Email this Page Email this Page
Display Modes
Linear Mode Linear Mode



Posting Rules  
You may post new threads
You may post replies
You may not post attachments
You may not edit your posts

BB code is On
Smilies are On
[IMG] code is On
HTML code is Off
Trackbacks are On
Pingbacks are On
Refbacks are On

 
For the best viewing experience please update your browser to Google Chrome