Fi light - Suzuki GSX-R Motorcycle Forums Gixxer.com

 
LinkBack Thread Tools Display Modes
post #1 of 5 (permalink) Old 05-27-2014, 11:10 PM Thread Starter
Squid
 
Join Date: May 2014
Posts: 6
Fi light

I just installed dyno jet quick shifter on my 2011 1000 track bike. Everything functions perfectly, but when I was shifting through the gears the Fi light came on. Once I got back to garage and turned bike off, I restarted it no light. Any ideas what is causing the light to come on during shifts, what could I do to fix the problem. Bike runs fine even though light is on, I'm just anal about that kinda of stuff and was wondering if anyone had any ssuggestions. Thanks in advance.
devillier2525 is offline  
Sponsored Links
Advertisement
 
post #2 of 5 (permalink) Old 05-27-2014, 11:14 PM
Ex-Lady Supermod

 
Join Date: Jul 2008
Posts: 16,129
Garage
Re: Fi light

When the light comes on, put it in dealer mode without turning off the bike or the code is lost. Search dealer mode for how-to.
Samantha750 is offline  
post #3 of 5 (permalink) Old 05-28-2014, 11:11 AM
Amateur
 
Join Date: Jun 2006
Posts: 327
Re: Fi light

Use the paperclip method to get the code. With most of these newer gixxers it usually turns out to be the set valve throwing random lights. Not sure why it would randomly flick on after a shifter install tho. Did you check all hoses and connections while you had the bike apart?
v6stanger is offline  
Sponsored Links
Advertisement
 
post #4 of 5 (permalink) Old 05-28-2014, 12:11 PM
Lifetime Premium
 
Karns Performance's Avatar
 
Join Date: May 2006
Location: pa
Motorcycle: 05 1k- sold / 2012 1k
Posts: 1,315
Re: Fi light

you need to shorten up your shift kill time to keep from throwing the light it may still do it once in awhile. (especialy when shifting at and hitting the limmiter)

btw make sure you are on the correct wires to check the code if not you could pop the ecu
i have seen it happen. (the switch is the correct way)

jason
Karns Performance is offline  
post #5 of 5 (permalink) Old 05-28-2014, 10:44 PM Thread Starter
Squid
 
Join Date: May 2014
Posts: 6
Re: Fi light

I have shortened the kill time to 35ms and still getting the light. I will try putting in dealer mode to see what code is. Thanks for the help guys. Would having the ecu flashed help. Is having it flashed worth it? Yalls thoughts.
devillier2525 is offline  
Sponsored Links
Advertisement
 
Reply

Quick Reply
Message:
Options

Register Now



In order to be able to post messages on the Suzuki GSX-R Motorcycle Forums Gixxer.com forums, you must first register.
Please enter your desired user name, your email address and other required details in the form below.

User Name:
Password
Please enter a password for your user account. Note that passwords are case-sensitive.

Password:


Confirm Password:
Email Address
Please enter a valid email address for yourself.

Email Address:
OR

Log-in










Thread Tools
Show Printable Version Show Printable Version
Email this Page Email this Page
Display Modes
Linear Mode Linear Mode



Posting Rules  
You may post new threads
You may post replies
You may not post attachments
You may not edit your posts

BB code is On
Smilies are On
[IMG] code is On
HTML code is Off
Trackbacks are On
Pingbacks are On
Refbacks are On

 
For the best viewing experience please update your browser to Google Chrome