Quick shift/ clutch prob. - Suzuki GSX-R Motorcycle Forums Gixxer.com
 
LinkBack Thread Tools Display Modes
post #1 of 10 (permalink) Old 05-19-2014, 12:21 PM Thread Starter
Track Day Winner
 
Join Date: Mar 2012
Location: Davenport Iowa
Motorcycle: 2009 gsxr1000, 2006 gsxr750 track bike
Posts: 80
Quick shift/ clutch prob.

Ok so I need some help. I have no clue as to wtf I'm doing but I'm working through this... I have an 09 1000 bazzaz zfitcqs and ive gone through two clutches the second clutch was an ebc race clutch it didn't make it around the track maybe 15 laps then I was pushing my bike back through the pits. The first time it seemed my quick shifter bolts were lose so I tightened them back up and loc tighted them. Everything seemed fine i took it up to the top of the power band while on the stand it went through the gears like butter. Rode it around the block same thing. Then race weekend comes at Saturday practice I made it through 1 session and i lost all power to the rear wheel. It seemed to have a couple of ruff shifts in there before it went I was debating on just using the clutch but it just went to shit. I Opened the clutch cover and its toast. Where do you guys think I should start? (Oh I had to ride a stock cbr1000, literally just put a body on it last week borrowed it from a friend and got second in both my races... would have won on my gixxer lol)

Sent from Motorcycle.com Free App
Cazperz is offline  
Sponsored Links
Advertisement
 
post #2 of 10 (permalink) Old 05-19-2014, 12:55 PM
Lifetime Premium
 
Moto_Joe's Avatar
 
Join Date: Apr 2002
Location: Macon Ga
Motorcycle: 2006 GSXR 600 Racebike
Posts: 117,182
Re: Quick shift/ clutch prob.

Sounds like you're not adjusting the clutch properly and burning up the clutch

Running through gears on a stand is a bad idea btw and proves nothing as the engine is not under load.

You need to replace the clutch pack and properly adjust it.



Moto_Joe is offline  
post #3 of 10 (permalink) Old 05-19-2014, 01:48 PM Thread Starter
Track Day Winner
 
Join Date: Mar 2012
Location: Davenport Iowa
Motorcycle: 2009 gsxr1000, 2006 gsxr750 track bike
Posts: 80
Re: Quick shift/ clutch prob.

I ran through them to see if the quick shifter worked. It was what bazzaz tech wanted to know. Light wasn't always turning on. How do you properly adjust it is there a how to on that? I followed the Suzuki service Manuel exactly even watched a bunch of vids all I saw about adjusting was 7lbs of torque on the springs.

Sent from Motorcycle.com Free App
Cazperz is offline  
Sponsored Links
Advertisement
 
post #4 of 10 (permalink) Old 05-19-2014, 02:20 PM
Lifetime Premium
 
Moto_Joe's Avatar
 
Join Date: Apr 2002
Location: Macon Ga
Motorcycle: 2006 GSXR 600 Racebike
Posts: 117,182
Re: Quick shift/ clutch prob.

Did you adjust the pressure plate? Cable slack? Lever end play?



Moto_Joe is offline  
post #5 of 10 (permalink) Old 05-19-2014, 02:53 PM
Amateur
 
Join Date: Jun 2006
Posts: 327
Re: Quick shift/ clutch prob.

I was advised to stay away from the ebc clutches from the tech that did the clutch in my last gixxer because they don't last. He said stick with the oem fibers and steels.

Definitely sounds like slipper adjustment is backing off.
v6stanger is offline  
post #6 of 10 (permalink) Old 05-19-2014, 03:06 PM Thread Starter
Track Day Winner
 
Join Date: Mar 2012
Location: Davenport Iowa
Motorcycle: 2009 gsxr1000, 2006 gsxr750 track bike
Posts: 80
Re: Quick shift/ clutch prob.

I didn't adjust anything really. I don't have any slack in the lever or cable its tight. What's the slipper adjustment did I miss some shit in the manual? Ive heard that about ebc. Had a shop do the clutch on my 750 last year and I asked about a better aftermarket clutch and they said I only want to use oem clutches. Idk y I went with the ebc.

Sent from Motorcycle.com Free App
Cazperz is offline  
post #7 of 10 (permalink) Old 05-19-2014, 03:16 PM
MotoGP
 
Anthony D's Avatar
 
Join Date: May 2001
Location: Jersey
Motorcycle: Whatever oldgixxer has in his garage...
Posts: 73,190
Garage
Re: Quick shift/ clutch prob.

So you put a new clutch in and didn't think to adjust it? Or did the shop put the clutch in and not adjust it?

Either way, get new oem steels and fibers, and download a factory service manual here: www.servicemanualsgsxr.com
Anthony D is offline  
post #8 of 10 (permalink) Old 05-19-2014, 04:00 PM
Lifetime Premium
 
Moto_Joe's Avatar
 
Join Date: Apr 2002
Location: Macon Ga
Motorcycle: 2006 GSXR 600 Racebike
Posts: 117,182
Quick shift/ clutch prob.

If the lever and cable are tight that is why it is slipping and likely burnt up

The slipper adjustment is for back
Torque not forward driving.

You likely went ebc because it saved a few bucks. Learned that lesson the hard way didn't ya? Lol. Oem works best



Moto_Joe is offline  
post #9 of 10 (permalink) Old 05-19-2014, 05:34 PM Thread Starter
Track Day Winner
 
Join Date: Mar 2012
Location: Davenport Iowa
Motorcycle: 2009 gsxr1000, 2006 gsxr750 track bike
Posts: 80
Re: Quick shift/ clutch prob.

I think that was my prob it seemed like the friction zone was pushed all the way to the start of the pull also. And yes i put it in and didn't even know about adjusting it... oops 250$ lesson like I said I really have no clue what I'm doing and trying to learn this shit as I go and don't have the budget to run to the shop for everything. I got the ebc because i talked to a guy who I don't think really knew and saw the word race on the title and said ill get you this. Im definitely ordering an oem and have another go at it. Thanks guys.

Sent from Motorcycle.com Free App
Cazperz is offline  
post #10 of 10 (permalink) Old 06-08-2014, 05:20 PM Thread Starter
Track Day Winner
 
Join Date: Mar 2012
Location: Davenport Iowa
Motorcycle: 2009 gsxr1000, 2006 gsxr750 track bike
Posts: 80
Re: Quick shift/ clutch prob.

Ok new kit I was short a steel so I just used an old one it wasn't warped or anything. But the Manuel is shit when it comes to adjusting this thing. I did the screw thing in the mid and the three lifter thingys but its still not disengaging the engine when I pull it in while in gear what am I missing?

Sent from Motorcycle.com Free App
Cazperz is offline  
Sponsored Links
Advertisement
 
Reply

Quick Reply
Message:
Options

Register Now



In order to be able to post messages on the Suzuki GSX-R Motorcycle Forums Gixxer.com forums, you must first register.
Please enter your desired user name, your email address and other required details in the form below.

User Name:
Password
Please enter a password for your user account. Note that passwords are case-sensitive.

Password:


Confirm Password:
Email Address
Please enter a valid email address for yourself.

Email Address:
OR

Log-in










Thread Tools
Show Printable Version Show Printable Version
Email this Page Email this Page
Display Modes
Linear Mode Linear Mode



Posting Rules  
You may post new threads
You may post replies
You may not post attachments
You may not edit your posts

BB code is On
Smilies are On
[IMG] code is On
HTML code is Off
Trackbacks are On
Pingbacks are On
Refbacks are On

 
For the best viewing experience please update your browser to Google Chrome