PC-V - Fi light - Suzuki GSX-R Motorcycle Forums Gixxer.com

 
LinkBack Thread Tools Display Modes
post #1 of 14 (permalink) Old 08-19-2013, 07:18 AM Thread Starter
Squid
 
Join Date: Aug 2013
Location: Nelspruit, South Africa
Motorcycle: Gsxr1000 2010 , KTM300xc-w 07
Posts: 13
PC-V - Fi light

I bought a second Hand GSXR1000 k0 about a year ago, shes only got 12000km's on, its got a pc v with auto tuner and quick shifter fitted, the qs was "disable" via the software. I reconnected this only to find that at high speed hi rpm the Fi light would come on, bike still performs well but there is a hesitation just as you open the throttle or slow riding in traffic, decided to connect it up to the Suzuki diagnostic software and I get a message "ignition coil 1,2,3,4 faulty!!, then clear the DTC turn the ignition off and back on Fi light gone!, until you ride it hard again. contacted our powercommander importer to report the problem, he says yes all Suzuki's have this problem as the ignition coils push out a higher voltage at high rpm, so with the Pcv fitted it interrupts the spark telling the cdi there is a coil fault illuminating the Fi light. possible fix?? NONE!! either remove the PC or live with it!, any one els have the same issue or is there a remedy to this dilemma??
Robere is offline  
Sponsored Links
Advertisement
 
post #2 of 14 (permalink) Old 08-19-2013, 07:51 AM
Lifetime Premium
 
Karns Performance's Avatar
 
Join Date: May 2006
Location: pa
Motorcycle: 05 1k- sold / 2012 1k
Posts: 1,315
Re: PC-V - Fi light

there isnt a problem with the gsxr the qs kill time is to long you must set the kill time less than .60 seconds normaly it works well in the .5 range.

jason
Karns Performance is offline  
post #3 of 14 (permalink) Old 08-19-2013, 08:09 AM Thread Starter
Squid
 
Join Date: Aug 2013
Location: Nelspruit, South Africa
Motorcycle: Gsxr1000 2010 , KTM300xc-w 07
Posts: 13
Re: PC-V - Fi light

okay!, ill check quick and report back what the settings are currently!! thanx
Robere is offline  
Sponsored Links
Advertisement
 
post #4 of 14 (permalink) Old 08-19-2013, 08:41 AM Thread Starter
Squid
 
Join Date: Aug 2013
Location: Nelspruit, South Africa
Motorcycle: Gsxr1000 2010 , KTM300xc-w 07
Posts: 13
Re: PC-V - Fi light

kill was set to 60sec have now changed it to 40!, really hope this works!, will check on the way home tonight after work!!
Robere is offline  
post #5 of 14 (permalink) Old 08-20-2013, 12:47 AM Thread Starter
Squid
 
Join Date: Aug 2013
Location: Nelspruit, South Africa
Motorcycle: Gsxr1000 2010 , KTM300xc-w 07
Posts: 13
Re: PC-V - Fi light

ok so after resetting the kill time, tested on the way home yesterday and NO luck still the same!, ride the bike hard and the FI light illuminates!!, now what? set the kill time even lower like maybe 25 or 30??
Robere is offline  
post #6 of 14 (permalink) Old 08-20-2013, 01:10 AM
I dont love OG's cack anymore
 
Travis V's Avatar
 
Join Date: Mar 2012
Posts: 1,590
Garage
Re: PC-V - Fi light

But it is "hesitating" so that's no good


Sent from Motorcycle.com Free App
Travis V is offline  
post #7 of 14 (permalink) Old 08-20-2013, 01:45 AM Thread Starter
Squid
 
Join Date: Aug 2013
Location: Nelspruit, South Africa
Motorcycle: Gsxr1000 2010 , KTM300xc-w 07
Posts: 13
Re: PC-V - Fi light

yip!, just off throttle there is a delay, very irritating in traffic, will just have to keep on trying I guess!
Robere is offline  
post #8 of 14 (permalink) Old 08-20-2013, 07:13 AM
Lifetime Premium
 
Karns Performance's Avatar
 
Join Date: May 2006
Location: pa
Motorcycle: 05 1k- sold / 2012 1k
Posts: 1,315
Re: PC-V - Fi light

check to make sure the rev extend and is disabled in the configuration screen i had a problem with that before and spent several hours to find - and also make sure the firmware is updated

jason
Karns Performance is offline  
post #9 of 14 (permalink) Old 08-20-2013, 08:39 AM Thread Starter
Squid
 
Join Date: Aug 2013
Location: Nelspruit, South Africa
Motorcycle: Gsxr1000 2010 , KTM300xc-w 07
Posts: 13
Re: PC-V - Fi light

hey dude I need layman's terms here, my hamster is currently not running on its wheel!, nearly home time!, I did a firmware update yesterday with the first attempt!!
Robere is offline  
post #10 of 14 (permalink) Old 08-20-2013, 03:08 PM
Expert
 
JP1143's Avatar
 
Join Date: Dec 2006
Location: Texas
Motorcycle: K4 1143, L2 1K
Posts: 1,993
Garage
Re: PC-V - Fi light

Quote:
Originally Posted by Robere View Post
hey dude I need layman's terms here, my hamster is currently not running on its wheel!, nearly home time!, I did a firmware update yesterday with the first attempt!!
JP1143 is offline  
post #11 of 14 (permalink) Old 08-20-2013, 03:58 PM
I dont love OG's cack anymore
 
Travis V's Avatar
 
Join Date: Mar 2012
Posts: 1,590
Garage
Re: PC-V - Fi light

I had problems big time with a fresh PC-V and autotune since the firmware was out of date. Do an update - You could also have a bad PC-V I would email or call powercommander directly if you have any problems!

An update may update the coil drivers to prevent your current problem
Travis V is offline  
post #12 of 14 (permalink) Old 08-20-2013, 09:14 PM
Lifetime Premium
 
Karns Performance's Avatar
 
Join Date: May 2006
Location: pa
Motorcycle: 05 1k- sold / 2012 1k
Posts: 1,315
Re: PC-V - Fi light

give their tech dept a call they can walk you through the software.

jason
Karns Performance is offline  
post #13 of 14 (permalink) Old 08-31-2013, 05:44 PM
!##NULL##!
 
rraiderr's Avatar
 
Join Date: Jun 2004
Location: Share a room with Motojoe
Motorcycle: Stretched and slammed Busa
Posts: 14,060
Re: PC-V - Fi light

The latest firmware for the PCV is

V1.10.5 with a date of 07/31/2013

You may want to check to see if you are up to date.
rraiderr is offline  
post #14 of 14 (permalink) Old 09-06-2013, 12:55 PM
Squid
 
Join Date: Sep 2008
Posts: 6
Re: PC-V - Fi light

I had the exact same problem,in any gear getting near the redline, i would get a FI light for an injector fault, sometimes just 1 injector, sometimes all 4.

Dynojet UK also said its a problem with Suzukis injectors being "Too Sensitive" which is complete bollocks as i had six months of trouble free riding with it installed and it never threw a fault, just started doing it oneday for no reason.

Never did find a fix for it
NixK7 is offline  
Sponsored Links
Advertisement
 
Reply

Quick Reply
Message:
Options

Register Now



In order to be able to post messages on the Suzuki GSX-R Motorcycle Forums Gixxer.com forums, you must first register.
Please enter your desired user name, your email address and other required details in the form below.

User Name:
Password
Please enter a password for your user account. Note that passwords are case-sensitive.

Password:


Confirm Password:
Email Address
Please enter a valid email address for yourself.

Email Address:
OR

Log-in










Thread Tools
Show Printable Version Show Printable Version
Email this Page Email this Page
Display Modes
Linear Mode Linear Mode



Posting Rules  
You may post new threads
You may post replies
You may not post attachments
You may not edit your posts

BB code is On
Smilies are On
[IMG] code is On
HTML code is Off
Trackbacks are On
Pingbacks are On
Refbacks are On

 
For the best viewing experience please update your browser to Google Chrome