Dash not working.... I Armi'd it 👀 - Suzuki GSX-R Motorcycle Forums Gixxer.com

 
LinkBack Thread Tools Display Modes
post #1 of 14 (permalink) Old 04-14-2019, 07:14 PM Thread Starter
Lifetime Premium
 
Armi's Avatar
 
Join Date: Aug 2009
Location: london,uk
Motorcycle: gsxr 750 srad with a few mods thanks to the members on this site.See signature.
Posts: 9,717
Dash not working.... I Armi'd it 👀

Hey chaps.... Been a long time.
Forgive me if asked before I promise I did a search cos I know how you guys are 👀
I'm using the phone and can't seem to find what I'm looking for..... Its been awhile.

The video should explain the problem.

Just to give you a heads up.... All was working well until I noticed a loose wire (for the halos on after market lights from the inverter).
Well stupidly I connected said wire to another wire that was loose (I know I'm stupid &#x1f440 and since then the dash doesn't work.
Headlight works... Front indicators, rear lights and horn doesn't.,as well as the dash!
I've replaced all the Fuses on the left side of the bike as well as cleaned the white plug on the left side too.

Just need a little direction please.... I know I'll get slated for doing what I did but I'm used to that and accept this is GDC 😊

I've spent many years here previous to this post 😂
And now I hold my breath 😂👀

OK.... Just realised I can't post a video,... Or probably don't know how 🙄
But here's the bike...
OK I can't seem to do that either 🙄

I should get some rest......

Look forward to..... and appreciate any input chaps... Cheers


To view links or images in signatures your post count must be 10 or greater. You currently have 0 posts.

K6 thou forks/"K Tec" Springs, Brembo 19x20 RCS m/c, R1 calipers, Hel ss lines, DID x ring gold chain, Sudco full exhaust, BMC filter, Gilles rearsets, Factory Pro engine covers, Samco Hoses, GPR steering damper, Yoshi MJN Jet kit thanks to our resident carb Ninja
To view links or images in signatures your post count must be 10 or greater. You currently have 0 posts.
CCMHUNT!'04 CRF 450R for giggles
To view links or images in signatures your post count must be 10 or greater. You currently have 0 posts.
Armi is offline  
Sponsored Links
Advertisement
 
post #2 of 14 (permalink) Old 04-14-2019, 07:23 PM
Vegemite-eating Administrator...
 
8you4t's Avatar
 
Join Date: Nov 2010
Location: Gippsland AUSTRALIA
Motorcycle: 2003 gsxr1000 ,2002 gsxr600 ,2008 gsxr600 ,2002 gsxr750 ,2006 CBR1000RR ,2001 CBR1100xx ,2001 CBR929rr ,2002 VTR1000f ,2008 FZ1 ,2002 SV650s
Posts: 12,401
Re: Dash not working.... I Armi'd it 👀

Heeeee’s baaaack !!!
8you4t is offline  
post #3 of 14 (permalink) Old 04-14-2019, 07:33 PM Thread Starter
Lifetime Premium
 
Armi's Avatar
 
Join Date: Aug 2009
Location: london,uk
Motorcycle: gsxr 750 srad with a few mods thanks to the members on this site.See signature.
Posts: 9,717
Ah.... You remember 👊👌🍻🍻🍻
Armi is offline  
Sponsored Links
Advertisement
 
post #4 of 14 (permalink) Old 04-14-2019, 09:31 PM
Vegemite-eating Administrator...
 
8you4t's Avatar
 
Join Date: Nov 2010
Location: Gippsland AUSTRALIA
Motorcycle: 2003 gsxr1000 ,2002 gsxr600 ,2008 gsxr600 ,2002 gsxr750 ,2006 CBR1000RR ,2001 CBR1100xx ,2001 CBR929rr ,2002 VTR1000f ,2008 FZ1 ,2002 SV650s
Posts: 12,401
Re: Dash not working.... I Armi'd it 👀

Are you trying to use emojis??
8you4t is offline  
post #5 of 14 (permalink) Old 04-15-2019, 12:23 AM Thread Starter
Lifetime Premium
 
Armi's Avatar
 
Join Date: Aug 2009
Location: london,uk
Motorcycle: gsxr 750 srad with a few mods thanks to the members on this site.See signature.
Posts: 9,717
Don't they work???
Armi is offline  
post #6 of 14 (permalink) Old 04-15-2019, 02:21 AM
Vegemite-eating Administrator...
 
8you4t's Avatar
 
Join Date: Nov 2010
Location: Gippsland AUSTRALIA
Motorcycle: 2003 gsxr1000 ,2002 gsxr600 ,2008 gsxr600 ,2002 gsxr750 ,2006 CBR1000RR ,2001 CBR1100xx ,2001 CBR929rr ,2002 VTR1000f ,2008 FZ1 ,2002 SV650s
Posts: 12,401
Re: Dash not working.... I Armi'd it 👀

Quote:
Originally Posted by Armi View Post
Don't they work???
No ...
8you4t is offline  
post #7 of 14 (permalink) Old 04-15-2019, 02:27 AM Thread Starter
Lifetime Premium
 
Armi's Avatar
 
Join Date: Aug 2009
Location: london,uk
Motorcycle: gsxr 750 srad with a few mods thanks to the members on this site.See signature.
Posts: 9,717
Shows how long I've been away lol.... I can't find those emoli's I've used in the past....
Great to hear from you BTW buddy.
Armi is offline  
post #8 of 14 (permalink) Old 04-15-2019, 02:33 AM
Vegemite-eating Administrator...
 
8you4t's Avatar
 
Join Date: Nov 2010
Location: Gippsland AUSTRALIA
Motorcycle: 2003 gsxr1000 ,2002 gsxr600 ,2008 gsxr600 ,2002 gsxr750 ,2006 CBR1000RR ,2001 CBR1100xx ,2001 CBR929rr ,2002 VTR1000f ,2008 FZ1 ,2002 SV650s
Posts: 12,401
Re: Dash not working.... I Armi'd it 👀

Same dude ... been ages

If you want the forum emojis click advanced and it will be on the right side
8you4t is offline  
post #9 of 14 (permalink) Old 04-15-2019, 03:57 AM
You should listen to me. No, seriously, listen to me.
 
Join Date: Oct 2008
Location: Santa Barbara
Motorcycle: Blue 2006 GSX-R1000
Posts: 7,149
Re: Dash not working.... I Armi'd it 👀

I hope you have a multimeter. I also gather that the bike runs. Measure the voltage at the O/G lead at the horn when the ignition switch is ON. The horn can be disconnected for this. It should be 12 V. It sounds like it isn't but we need to know for sure. If it isn't, measure the voltage on both sides of the SIGNAL fuse (fuse should be in place). Report back.
BillV is offline  
post #10 of 14 (permalink) Old 04-15-2019, 06:57 AM Thread Starter
Lifetime Premium
 
Armi's Avatar
 
Join Date: Aug 2009
Location: london,uk
Motorcycle: gsxr 750 srad with a few mods thanks to the members on this site.See signature.
Posts: 9,717
Thanks for your input buddy..... I shall try do that over the weekend and report back.
Much obliged..... Cheers!
Armi is offline  
post #11 of 14 (permalink) Old 04-15-2019, 06:59 AM Thread Starter
Lifetime Premium
 
Armi's Avatar
 
Join Date: Aug 2009
Location: london,uk
Motorcycle: gsxr 750 srad with a few mods thanks to the members on this site.See signature.
Posts: 9,717
8you4t.....i would of I knew where the advanced button is..... I can't even quote your reply like I used to be able to.... WTF lol.... I had to screenshot it....
Attached Images
File Type: jpg Screenshot_20190415-125808_Chrome_1555329567812.jpg (491.4 KB, 5 views)
Armi is offline  
post #12 of 14 (permalink) Old 04-15-2019, 07:14 AM
Vegemite-eating Administrator...
 
8you4t's Avatar
 
Join Date: Nov 2010
Location: Gippsland AUSTRALIA
Motorcycle: 2003 gsxr1000 ,2002 gsxr600 ,2008 gsxr600 ,2002 gsxr750 ,2006 CBR1000RR ,2001 CBR1100xx ,2001 CBR929rr ,2002 VTR1000f ,2008 FZ1 ,2002 SV650s
Posts: 12,401
Re: Dash not working.... I Armi'd it 👀

Yeah I use the desk top view/page .... heaps better IMO
8you4t is offline  
post #13 of 14 (permalink) Old 04-15-2019, 06:37 PM Thread Starter
Lifetime Premium
 
Armi's Avatar
 
Join Date: Aug 2009
Location: london,uk
Motorcycle: gsxr 750 srad with a few mods thanks to the members on this site.See signature.
Posts: 9,717
Quick update...... Bought some new fuses, even though I replaced them with spare ones I had in the house, as a precaution not thinking it would make a difference.
It only bloody well did...... As a certain Italian would say, "I very appy" 🙂
Armi is offline  
post #14 of 14 (permalink) Old 04-18-2019, 06:53 PM
Lifetime Premium
 
closetotheedge's Avatar
 
Join Date: Apr 2004
Location: Sydney Australia
Motorcycle: K4 1000
Posts: 1,511
Re: Dash not working.... I Armi'd it 👀

Interesting it even cranked, my young blokes K6 wouldn't start when his dash lights ect didn't work a few weeks ago, changes a 10amp fuse and presto. He has blown the same fuse once since then + 2500k's, yours cranking suggests a bigger problem then I suspect with my sons.
closetotheedge is offline  
Sponsored Links
Advertisement
 
Reply

Quick Reply
Message:
Options

Register Now



In order to be able to post messages on the Suzuki GSX-R Motorcycle Forums Gixxer.com forums, you must first register.
Please enter your desired user name, your email address and other required details in the form below.

User Name:
Password
Please enter a password for your user account. Note that passwords are case-sensitive.

Password:


Confirm Password:
Email Address
Please enter a valid email address for yourself.

Email Address:
OR

Log-in










Thread Tools
Show Printable Version Show Printable Version
Email this Page Email this Page
Display Modes
Linear Mode Linear Mode



Similar Threads
Thread Thread Starter Forum Replies Last Post
New HM M3 dash on K6 1000 - custome wiring needed mugget 05-06 GSX-R1000 0 10-11-2018 12:25 AM
gsxr 600 srad headlight not working gary5661 SRADs (97-00 600 and 96-99 750) 5 04-12-2014 03:34 PM
Dash no lights, bike won't start. Please HELP!!! stask1 06-07 GSX-R600/750 4 04-04-2010 03:01 PM
gsxr 600 k6 dash not working PLEASE HELP! tomn1988 06-07 GSX-R600/750 4 01-21-2010 03:50 AM
Sensor or Dash? Squigs 04-05 GSX-R600/750 13 10-25-2009 08:39 PM

Posting Rules  
You may post new threads
You may post replies
You may not post attachments
You may not edit your posts

BB code is On
Smilies are On
[IMG] code is On
HTML code is Off
Trackbacks are On
Pingbacks are On
Refbacks are On

 
For the best viewing experience please update your browser to Google Chrome