Engine turning off while riding - Suzuki GSX-R Motorcycle Forums Gixxer.com

 
LinkBack Thread Tools Display Modes
post #1 of 10 (permalink) Old 04-19-2019, 07:52 PM Thread Starter
Squid
 
Join Date: Dec 2018
Posts: 2
Engine turning off while riding

Hello everyone new in the forum my bike is a 2003 gsxr 1000 I had it for about 7 year. Last year while riding the engine turn of at 6000 rpms as soon goes down that 6000 turn on again does not let me past 6000rpm in any gear , I had switched the fuel pump, eliminated the SET. I will appreciate any help to find out what is wrong thanks
Ftarqui is offline  
Sponsored Links
Advertisement
 
post #2 of 10 (permalink) Old 04-19-2019, 10:36 PM
Currently using pedals..
 
tatersalad314's Avatar
 
Join Date: May 2015
Location: Texas
Motorcycle: L5 600
Posts: 2,979
You switched the fuel pump, but did you test either of them?
tatersalad314 is offline  
post #3 of 10 (permalink) Old 04-20-2019, 01:27 AM
You should listen to me. No, seriously, listen to me.
 
Join Date: Oct 2008
Location: Santa Barbara
Motorcycle: Blue 2006 GSX-R1000
Posts: 7,228
Re: Engine turning off while riding

Does it bog down or is there a sharp cut-off at 6000?

I'm thinking kickstand switch, secondary throttle, or fuel filter but we need more information.
BillV is offline  
Sponsored Links
Advertisement
 
post #4 of 10 (permalink) Old 04-20-2019, 05:15 AM
Provisional Novice
 
nosurrenda's Avatar
 
Join Date: Jun 2018
Posts: 109
Garage
Re: Engine turning off while riding

I'm gonna say he put the fuel line on back to front, 'cos that's what I did once and got the same symptoms.
nosurrenda is online now  
post #5 of 10 (permalink) Old 04-23-2019, 12:22 PM Thread Starter
Squid
 
Join Date: Dec 2018
Posts: 2
Hello, yes I tested the fuel pumps and the line, replace fuel filter. Now the bike as soon reach 6000RPM it does bog down and after several seconds turn on again while is doing this shows a check on the screen but went I put it on dealer mod is not giving me codes at all just -C00 thanks
Ftarqui is offline  
post #6 of 10 (permalink) Old 04-23-2019, 03:00 PM
Lifetime Premium
 
closetotheedge's Avatar
 
Join Date: Apr 2004
Location: Sydney Australia
Motorcycle: K4 1000 K6 1000
Posts: 1,523
Re: Engine turning off while riding

I had a similar problem recently, I posted I thought it was the pump but I should have posted filter. I couldn't be bothered stuffing around changing a filter so I covered all bases and installed a new pump and filter.
I reckon that paper filter causes big problems as they age.
closetotheedge is offline  
post #7 of 10 (permalink) Old 04-23-2019, 03:05 PM
You should listen to me. No, seriously, listen to me.
 
Join Date: Oct 2008
Location: Santa Barbara
Motorcycle: Blue 2006 GSX-R1000
Posts: 7,228
Re: Engine turning off while riding

"while is doing this shows a check on the screen but went I put it on dealer mod is not giving me codes at all just -C00"
That's because you're shutting the bike off to put it in dealer mode. That causes the codes to be cleared. You must keep it running. One way is to locate the switch where you can reach it without turning anything off. If you're certain that you're not experiencing any overheating issues, you can just leave it in dealer mode while you ride.

How did you test the fuel pumps? You should have performed a flow rate test as is described in the service manual.

"replace fuel filter" Which one, the strainer at the bottom or the real/main filter?
BillV is offline  
post #8 of 10 (permalink) Old 04-24-2019, 09:47 AM
I know things... A lot of things.
 
Join Date: Feb 2015
Motorcycle: GSXR 750 K4
Posts: 2,989
Re: Engine turning off while riding

Quote:
Originally Posted by Ftarqui View Post
... while is doing this shows a check on the screen but went I put it on dealer mod is not giving me codes at all just -C00
I read that as "the dash shows CHEC while the bike is bogging down". If that is the case then it makes Bill's "faulty kickstand switch" (or similar electrical/wiring failure) more probable.
dpapavas is offline  
post #9 of 10 (permalink) Old 04-24-2019, 12:16 PM
Provisional Novice
 
Kartel's Avatar
 
Join Date: Nov 2013
Location: Manchester, U.K.
Motorcycle: GSX-R1000 K4
Posts: 249
Re: Engine turning off while riding

When my spring of the kickstand got loose my bike could cut off but not at any particular rpm, it was just intermittent, once the soldering where alarm was put into the circuit caused similar problems but again not at any particular rpm...
Kartel is offline  
post #10 of 10 (permalink) Old 04-24-2019, 12:31 PM
Likes Diiiiiiiiiiiiiiicks
 
Just_Nick's Avatar
 
Join Date: Jul 2009
Motorcycle: 2006 GSXR "250"
Posts: 3,763
Garage
Re: Engine turning off while riding

Quote:
Originally Posted by Ftarqui View Post
Hello, yes I tested the fuel pumps and the line, replace fuel filter. Now the bike as soon reach 6000RPM it does bog down and after several seconds turn on again while is doing this shows a check on the screen but went I put it on dealer mod is not giving me codes at all just -C00 thanks
Did you actually replace the filter, or are you calling the strainer on the fuel pump the filter? Because it's not.
And what actual diagnostic steps did you do before deciding to just throw in the pump?
Just_Nick is offline  
Sponsored Links
Advertisement
 
Reply

Quick Reply
Message:
Options

Register Now



In order to be able to post messages on the Suzuki GSX-R Motorcycle Forums Gixxer.com forums, you must first register.
Please enter your desired user name, your email address and other required details in the form below.

User Name:
Password
Please enter a password for your user account. Note that passwords are case-sensitive.

Password:


Confirm Password:
Email Address
Please enter a valid email address for yourself.

Email Address:
OR

Log-in










Thread Tools
Show Printable Version Show Printable Version
Email this Page Email this Page
Display Modes
Linear Mode Linear Mode



Similar Threads
Thread Thread Starter Forum Replies Last Post
bought '05 Gsxr 600 yesterday, started dying after turning off, then riding DMacK24 04-05 GSX-R600/750 8 06-20-2016 04:55 AM
2nd gear slipping... I'm pulling the engine and going in! ShawnColorado 01-03 600 and 00-03 750 24 11-16-2015 06:14 PM
Urban Guerrilla... Riding in Traffic (daily commute) Beaker The Starting Line< ======= 2 05-04-2008 02:17 AM
Anticipation - start of the season superflytnt Club Racer 29 01-29-2004 12:39 PM
OK, the skinny on engine break-in(Long) fun2fly F.A.Q. 8 05-01-2002 11:05 PM

Posting Rules  
You may post new threads
You may post replies
You may not post attachments
You may not edit your posts

BB code is On
Smilies are On
[IMG] code is On
HTML code is Off
Trackbacks are On
Pingbacks are On
Refbacks are On

 
For the best viewing experience please update your browser to Google Chrome