GSX-R 1000 k4 problem video here - Suzuki GSX-R Motorcycle Forums Gixxer.com
 
LinkBack Thread Tools Display Modes
post #1 of 13 (permalink) Old 11-05-2015, 03:17 AM Thread Starter
Squid
 
Join Date: Nov 2015
Posts: 4
GSX-R 1000 k4 problem video here

https://www.youtube.com/watch?v=9SjYRedT5Hc

What should I do? Where to find fault? How to fix it?
eMule0 is offline  
Sponsored Links
Advertisement
 
post #2 of 13 (permalink) Old 11-05-2015, 04:11 AM
MotoGP
 
Anthony D's Avatar
 
Join Date: May 2001
Location: Jersey
Motorcycle: Whatever oldgixxer has in his garage...
Posts: 73,190
Garage
Re: GSX-R 1000 k4 problem video here

The fact that it says "chec" on the dash leads me to think it is the kickstand switch.
Anthony D is offline  
post #3 of 13 (permalink) Old 11-05-2015, 06:05 AM Thread Starter
Squid
 
Join Date: Nov 2015
Posts: 4
Re: GSX-R 1000 k4 problem video here

kickstand is OK, kilswitch too. In service, no one knows where the problem is. I apologize for the translation, my English is poor.
eMule0 is offline  
Sponsored Links
Advertisement
 
post #4 of 13 (permalink) Old 11-05-2015, 06:35 AM
MotoGP
 
Anthony D's Avatar
 
Join Date: May 2001
Location: Jersey
Motorcycle: Whatever oldgixxer has in his garage...
Posts: 73,190
Garage
Re: GSX-R 1000 k4 problem video here

"chec" indicates that is ecu isn't receiving any communication.

Check your stop/run switch, and your fuses as well.
Anthony D is offline  
post #5 of 13 (permalink) Old 11-05-2015, 07:22 AM Thread Starter
Squid
 
Join Date: Nov 2015
Posts: 4
Re: GSX-R 1000 k4 problem video here

stop/run switch is OK i have new wires and kickstand is disconnected. Maybe it does FUEL PUMP FAN SWITCH RELAY or Flasher relay...., but I dont know
eMule0 is offline  
post #6 of 13 (permalink) Old 11-05-2015, 09:17 AM
I know things... A lot of things.
 
Join Date: Feb 2015
Motorcycle: GSXR 750 K4
Posts: 3,063
Re: GSX-R 1000 k4 problem video here

There's a posibility that the various switches, esp. the kickstand switch test fine while the bike is stationary, but fail at certain circumstances, for instance due to bumps and a weak stand spring or due to resonance at certain rpms. It might be a good idea to try and isolate the switch entirely, by temporarily disconnecting it and jumping the wires manually. Just don't hack up the wiring in the process, be extra careful while riding and don't leave it like that permanently, if it works.
dpapavas is online now  
post #7 of 13 (permalink) Old 11-05-2015, 10:15 AM Thread Starter
Squid
 
Join Date: Nov 2015
Posts: 4
Re: GSX-R 1000 k4 problem video here

Kickstand is disconnect, but the wires are connected as if they stand functioned. The problem is somewhere in the circuit switching box, killswitch and relays fuel. How to proceed in removing the problem? Will be resolved through exchange relays?
eMule0 is offline  
post #8 of 13 (permalink) Old 11-12-2015, 01:17 PM
Squid
 
Join Date: Oct 2015
Location: Galicia, Spain
Motorcycle: GSX-R 1000 K4
Posts: 1
Re: GSX-R 1000 k4 problem video here

regulator probably?
Märtönen is offline  
post #9 of 13 (permalink) Old 01-22-2016, 11:47 PM
Provisional Novice
 
Join Date: May 2010
Location: Europe
Motorcycle: GSXR 1000 K4
Posts: 120
Re: GSX-R 1000 k4 problem video here

I bet it's the fuel pump relay. I had the same issue with my K1 1000, changed the relay and it was all good.
g-powerr is offline  
post #10 of 13 (permalink) Old 03-15-2016, 09:02 PM
Track Day Winner
 
Join Date: Feb 2009
Location: Jamestown, N.D.
Motorcycle: K4 1K
Posts: 49
Re: GSX-R 1000 k4 problem video here

Any news on the issue? I think I am having the same or similar issue.
Isdera112i is offline  
post #11 of 13 (permalink) Old 03-16-2016, 04:09 PM
You should listen to me. No, seriously, listen to me.
 
Join Date: Oct 2008
Location: Santa Barbara
Motorcycle: Blue 2006 GSX-R1000
Posts: 7,514
Re: GSX-R 1000 k4 problem video here

^What are the symptoms when it dies? Does the cluster get power? What is displayed on the cluster's LCD panel. Are you in neutral and does the neutral light come on? Does the fuel pump prime?
BillV is offline  
post #12 of 13 (permalink) Old 03-16-2016, 07:21 PM
Not the powers that be, not even close.
 
600k2's Avatar
 
Join Date: Jun 2009
Motorcycle: 600k2
Posts: 23,062
Re: GSX-R 1000 k4 problem video here

My ECU flaked out once on me. Bike shut off while riding, I had chec displayed with key and kill switches on, fuel pump did not prime but the engine would crank. The ECU was not commanding the fuel pump relay on and not communicating with the instrument panel. The bike would not enter dealer mode either.

This happened to me:

https://www.gixxer.com/forums/18-01-0...t-restart.html
600k2 is offline  
post #13 of 13 (permalink) Old 03-17-2016, 06:09 PM
Squid
 
Join Date: Dec 2012
Posts: 16
Re: GSX-R 1000 k4 problem video here

Check the two connectors going into the ECU and the ECU connector pins for corrosion.

Water can get in there from washing, or riding in the rain. I pulled mine out last year to inspect and there was significant corrosion, but not failing yet.

My 99 R1 corrosion went to far before I noticed, and had to buy new ECU.
vanherk is offline  
Sponsored Links
Advertisement
 
Reply

Quick Reply
Message:
Options

Register Now



In order to be able to post messages on the Suzuki GSX-R Motorcycle Forums Gixxer.com forums, you must first register.
Please enter your desired user name, your email address and other required details in the form below.

User Name:
Password
Please enter a password for your user account. Note that passwords are case-sensitive.

Password:


Confirm Password:
Email Address
Please enter a valid email address for yourself.

Email Address:
OR

Log-in










Thread Tools
Show Printable Version Show Printable Version
Email this Page Email this Page
Display Modes
Linear Mode Linear Mode



Posting Rules  
You may post new threads
You may post replies
You may not post attachments
You may not edit your posts

BB code is On
Smilies are On
[IMG] code is On
HTML code is Off
Trackbacks are On
Pingbacks are On
Refbacks are On

 
For the best viewing experience please update your browser to Google Chrome