TURBO Question. - Suzuki GSX-R Motorcycle Forums Gixxer.com

 
LinkBack Thread Tools Display Modes
post #1 of 15 (permalink) Old 03-16-2007, 05:34 AM Thread Starter
Provisional Novice
 
payday's Avatar
 
Join Date: Apr 2005
Location: P.G., MD
Motorcycle: 05/GSX-R1000
Posts: 140
TURBO Question.

What did you turbo guys do with map (air ) sensor, and the 2 hoses from the air box. 1 to the pair, and the other goes to something else.
payday is offline  
Sponsored Links
Advertisement
 
post #2 of 15 (permalink) Old 03-17-2007, 12:18 PM
Expert
 
SmurfOnAGixxer's Avatar
 
Join Date: May 2004
Location: Detroit, MI/Miami/Lake Havasu City, AZ
Motorcycle: 38 Scarab AVS 1800HP, Bikeless until winter
Posts: 2,885
Re: TURBO Question.

I tapped a hole and installed the air sensor into the plenum. The Pair system I removed completely. I put a check valve on the hose coming from the crankcase.
SmurfOnAGixxer is offline  
post #3 of 15 (permalink) Old 03-19-2007, 07:15 AM Thread Starter
Provisional Novice
 
payday's Avatar
 
Join Date: Apr 2005
Location: P.G., MD
Motorcycle: 05/GSX-R1000
Posts: 140
Re: TURBO Question.

Don't mean to be repetitive. But

the sensor you tapped was the AIT air temp sensor right.

And the one with the check valve is the one from the back of the air box that goes into a box in the bottom of the motor (ie. crankcase you said).

? what about the MAP sensor I believe that is t'd to each of the throttle bodies. do you just leave that one alone.

? Did you cover your pair holes on the valve cover with plugs, or left them open.

And lastly, (P.S. thanks for the help) If the MAP reads boost won't it throw a check engine light.

WHERE THE HELL DO I GET A CHECK VALVE FROM.
AUTO PARTS STORES I GO TO I DON'T SEE THEM.
PEPBOYS, ADVANCED, AND A COUPLE OTHER. I EVEN TRIED LOOKING ONLINE.

THANKS AGAIN.

There is no such thing as TOO FAST.
just TOO HIGH.
payday is offline  
Sponsored Links
Advertisement
 
post #4 of 15 (permalink) Old 03-19-2007, 02:06 PM
Track Day Winner
 
Join Date: Jul 2006
Location: Luton . UK
Motorcycle: Gsxr 750 '99'
Posts: 32
Re: TURBO Question.

Hi mate

With mine i t'd off the t/body vacume lines and rand it straight to the mapsensor, but also t'd off to athmosphere just before the map sensor. Also use a check valve in the athmosphere line.

I found that without the athmosphere line, when it sensed positive pressure it threw up a FI Light.

If you want il post up a quick diagram of what i mean

Hope that helps
Taner is offline  
post #5 of 15 (permalink) Old 03-19-2007, 11:41 PM Thread Starter
Provisional Novice
 
payday's Avatar
 
Join Date: Apr 2005
Location: P.G., MD
Motorcycle: 05/GSX-R1000
Posts: 140
Re: TURBO Question.

I believe that that is everything guys. my local speed shop after looking through a couple of their catalogs were able to find some to order me, I pick them up tomorrow.
No photos will be necessary. I have a photo of that from a busa turbo install.
I am very confident that i will have no more problems with the rest of my install.
I should be done by friday.
I'm surprised that no one has showed much interest in my boost project, any way it's going to be way faster than the 40 shot on it now.
THANKS AGAIN.
i'll make sure to send you guys the pics and #'s.

There is no such thing as TOO FAST.
just TOO HIGH.
payday is offline  
post #6 of 15 (permalink) Old 03-20-2007, 12:55 AM
Expert
 
Join Date: May 2001
Location: Boise, Idaho
Motorcycle: badass1000
Posts: 2,401
Re: TURBO Question.

One check valve may not be enough. I had to have two on mine. It would still see too much boost and set off a FI error with only one.
I have heard some people using as many as 3 or 4.
badass1000 is offline  
post #7 of 15 (permalink) Old 03-20-2007, 04:33 AM Thread Starter
Provisional Novice
 
payday's Avatar
 
Join Date: Apr 2005
Location: P.G., MD
Motorcycle: 05/GSX-R1000
Posts: 140
Re: TURBO Question.

One more thing I just read that they put a check valve on the fuel also.
Is this needed too?


and in response to:
badass1000One check valve may not be enough. I had to have two on mine. It would still see too much boost and set off a FI error with only one.
I have heard some people using as many as 3 or 4.

are they all in line or t'd before the MAP.
payday is offline  
post #8 of 15 (permalink) Old 03-20-2007, 11:15 AM
Expert
 
Join Date: May 2001
Location: Boise, Idaho
Motorcycle: badass1000
Posts: 2,401
Re: TURBO Question.

They are all tee'd.
I have never heard of putting a check valve in the fuel line.
badass1000 is offline  
post #9 of 15 (permalink) Old 03-20-2007, 12:28 PM Thread Starter
Provisional Novice
 
payday's Avatar
 
Join Date: Apr 2005
Location: P.G., MD
Motorcycle: 05/GSX-R1000
Posts: 140
Re: TURBO Question.

Hey Taner,

On second thought can you post up the diagram.
payday is offline  
post #10 of 15 (permalink) Old 03-22-2007, 05:46 AM Thread Starter
Provisional Novice
 
payday's Avatar
 
Join Date: Apr 2005
Location: P.G., MD
Motorcycle: 05/GSX-R1000
Posts: 140
Re: TURBO Question.

OK, OK, OK.

HOOKED THE JOINT UP YESTURDAY TRYING NOT TO FORGET ANYTHING.
ADDED COOLANT, THEN THE OIL. LET THE MOTOR TURN OVER A COUPLE TIMES TO GET THE OIL PRIMED. WHILE PRAYING THAT NOTHING WENT WRONG.
NOTE: SHE HAS NOT BEEN STARTED SINCE EARLY JAN.
AND I JUST HAVE THE DUMP PIPE ON, ITS NOT HOOKED TO MY IXIL DUAL CANS YET.
ANYWAY.
WHEN I FINALLY CRANKED IT UP IT SOUNDED LIKE A MONSTER THA HAS BEEN SLEEPING ALL WINTER. ALL I WANTED TO DO WAS GIVE IT GAS TO HEAR ITS POWER THAT WILL HAVE EVERYONE FEARING HER THIS SUMMER.

AND THEN SHE STARTED LEAKING OIL FROM THE TURBO DRAIN AND THE FI LIGHT CAME ON (NOT IN THAT ORDER).
I FABBED UP THE OIL DRAIN CAUSE IT DIDN'T HAVE HOLES TAPPED FOR THE NORMAL FLANGE WITH 2 SCREWS, SO I TAPPED IT MYSELF, BUT IT WAS NOT 100% FLAT OR HAD THAT MUCH SURFACE AREA EITHER.

I WILL ATTEMPT TO FIX THAT TODAY.
AND I WAS WONDERING IF THE PAIR SENSOR THROWS A FI LIGHT.
BETTER YET, ANY BODY REMEMBER THOSE 2 PRONGS TO HIT WITH THE SEFETY PIN TO GET THAT FI CODE TO POP UP.
AND I ONLY USED 1 CHECK VALVE FOR THE MAP. I GOTTA GET SOME MORE HOSE TO RUN THE OTHER ONE.

*** AND I BOUGHT EXTRA CHECK VALVES IF ANYONE NEEDS SOME***

CAUSE I COULD NOT FIND THEM ANYWHERE, SO SOMEONE ELSE MUST HAVE THIS SAME PROBLEM.

OH, AND MY MAP WAS NOT MOUNTED YET. THAT DAMN CABLE WAS WAY TOO SHORT TO FIT WHERE I WANTED TO PUT IT. SO I WILL EITHER EXTEND IT OR PUT IT IN THE INTAKE PLENUM.

* CHECK VALVE ON THAT CRANKCASE TUBE THAT CAME OUT THE BACK OF THE AIR BOX. SO AIR CAN GO IN AND NONE CAN GET OUT.

*CHECK VALVE T'D BEFORE MAP TO LET AIR OUT X1 WILL BE 2 TODAY.

*PAIR HOLES ON VALVE COVER PLUGGED.

*INTERCOOLER WILL BE HERE NEXT WEEK OOOOHHH. YEAH BITCHES THAT'S RIGHT.


TALK TO ME GUYS. !!!!!

There is no such thing as TOO FAST.
just TOO HIGH.
payday is offline  
post #11 of 15 (permalink) Old 03-22-2007, 05:19 PM
Can Never Be Another GDC
 
GSXR6BOY's Avatar
 
Join Date: Nov 2005
Location: Ann Arbor, MI
Motorcycle: 05 GSXR 600 Ann.
Posts: 1,701
Re: TURBO Question.

Sweeeet!
GSXR6BOY is offline  
post #12 of 15 (permalink) Old 03-22-2007, 10:34 PM Thread Starter
Provisional Novice
 
payday's Avatar
 
Join Date: Apr 2005
Location: P.G., MD
Motorcycle: 05/GSX-R1000
Posts: 140
Re: TURBO Question.

Urgent: Help

So Changed The Oil Drain From The Flange With The Two Screws To A Screw In Type Right In The Bottom Of The Turbo

Now Its Spitting Creamy Looking Oil Out The Dump Pipe And It Didnt Do That Yesturday
I Might Have A Little More Oil In It Than Before
Please Tell Me That This Is My Only Problem
Oil Looked Like Coffee With A Lot Of Creamer In It

The Drain Didnt Feel Like It Was Draining Like Yesterday Either

Help..............
payday is offline  
post #13 of 15 (permalink) Old 03-27-2007, 10:43 PM
Expert
 
SmurfOnAGixxer's Avatar
 
Join Date: May 2004
Location: Detroit, MI/Miami/Lake Havasu City, AZ
Motorcycle: 38 Scarab AVS 1800HP, Bikeless until winter
Posts: 2,885
Re: TURBO Question.

If you dont have a scavenger pump, when you brake hard, or the bike sits, you will get some turbo drainback... and it blows out the exhuast side.
SmurfOnAGixxer is offline  
post #14 of 15 (permalink) Old 03-28-2007, 04:30 AM Thread Starter
Provisional Novice
 
payday's Avatar
 
Join Date: Apr 2005
Location: P.G., MD
Motorcycle: 05/GSX-R1000
Posts: 140
Re: TURBO Question.

You didn't see the urgent turbo help: thread.

All problems were solved, and she runs fine, just have to get her tuned.
And I did add a scavenge pump.
payday is offline  
post #15 of 15 (permalink) Old 04-04-2007, 04:56 AM Thread Starter
Provisional Novice
 
payday's Avatar
 
Join Date: Apr 2005
Location: P.G., MD
Motorcycle: 05/GSX-R1000
Posts: 140
Re: TURBO Question.

Question:

Do all you turbo guys prop up your stand so it doesn't lean over as much when on the kick stand. Or is your bike slammed to the point that it almost stand up anyway.

Cause if I don't prop it up, I get oil on my compressor side and even on the filter.
payday is offline  
Sponsored Links
Advertisement
 
Reply

Quick Reply
Message:
Options

Register Now



In order to be able to post messages on the Suzuki GSX-R Motorcycle Forums Gixxer.com forums, you must first register.
Please enter your desired user name, your email address and other required details in the form below.

User Name:
Password
Please enter a password for your user account. Note that passwords are case-sensitive.

Password:


Confirm Password:
Email Address
Please enter a valid email address for yourself.

Email Address:
OR

Log-in










Thread Tools
Show Printable Version Show Printable Version
Email this Page Email this Page
Display Modes
Linear Mode Linear Mode



Posting Rules  
You may post new threads
You may post replies
You may not post attachments
You may not edit your posts

BB code is On
Smilies are On
[IMG] code is On
HTML code is Off
Trackbacks are On
Pingbacks are On
Refbacks are On

 
For the best viewing experience please update your browser to Google Chrome