Muzzle Loader No fire. - Suzuki GSX-R Motorcycle Forums Gixxer.com

 
LinkBack Thread Tools Display Modes
post #1 of 2 (permalink) Old 10-07-2011, 05:52 PM Thread Starter
Amateur
 
firewoodman64's Avatar
 
Join Date: Sep 2011
Location: In the land of Milk and Honey
Motorcycle: 2001 Vulcan Nomad, 2008 Zx6(sold), 2001 Ktm 300, 2003 Ktm 65(Sons), 2007 Ktm 50(Sons), 2006 Ktm 50(Daughters)
Posts: 674
Muzzle Loader No fire.

Anyone ever mess with Muzzleloaders Much???????? I got a new Knight muzzle loader that uses 209 primers and it will not fire. Its like the firing pin will not go out far enough to strick the primer. Any thoughts??????
I have taken it apart dont see anything that would keep it from malfunctioning in the trigger assy. Any Help is greatly appreciated.
firewoodman64 is offline  
Sponsored Links
Advertisement
 
post #2 of 2 (permalink) Old 10-07-2011, 08:33 PM
Amateur
 
kman0066's Avatar
 
Join Date: Feb 2005
Location: Nashville, TN
Motorcycle: 06 &11 ZX-10Rs
Posts: 428
Re: Muzzle Loader No fire.

I'm not familiar with that particular model, but I'll brain dump what I know about troubleshooting muzzle-loaders...which isn't a lot, but I do own one. If the primers are old (open for a long time), they could be bad. Moisture = bad. I assume the primers themselves are not firing off at all? If they are not, then pull the firing pin and spring, check for any grease or obstructions in the assembly, sometimes new fire arms are packed with grease or have a small piece of machined metal that ends up in there. Clean it up really well. If it is firing the primer but not igniting the powder, then it's just cleaning the hole to the chamber with a small wire or perhaps some bad powder(unlikely).

If it's a new to you gun (meaning used) and everything else checks out and you are using new primers, it's possible the spring is worn and needs to be replaced. I troubleshot a Mauser once and after many failed fixes, it ended up being the spring was too weak since it was so old. It was leaving a good dent in the primer, but it wasn't striking it with enough force. A new spring for $5 has got it working like new.

Sorry if it doesn't help.

WERA Expert # 43

2006 ZX-10R - Street/Backup race bike
2011 ZX-10R - Race bike (WERA A Superstock, A Superbike, F1, Open Superstock, WERA Superbike)
kman0066 is offline  
Sponsored Links
Advertisement
 
Reply

Quick Reply
Message:
Options

Register Now



In order to be able to post messages on the Suzuki GSX-R Motorcycle Forums Gixxer.com forums, you must first register.
Please enter your desired user name, your email address and other required details in the form below.

User Name:
Password
Please enter a password for your user account. Note that passwords are case-sensitive.

Password:


Confirm Password:
Email Address
Please enter a valid email address for yourself.

Email Address:
OR

Log-in










Thread Tools
Show Printable Version Show Printable Version
Email this Page Email this Page
Display Modes
Linear Mode Linear Mode



Posting Rules  
You may not post new threads
You may not post replies
You may not post attachments
You may not edit your posts

BB code is On
Smilies are On
[IMG] code is On
HTML code is Off
Trackbacks are On
Pingbacks are On
Refbacks are On

 
For the best viewing experience please update your browser to Google Chrome