93 750 oil pump - Suzuki GSX-R Motorcycle Forums Gixxer.com
 
LinkBack Thread Tools Display Modes
post #1 of 2 (permalink) Old 11-07-2017, 02:16 PM Thread Starter
Track Day Winner
 
racerguy36's Avatar
 
Join Date: Mar 2016
Location: Kingsville, on
Motorcycle: 86 Yamaha Venture, 84 Suzuki GS1150EF x 2, 93 GSXR 750
Posts: 44
Garage
93 750 oil pump

Might sound unusual, however how much torque/tension/resistance should there be on the oil pump shaft once the water pump has been removed?
Found some bright and shinnies in the oil, a little too much to ignore anymore, and when I drained the coolant into a container I came across a few pieces of black metal, a couple as big as a peppercorn. Now, there wasn't a lot in the coolant, and it was not contaminated with oil or vise versa, but there's obviously an issue somewhere. I think I've traced the glittery oil to the cam journals and cam hold downs, they have some marks I don't like, however I've never seen metal in coolant before.
I removed the water pump (without breaking it tyvm) and inspected the impeller etc and have found nothing wrong there.
I've often wondered about an oil flow/pressure issue as previously I've seen different color oils (1 dark 1 light) in different pockets in the head under the valve cover even tho the oil pressure is within spec.
As with our old race car, I was thinking of priming the oil system and confirm good volume/flow from the oil galleries we could see and when trying to turn the oil pump shaft, just about broke my wrist. The drill spun instead of the shaft, I gotta say I wasn't expecting that to happen at all.
Should it spin pretty easily? The pan/filter/sensor are all still in the engine, there can't be any residual pressure inline somewhere is there? Is the pump toast? I really wasn't interested in splitting the cases to confirm what I fear the most, the by-product of splitting the cases is the 750 lump will end up as a paperweight and me looking for a 1000 or 1100 engine for this thing. Maybe 1 of the 1150 ef engines I have in a corner.....
Any suggestions, insight?
I measured the cam journals and lobes, and they are within spec however the journals have lines in them and the cams are close to being out of spec. I don't know what kind of life this old girl had before I got it, but I've been beating her up pretty good for 2 years now. For an $800 basket, it doesn't owe me anything at this point.
Any suggestions are welcome,
thanks
racerguy36 is offline  
Sponsored Links
Advertisement
 
post #2 of 2 (permalink) Old 11-07-2017, 10:24 PM
Juvenile Thinker
 
Bufftester's Avatar
 
Join Date: Mar 2013
Location: University Place, WA
Motorcycle: 1992 GSX-R600W, 1994 GSX-R750WN, 1995 GSX-R750WP, 2001 KX/DX 220 Hybrid, 1995 RMX250, 1999 KLX300R
Posts: 273
Garage
Re: 93 750 oil pump

The oil pump is gear driven off the transmission input shaft via the crank. You can't turn it without turning the crank, don't think your drill would have enough torque to do that. The oil pump drives the water pump, not the other way around. If you have no oil in your coolant, or coolant in your oil, then you have two different issues.
Bufftester is offline  
Sponsored Links
Advertisement
 
Reply

Quick Reply
Message:
Options

Register Now



In order to be able to post messages on the Suzuki GSX-R Motorcycle Forums Gixxer.com forums, you must first register.
Please enter your desired user name, your email address and other required details in the form below.

User Name:
Password
Please enter a password for your user account. Note that passwords are case-sensitive.

Password:


Confirm Password:
Email Address
Please enter a valid email address for yourself.

Email Address:
OR

Log-in










Thread Tools
Show Printable Version Show Printable Version
Email this Page Email this Page
Display Modes
Linear Mode Linear Mode



Posting Rules  
You may post new threads
You may post replies
You may not post attachments
You may not edit your posts

BB code is On
Smilies are On
[IMG] code is On
HTML code is Off
Trackbacks are On
Pingbacks are On
Refbacks are On

 
For the best viewing experience please update your browser to Google Chrome