Random engine shut down on my 04 gixxer 750 - Suzuki GSX-R Motorcycle Forums Gixxer.com

 
LinkBack Thread Tools Display Modes
post #1 of 7 (permalink) Old 03-25-2010, 08:43 PM Thread Starter
Squid
 
Join Date: Mar 2010
Location: Littleton, CO
Motorcycle: 2004 GSX-R 750
Posts: 6
Exclamation Random engine shut down on my 04 gixxer 750

Hello all, this is AngryWasp reporting in. I just bought my first gsx-r 750 and sadly already ran into what could become a large issue with my motor. I was recently riding home from dinner, when my check oil light flashed, my engine dove into the lower rpms until it eventually shut off while in motion. I am not sure if there is oil delivery issues with the oil pump in the 04 750 motor, or a sensor issue. So being new to this motor, I wanted to know if you guys on here know what could cause this, and if i need to worry about laying down the big bucks to repair it.

EDIT: It started right back up, and it ran perfect the rest of the way home.

Thanks for all imput and hope you all take me in as a fellow gixxer rider.

AngryWasp reporting in from the rocky mountains colorado.

Last edited by AngryWasp; 03-25-2010 at 09:01 PM.
AngryWasp is offline  
Sponsored Links
Advertisement
 
post #2 of 7 (permalink) Old 03-25-2010, 09:40 PM
Squid
 
Join Date: Feb 2010
Location: Anoka, MN
Motorcycle: 05 GSXR 600
Posts: 17
Re: Random engine shut down on my 04 gixxer 750

I would imagine if it started right up and ran perfect afterwards, I would look more towards a pressure sensor... Usually if an oil pump goes bad, it just goes bad and that's it. My advice would be to find someone with a oil pressure test kit (sometimes auto parts stores rent specialty tools too), run it to operating temp, and verify proper oil pressure. Did it rattle/make any noises when the light came on? Hopefully that's all that it needs, Good Luck!
Matt05 is offline  
post #3 of 7 (permalink) Old 03-25-2010, 09:48 PM Thread Starter
Squid
 
Join Date: Mar 2010
Location: Littleton, CO
Motorcycle: 2004 GSX-R 750
Posts: 6
Re: Random engine shut down on my 04 gixxer 750

No noises, just light, motor ran down and shut off...then it started back up. Thanks for the advice
AngryWasp is offline  
Sponsored Links
Advertisement
 
post #4 of 7 (permalink) Old 03-25-2010, 09:53 PM
Squid
 
Join Date: Feb 2010
Location: Anoka, MN
Motorcycle: 05 GSXR 600
Posts: 17
Re: Random engine shut down on my 04 gixxer 750

I'm admittedly pretty new to these bikes, but usually, when an engine looses oil pressure, they clatter like hell. Sounds more like a sensor malfunction to me, but I would def. test to be sure. Hopefully you got lucky!
Matt05 is offline  
post #5 of 7 (permalink) Old 03-25-2010, 10:03 PM Thread Starter
Squid
 
Join Date: Mar 2010
Location: Littleton, CO
Motorcycle: 2004 GSX-R 750
Posts: 6
Re: Random engine shut down on my 04 gixxer 750

Yup me too, thanks ahah
AngryWasp is offline  
post #6 of 7 (permalink) Old 03-28-2010, 05:49 PM
Track Day Winner
 
madmaxse-l's Avatar
 
Join Date: Dec 2009
Location: Lakeland, Fl
Motorcycle: K4 GSXR 750
Posts: 85
Re: Random engine shut down on my 04 gixxer 750

Mine did this same thing when I bought it(k4 750). Matter of fact, when I took it for the first spin after I took it off the trailer, it shut off in the first 2 miles, little red light came on too. Pulled off the road and started it back up and made it home. It did this maybe 5 times over the next week and it has not done it since then. That was over 5 months ago and it has yet to do it again so I haven't changed anything.

I never noticed any increased noise or anything when it shut off though...
madmaxse-l is offline  
post #7 of 7 (permalink) Old 04-13-2010, 10:47 PM
Squid
 
Join Date: Apr 2010
Posts: 2
Re: Random engine shut down on my 04 gixxer 750

i have a 98 gsxr 600 that i just bought and mine is idling kind of high, and when i have it adjusted to where it is settling down, the red oil light comes on and it shuts off.. it starts right back up with a tiny tiny tweak of the throttle.... what is it suppose to idle at? right now if it goes below 2000 rpms the light will come on and not really stall out but more like just shut off... no weird noises nothing like that.. bike runs/ drives great, just after i come to a stop it will shut down when rpms get low...please helpp,, im going to change my oil, all pligs are new, no vacume leaks and carbs completely cleaned now... i dont think its been done for a while
jsviper2 is offline  
Sponsored Links
Advertisement
 
Reply

Quick Reply
Message:
Options

Register Now



In order to be able to post messages on the Suzuki GSX-R Motorcycle Forums Gixxer.com forums, you must first register.
Please enter your desired user name, your email address and other required details in the form below.

User Name:
Password
Please enter a password for your user account. Note that passwords are case-sensitive.

Password:


Confirm Password:
Email Address
Please enter a valid email address for yourself.

Email Address:
OR

Log-in










Thread Tools
Show Printable Version Show Printable Version
Email this Page Email this Page
Display Modes
Linear Mode Linear Mode



Posting Rules  
You may post new threads
You may post replies
You may not post attachments
You may not edit your posts

BB code is On
Smilies are On
[IMG] code is On
HTML code is Off
Trackbacks are On
Pingbacks are On
Refbacks are On

 
For the best viewing experience please update your browser to Google Chrome