Secondary injectors not working - Suzuki GSX-R Motorcycle Forums Gixxer.com
 
LinkBack Thread Tools Display Modes
post #1 of 10 (permalink) Old 07-02-2018, 04:06 AM Thread Starter
Squid
 
Join Date: Feb 2016
Posts: 4
Secondary injectors not working

Morning all.

I'm having a really strange technical problem...

The engine is running super smooth on part throttle up to about 8000 rpm, after that it really bogs down (it does the same if I open the throttle right up) and I'm 99% sure the secondary injectors aren't firing.

The injectors are defiantly not faulty (I've tried them op a battery) and the fuel pressure is fine.

Has anyone experienced anything like this before and got any advice? I'm totally stuck!

Ben
benners05 is offline  
Sponsored Links
Advertisement
 
post #2 of 10 (permalink) Old 07-02-2018, 04:27 AM
Married his Fleshlight... And Also touches people in a "special" way
 
Join Date: Feb 2016
Posts: 865
Re: Secondary injectors not working

My 750 wouldn't rev past 8k when i bought it. It turns out one of the secondary injectors failed and wasn't opening but it was enough to severely effect performance.

Have you confirmed all the injectors are firing


Also perform a fuel flow test on the fuel pump to rule that out.

Sent from my SM-G900I using Tapatalk
bentoverhard69 is online now  
post #3 of 10 (permalink) Old 07-02-2018, 09:39 AM
Dreaming of buttsecks for years...
 
TheGeek's Avatar
 
Join Date: Feb 2006
Location: Indiana
Motorcycle: Anniversary Edition 600 & 2018 Harley Street Glide
Posts: 13,348
Garage
Re: Secondary injectors not working

Sounds more like fuel pump than injectors to me.....
TheGeek is offline  
Sponsored Links
Advertisement
 
post #4 of 10 (permalink) Old 07-02-2018, 04:47 PM
You should listen to me. No, seriously, listen to me.
 
Join Date: Oct 2008
Location: Santa Barbara
Motorcycle: Blue 2006 GSX-R1000
Posts: 7,500
Re: Secondary injectors not working

The main filter in the pump is suspect. Do the flow test. Pray that you have a K7 or later.
BillV is offline  
post #5 of 10 (permalink) Old 07-03-2018, 06:41 AM Thread Starter
Squid
 
Join Date: Feb 2016
Posts: 4
Re: Secondary injectors not working

Hi, I checked the fuel pressure last night ant it was good (43 psi) how do you do a flow test?
benners05 is offline  
post #6 of 10 (permalink) Old 07-03-2018, 10:29 AM
Squid
 
Join Date: Aug 2013
Posts: 5
Re: Secondary injectors not working

Ok, maybe not the same but different if that make any sense, I was over at my tuning guys house helping him work on a home built long travel buggy that had a similar issue (08 GSX-R 1000 w/06 harness and ECU). If you revved it to 8 grand or so it would start to missfire and do all sorts of weird shit, we tried everything then totally by accident the cam sensor came unplugged while running it (on his chassis dyno) and it revved all the way to the rev limiter with no problems at all. He ended up putting a switch in the harness to cut the cam signal once it is running...

I had a similar problem on my race car Mini sprint w/08 GSX-R and cut down harness when my side stand switch messed up, car ran to 7 Gs no problem but no more then after trouble shooting for a day I found my side-stand switch was not working correctly and put a new one in and fixed!

I hope that sheds some light on new direction to go in when trouble shooting. Good luck!
torkman15 is offline  
post #7 of 10 (permalink) Old 07-03-2018, 12:06 PM
You should listen to me. No, seriously, listen to me.
 
Join Date: Oct 2008
Location: Santa Barbara
Motorcycle: Blue 2006 GSX-R1000
Posts: 7,500
Re: Secondary injectors not working

Search for Fuel Discharge Amount Inspection in the service manual. The page varies depending on the year. Alternately you can leave the pressure gauge connected while you ride in conditions where it bogs down to check what the pressure is then. But that's generally complicated to hook up and dangerous to do.

The side-stand switch is another well known problem area but it's more associated with erratic operation instead of bogging down, i.e. it trips, oftentimes only briefly, the interlock relay. This cuts the power to the ECM, ignition coils, and fuel pump relay, which in turn cuts power to the injectors and fuel pump.
BillV is offline  
post #8 of 10 (permalink) Old 07-13-2018, 02:28 AM Thread Starter
Squid
 
Join Date: Feb 2016
Posts: 4
Re: Secondary injectors not working

Thanks guys, tried all of the above and still doing it. I've put an AFR gauge on it too and it is definitely fuel, as soon as it reaches the point on the map where the 2nd injectors open it goes mega lean. Will be back in the garage tomorrow in search of a solution!
benners05 is offline  
post #9 of 10 (permalink) Old 07-13-2018, 12:34 PM
You should listen to me. No, seriously, listen to me.
 
Join Date: Oct 2008
Location: Santa Barbara
Motorcycle: Blue 2006 GSX-R1000
Posts: 7,500
Re: Secondary injectors not working

What rate did you measure during the flow test? You could try swapping the primary and secondary injectors but it seems a bit of a stretch that the secondaries are clogged while the primaries are OK. Make sure the fuel line isn't kinked. Are the secondaries getting power?
BillV is offline  
post #10 of 10 (permalink) Old 07-14-2018, 08:02 AM
Dreaming of buttsecks for years...
 
TheGeek's Avatar
 
Join Date: Feb 2006
Location: Indiana
Motorcycle: Anniversary Edition 600 & 2018 Harley Street Glide
Posts: 13,348
Garage
Re: Secondary injectors not working

I would assume if the secondary injectors had an electrical problem, the self-diagnostic would see it and give an FI code.
TheGeek is offline  
Sponsored Links
Advertisement
 
Reply

Quick Reply
Message:
Options

Register Now



In order to be able to post messages on the Suzuki GSX-R Motorcycle Forums Gixxer.com forums, you must first register.
Please enter your desired user name, your email address and other required details in the form below.

User Name:
Password
Please enter a password for your user account. Note that passwords are case-sensitive.

Password:


Confirm Password:
Email Address
Please enter a valid email address for yourself.

Email Address:
OR

Log-in










Thread Tools
Show Printable Version Show Printable Version
Email this Page Email this Page
Display Modes
Linear Mode Linear Mode



Posting Rules  
You may post new threads
You may post replies
You may not post attachments
You may not edit your posts

BB code is On
Smilies are On
[IMG] code is On
HTML code is Off
Trackbacks are On
Pingbacks are On
Refbacks are On

 
For the best viewing experience please update your browser to Google Chrome