What in the world is wrong with my fuel pump - Suzuki GSX-R Motorcycle Forums Gixxer.com
 1Likes
  • 1 Post By dpapavas
 
LinkBack Thread Tools Display Modes
post #1 of 8 (permalink) Old 11-03-2017, 12:40 PM Thread Starter
Amateur
 
Join Date: Mar 2017
Motorcycle: 2006 GSXR 1000
Posts: 349
Garage
What in the world is wrong with my fuel pump

2006 gsxr 1000.

About 1000 miles on new fuel pump, its a generic one. I got it because of bad fuel flow I had, changed the pump and cleaned the filter and fuel flow is fine now. this just started about a week ago. Sometimes it sounds worse sometimes its not there ever. It also only happens after sitting over night or for a while, like when I'm at work. If I start it over and over within a few hours it will sound normal. I primed it twice in this video below and the first time you can hear it, it sounds like its sputtering or getting air in the system, then I prime again and its fine. one time I primed twice and it still made that sound.

Note* it will still start without hesitation on the first turn over even with that sound.



fastfedd is offline  
Sponsored Links
Advertisement
 
post #2 of 8 (permalink) Old 11-03-2017, 04:18 PM
You should listen to me. No, seriously, listen to me.
 
Join Date: Oct 2008
Location: Santa Barbara
Motorcycle: Blue 2006 GSX-R1000
Posts: 7,514
Re: What in the world is wrong with my fuel pump

Are you sure that it's coming from the pump and not something else like the EXCVA, STVA, or fuel pump relay?
BillV is offline  
post #3 of 8 (permalink) Old 11-03-2017, 04:24 PM Thread Starter
Amateur
 
Join Date: Mar 2017
Motorcycle: 2006 GSXR 1000
Posts: 349
Garage
Re: What in the world is wrong with my fuel pump

you heard it in that video? I'm willing to bet its the pump, besides does the EXCVA OR STVA stay off until I turn the kill switch on?
fastfedd is offline  
Sponsored Links
Advertisement
 
post #4 of 8 (permalink) Old 11-03-2017, 05:49 PM
You should listen to me. No, seriously, listen to me.
 
Join Date: Oct 2008
Location: Santa Barbara
Motorcycle: Blue 2006 GSX-R1000
Posts: 7,514
Re: What in the world is wrong with my fuel pump

I heard something but it was somewhat obscured by the background noise. The EXCVA and STVA, like the fuel pump, go through a start-up routine when the ECM gets power. That happens when both the ignition and kill switches are turned on.
BillV is offline  
post #5 of 8 (permalink) Old 11-06-2017, 08:47 AM
I know things... A lot of things.
 
Join Date: Feb 2015
Motorcycle: GSXR 750 K4
Posts: 3,060
Re: What in the world is wrong with my fuel pump

That sounds like the STVA clicking against the stops to me. I wonder why it only does it only sometimes, but it probably has something to do with the angle of the blades when the start-up routine starts. During the first cycle, for instance, they were probably closed from last shutdown, while on the second they were left wide open from the first cycle and, apparently, the ECM didn't bother re-cycling them. I haven't noticed such behavior on my K4, but, then again, I don't usually cycle power more than once before starting the engine.
dpapavas is offline  
post #6 of 8 (permalink) Old 11-06-2017, 02:18 PM
Dreaming of buttsecks for years...
 
TheGeek's Avatar
 
Join Date: Feb 2006
Location: Indiana
Motorcycle: Anniversary Edition 600 & 2018 Harley Street Glide
Posts: 13,358
Garage
Re: What in the world is wrong with my fuel pump

I'm in total agreement that it sounds like the STVA.... but it shouldn't sound like that.
TheGeek is offline  
post #7 of 8 (permalink) Old 11-08-2017, 09:51 AM
I know things... A lot of things.
 
Join Date: Feb 2015
Motorcycle: GSXR 750 K4
Posts: 3,060
Re: What in the world is wrong with my fuel pump

Yes, it does bang a bit more than usual. Badly adjusted STPS perhaps? Or maybe something's wrong with the fast-idle linkage. A video of the operation of the linkage (visible on the left side of the throttle body) during startup, might show something interesting.
TheGeek likes this.
dpapavas is offline  
post #8 of 8 (permalink) Old 11-08-2017, 03:12 PM Thread Starter
Amateur
 
Join Date: Mar 2017
Motorcycle: 2006 GSXR 1000
Posts: 349
Garage
Re: What in the world is wrong with my fuel pump

It's been about 3-4 days now and it hasn't done it since. So I'm not sure maybe you guys were right and it wasn't the fuel pump. bike (knocks on wood) is running great
fastfedd is offline  
Sponsored Links
Advertisement
 
Reply

Quick Reply
Message:
Options

Register Now



In order to be able to post messages on the Suzuki GSX-R Motorcycle Forums Gixxer.com forums, you must first register.
Please enter your desired user name, your email address and other required details in the form below.

User Name:
Password
Please enter a password for your user account. Note that passwords are case-sensitive.

Password:


Confirm Password:
Email Address
Please enter a valid email address for yourself.

Email Address:
OR

Log-in










Thread Tools
Show Printable Version Show Printable Version
Email this Page Email this Page
Display Modes
Linear Mode Linear Mode



Posting Rules  
You may post new threads
You may post replies
You may not post attachments
You may not edit your posts

BB code is On
Smilies are On
[IMG] code is On
HTML code is Off
Trackbacks are On
Pingbacks are On
Refbacks are On

 
For the best viewing experience please update your browser to Google Chrome