Gsxr1000 k8 intermittent cluster issues - Suzuki GSX-R Motorcycle Forums Gixxer.com
 1Likes
  • 1 Post By dpapavas
 
LinkBack Thread Tools Display Modes
post #1 of 9 (permalink) Old 04-08-2017, 03:54 PM Thread Starter
Squid
 
Join Date: Apr 2017
Posts: 4
Gsxr1000 k8 intermittent cluster issues

Hi folks.

Being new to this I've had a look at past posts and the issue I have is similiar to some comments/posts, Although for some reason not quite the same problem as I'm having I have a gsxr1000 k8.
All lights,indicators,hazards,horn,,killswitch, etc all work but the rev counter and digital speedo don't...If I disconnect the battery or the speedo unit then reconnect it, it works until the bike is switched back off,although this varies from 1hr to 1day,
i have checked all fuses and cleaned the miltiplug behind left hand fairing,The bike has been into local bike garage and they have found no faults on diagnostic machine..ANY IDEAS ??? I would be eternally grateful.
Gixerboy72 is offline  
Sponsored Links
Advertisement
 
post #2 of 9 (permalink) Old 04-08-2017, 04:57 PM
IM THE BRONZE
 
Join Date: Apr 2008
Posts: 1,336
Re: Gsxr1000 k8 intermittent cluster issues

I'd also look at all your ECM connections. Get a wiring diagram and see which wires might be the culprit.
Geesxara is offline  
post #3 of 9 (permalink) Old 04-08-2017, 06:27 PM
You should listen to me. No, seriously, listen to me.
 
Join Date: Oct 2008
Location: Santa Barbara
Motorcycle: Blue 2006 GSX-R1000
Posts: 7,514
Re: Gsxr1000 k8 intermittent cluster issues

How have you checked the fuses with an ohmmeter?

"If I disconnect the battery or the speedo unit then reconnect it, it works until the bike is switched back off,although this varies from 1hr to 1day,"

That sounds like it's working OK. Where's the problem? Or are you saying that when you switch it off and later back on, the tach and speedo don't work unless you disconnect and reconnect that battery. What about the temperature display? You say that the indicators work. Does that include the gear indicator? I think that you need to be more specific about exactly what is happening.

With the bike turned completely off, disconnect the battery (pos or neg terminal is enough). Wait a minute and reconnect, watching the cluster as you do. Does anything happen?
BillV is offline  
Sponsored Links
Advertisement
 
post #4 of 9 (permalink) Old 04-10-2017, 11:37 AM Thread Starter
Squid
 
Join Date: Apr 2017
Posts: 4
Re: Gsxr1000 k8 intermittent cluster issues

Thanks for replying.

Sorry I didn't explain it that great, when I go out to take out the bike I have no speedo/rev counter and when I disconnect the battery or the speedo and reconnect it all works fine for the limited time I mentioned, temp gauge gear shift the full works.....Also having watched the speedo/ rev counter when I'm connecting the battery the rev counter does the sweep round and back again. oh and all fuses are fine.
Gixerboy72 is offline  
post #5 of 9 (permalink) Old 04-11-2017, 08:31 AM
I know things... A lot of things.
 
Join Date: Feb 2015
Motorcycle: GSXR 750 K4
Posts: 3,060
Re: Gsxr1000 k8 intermittent cluster issues

Sounds to me like an internal fault in the instrument cluster...
Gixerboy72 likes this.
dpapavas is offline  
post #6 of 9 (permalink) Old 04-11-2017, 02:32 PM Thread Starter
Squid
 
Join Date: Apr 2017
Posts: 4
Re: Gsxr1000 k8 intermittent cluster issues

I'll have a look on Friday off for Easter weekend.....that'll please the good lady..Easter in the garage....lol
Gixerboy72 is offline  
post #7 of 9 (permalink) Old 04-11-2017, 02:53 PM
IM THE BRONZE
 
Join Date: Apr 2008
Posts: 1,336
Re: Gsxr1000 k8 intermittent cluster issues

Quote:
Originally Posted by Gixerboy72 View Post
I'll have a look on Friday off for Easter weekend.....that'll please the good lady..Easter in the garage....lol
I got 99 problems but a beatch aint one.
Maybe thats why my bikes run perfectly.
Geesxara is offline  
post #8 of 9 (permalink) Old 04-15-2017, 05:01 PM Thread Starter
Squid
 
Join Date: Apr 2017
Posts: 4
Re: Gsxr1000 k8 intermittent cluster issues

Yep your bang on the cluster has gone to the old parts bin in the sky.. Hay ho at least a new ones not that dear only 600.78p in good old u.k....hay ho...I think I'll check ebay.com.
Gixerboy72 is offline  
post #9 of 9 (permalink) Old 04-15-2017, 08:12 PM
You should listen to me. No, seriously, listen to me.
 
Join Date: Oct 2008
Location: Santa Barbara
Motorcycle: Blue 2006 GSX-R1000
Posts: 7,514
Re: Gsxr1000 k8 intermittent cluster issues

You could ask someone like BLUEGAUGES.COM if it's worth his taking a look at it. Another that's probably closer to you is Carmo Electronics.
BillV is offline  
Sponsored Links
Advertisement
 
Reply

Quick Reply
Message:
Options

Register Now



In order to be able to post messages on the Suzuki GSX-R Motorcycle Forums Gixxer.com forums, you must first register.
Please enter your desired user name, your email address and other required details in the form below.

User Name:
Password
Please enter a password for your user account. Note that passwords are case-sensitive.

Password:


Confirm Password:
Email Address
Please enter a valid email address for yourself.

Email Address:
OR

Log-in










Thread Tools
Show Printable Version Show Printable Version
Email this Page Email this Page
Display Modes
Linear Mode Linear Mode



Posting Rules  
You may post new threads
You may post replies
You may not post attachments
You may not edit your posts

BB code is On
Smilies are On
[IMG] code is On
HTML code is Off
Trackbacks are On
Pingbacks are On
Refbacks are On

 
For the best viewing experience please update your browser to Google Chrome