06 GSXR 600 Cluster Not Working : Suzuki GSX-R Motorcycle Forums: Gixxer.com
» Insurance
» Suzuki GSX-R Prices
» Sponsors
Go Back   Suzuki GSX-R Motorcycle Forums Gixxer.com > Gixxer Forums > GSX-R600 / GSX-R750 General forum > 06-07 GSX-R600/750

Reply
 
Thread Tools Search this Thread Display Modes
Old 11-30-2012, 09:15 AM   #1
Cardonaic
Squid
 
Join Date: Nov 2012
Location: Dallas
Motorcycle: 06 GSXR 600
Posts: 1
06 GSXR 600 Cluster Not Working

I have a 2006 GSXR 600 with about 30k. While riding the cluster went out. The only thing that lights up is the high beam indicater and the RPM needle goes up and then down. I replaced the cluster and it does the same thing. I pulled of the wiring harness that has all the light socket conectors on it and it looks to be in tack. Is there anything else it could check before taking it to a shop? Thanks in advance.

Bike starts so battery is good and all fuses are good.
Cardonaic is offline   Reply With Quote
Sponsored Links
Advertisement
 
Old 11-30-2012, 09:40 AM   #2
oldgixxer
Loves to nibble on Shannons huge boobs
 
oldgixxer's Avatar
 
Join Date: Jan 2001
Location: Orange County,N.Y.
Motorcycle: None, gave them all to Anthony D...
Posts: 15,122
Re: 06 GSXR 600 Cluster Not Working

Please get familiar with the forum so you know which section to post in....thread moved
oldgixxer is offline   Reply With Quote
Old 11-30-2012, 10:11 AM   #3
rv6john
Club Racer
 
Join Date: Mar 2010
Location: Western North Carolina
Motorcycle: GSXR 750K6, 2007 Kawasaki Z1000, Aprilia SXV550, DR650
Posts: 1,744
Re: 06 GSXR 600 Cluster Not Working

It sure sounds like a wiring problem. There is a wiring diagram in the back of the service manual. If you don't have one yet, download it at www.servicemanualsgsxr.com.

I would check that you have power at the O/G wire at the cluster connector and check continuity between the cluster and the ECU.
rv6john is offline   Reply With Quote
Sponsored Links
Advertisement
 
Reply

Thread Tools Search this Thread
Search this Thread:

Advanced Search
Display Modes

Posting Rules
You may not post new threads
You may not post replies
You may not post attachments
You may not edit your posts

BB code is On
Smilies are On
[IMG] code is On
HTML code is Off

Forum Jump

Powered by vBadvanced CMPS v3.2.2

All times are GMT -5. The time now is 06:07 PM.



Powered by vBulletin® Copyright ©2000 - 2014, Jelsoft Enterprises Ltd.
Copyright 2008 2013 Gixxer.com
Motorcycle News, Videos and Reviews
Honda Grom Forum Harley Davidson Forum Honda 600RR Kawasaki Forum Yamaha R6 Forum Yamaha FZ-09 Forum
1199 Panigale Forum Roadglide Forum Honda CBR1000 Forum Vulcan Forum Yamaha R1 Forum Yamaha R3 Forum
Ducati Monster Forum Harley Forums Honda CBR250R Forum ZX10R Forum Star Raider Forum Yamaha Viking Forum
Suzuki GSXR Forum V-Rod Forums Honda Shadow Forum Kawasaki Motorcycle Forum Star Warrior Forum KTM Duke 390 Forum
SV650 Forum BMW S1000RR Forum Honda Fury Forum Kawasaki Versys Forum Drag Racing Forum Ducati 899 Panigale Forum
Suzuki V-Strom BMW K1600 Triumph Forum Victory Forums Sportbikes BMW NineT Forum
Volusia Forum BMW F800 Forum Triumph 675 Forum MV Agusta Forum HD Street Forum Suzuki GW250 Forum
Yamaha Motorcycles Victory Gunner Forum Honda Vultus Forum HD LiveWire Forum Ninja H2 Forum Ducati Scrambler Forum